From: Joe Perches <joe@perches.com>
To: Martin Kaiser <martin@kaiser.cx>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: Larry Finger <Larry.Finger@lwfinger.net>,
Phillip Potter <phil@philpotter.co.uk>,
Michael Straube <straube.linux@gmail.com>,
linux-staging@lists.linux.dev, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 4/7] staging: r8188eu: replace if with ternary operator
Date: Sat, 14 May 2022 10:54:45 -0700 [thread overview]
Message-ID: <b69cd7d3f0e3b62c5ef12cd1b98eac45f56022a4.camel@perches.com> (raw)
In-Reply-To: <20220514164740.282552-5-martin@kaiser.cx>
On Sat, 2022-05-14 at 18:47 +0200, Martin Kaiser wrote:
> Replace an if statement with a ternary operator, making the code a tiny
> bit shorter.
[]
> diff --git a/drivers/staging/r8188eu/core/rtw_mlme_ext.c b/drivers/staging/r8188eu/core/rtw_mlme_ext.c
[]
> @@ -1503,10 +1503,8 @@ unsigned int OnAction_back(struct adapter *padapter, struct recv_frame *precv_fr
> preorder_ctrl->indicate_seq = 0xffff;
> preorder_ctrl->enable = pmlmeinfo->bAcceptAddbaReq;
>
> - if (pmlmeinfo->bAcceptAddbaReq)
> - issue_action_BA(padapter, mgmt->sa, WLAN_ACTION_ADDBA_RESP, 0);
> - else
> - issue_action_BA(padapter, mgmt->sa, WLAN_ACTION_ADDBA_RESP, 37);/* reject ADDBA Req */
> + issue_action_BA(padapter, mgmt->sa, WLAN_ACTION_ADDBA_RESP,
> + pmlmeinfo->bAcceptAddbaReq ? 0 : 37);
Seems like magic numbers. Maybe add/use defines?
next prev parent reply other threads:[~2022-05-14 17:58 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-05-14 16:47 [PATCH 0/7] staging: r8188eu: more cleanups in OnAction_back Martin Kaiser
2022-05-14 16:47 ` [PATCH 1/7] staging: r8188eu: get addba resp status from ieee80211_mgmt Martin Kaiser
2022-05-14 16:47 ` [PATCH 2/7] staging: r8188eu: read addba resp tid " Martin Kaiser
2022-05-14 16:47 ` [PATCH 3/7] staging: r8188eu: merge process_addba_req into OnAction_back Martin Kaiser
2022-05-14 16:47 ` [PATCH 4/7] staging: r8188eu: replace if with ternary operator Martin Kaiser
2022-05-14 17:54 ` Joe Perches [this message]
2022-05-14 16:47 ` [PATCH 5/7] staging: r8188eu: use BIT(tid) instead of manual shift Martin Kaiser
2022-05-14 16:47 ` [PATCH 6/7] staging: r8188eu: check for initiator vs recipient Martin Kaiser
2022-05-14 16:47 ` [PATCH 7/7] staging: r8188eu: use the tid in delba processing Martin Kaiser
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=b69cd7d3f0e3b62c5ef12cd1b98eac45f56022a4.camel@perches.com \
--to=joe@perches.com \
--cc=Larry.Finger@lwfinger.net \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-staging@lists.linux.dev \
--cc=martin@kaiser.cx \
--cc=phil@philpotter.co.uk \
--cc=straube.linux@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®