From: Swamil Jain <s-jain1@ti.com>
To: <aradhya.bhatia@linux.dev>, <devarsht@ti.com>,
<mripard@kernel.org>, <tomi.valkeinen@ideasonboard.com>,
<jyri.sarha@iki.fi>, <maarten.lankhorst@linux.intel.com>,
<simona@ffwll.ch>, <airlied@gmail.com>, <tzimmermann@suse.de>,
<h-shenoy@ti.com>
Cc: <praneeth@ti.com>, <u-kumar1@ti.com>, <vigneshr@ti.com>,
<dri-devel@lists.freedesktop.org>, <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v7 0/2] Decouple max/min_pclk_khz check from constant display feats
Date: Tue, 28 Oct 2025 08:58:02 +0530 [thread overview]
Message-ID: <b6ce2b26-d941-4620-9544-e72d1d3d0d73@ti.com> (raw)
In-Reply-To: <20251027212624.359235-1-s-jain1@ti.com>
On 28-10-2025 02:56, Swamil Jain wrote:
> In an effort to make the existing compatibles more usable, we are
> removing the max/min_pclk_khz form dispc_features structure and doing
> the supported pixel clock checks using clk_round_rate().
>
> Changes are fully backwards compatible.
>
> - Remove max/min_pclk_khz and use clk_round_rate to validate modes
> - Skip OLDI mode validate through dispc_vp_mode_valid and add
> mode_valid hook to validate modes for OLDI bridge in tidss_oldi.c
>
> ---
NACK. I will resend v7 with some modifications in the cover letter.
Regards,
Swamil> Changelog v6->v7
> - Remove both max/min_pclk_khz as suggested by Tomi
> - Use mode_valid() instead of atomic_check()
> - Squash patches v6 PATCH 1/3 and PATCH 2/3 which is a fix to OLDI
> series[1]
> - Minor fixes in commit message
> - Update comments to include more reasoning to add Fixes tag to
> Patch v7 2/2
>
> [1]: https://lore.kernel.org/all/20250528122544.817829-1-aradhya.bhatia@linux.dev/
>
> v6 patch link:
> https://lore.kernel.org/all/20250911110715.2873596-1-s-jain1@ti.com/
>
> Changelog v5->v6
> - Drop caching logic
> - Add comments for tolerance value
> (We are targeting another series for reducing tolerance value)
> - Minor fixes in commit message
>
> v5 patch link:
> https://lore.kernel.org/all/20250819192113.2420396-1-s-jain1@ti.com/
>
> Changelog v4->v5
> - Rename is_oldi_vp[] to is_ext_vp_clk[]
> - Store both pixel clock round_rate and attempted_rate to reduce
> clk_round_rate() calls while validating modes
> - Code changes suggested by Tomi[2]
> - Minor fixes in comments and commit message
>
> [2]: https://lore.kernel.org/all/8cd9d1c4-2e9f-4766-b224-21925c4f991d@ideasonboard.com/
>
> v4 patch link:
> https://lore.kernel.org/all/20250704094851.182131-1-j-choudhary@ti.com/
>
> Changelog v3->v4:
> - Minor cosmetic fixes in code, comments and commit message
> - Pick up R-by and add Fixes tag
>
> v3 patch link:
> https://lore.kernel.org/all/20250701095541.190422-1-j-choudhary@ti.com/
>
> Changelog v2->v3:
> - Add changes for OLDI
> - Rename max_pclk as it is misleading
> - Change commit message to make it more appropriate
> - Drop unnecessary zero initialization
>
> v2 patch link:
> https://lore.kernel.org/all/20250618100509.20386-1-j-choudhary@ti.com/
>
> Changelog v1->v2:
> - Rebase it on linux-next after OLDI support series as all of its
> patches are reviewed and tested and it touches one of the functions
> used.
>
> v1 patch link:
> https://lore.kernel.org/all/20250618075804.139844-1-j-choudhary@ti.com/
>
> ---
> Jayesh Choudhary (2):
> drm/tidss: Remove max_pclk_khz and min_pclk_khz from tidss display
> features
> drm/tidss: Move OLDI mode validation to OLDI bridge mode_valid hook
>
> drivers/gpu/drm/tidss/tidss_dispc.c | 87 +++++++++++------------------
> drivers/gpu/drm/tidss/tidss_dispc.h | 3 -
> drivers/gpu/drm/tidss/tidss_drv.h | 2 +
> drivers/gpu/drm/tidss/tidss_oldi.c | 21 +++++++
> 4 files changed, 55 insertions(+), 58 deletions(-)
>
prev parent reply other threads:[~2025-10-28 3:28 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-10-27 21:26 Swamil Jain
2025-10-27 21:26 ` [PATCH v7 1/2] drm/tidss: Remove max_pclk_khz and min_pclk_khz from tidss display features Swamil Jain
2025-10-27 21:26 ` [PATCH v7 2/2] drm/tidss: Move OLDI mode validation to OLDI bridge mode_valid hook Swamil Jain
2025-10-28 3:28 ` Swamil Jain [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=b6ce2b26-d941-4620-9544-e72d1d3d0d73@ti.com \
--to=s-jain1@ti.com \
--cc=airlied@gmail.com \
--cc=aradhya.bhatia@linux.dev \
--cc=devarsht@ti.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=h-shenoy@ti.com \
--cc=jyri.sarha@iki.fi \
--cc=linux-kernel@vger.kernel.org \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mripard@kernel.org \
--cc=praneeth@ti.com \
--cc=simona@ffwll.ch \
--cc=tomi.valkeinen@ideasonboard.com \
--cc=tzimmermann@suse.de \
--cc=u-kumar1@ti.com \
--cc=vigneshr@ti.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®