From: Jens Axboe <axboe@kernel.dk>
To: Markus Elfring <Markus.Elfring@web.de>,
linux-nvme@lists.infradead.org, Christoph Hellwig <hch@lst.de>,
Keith Busch <kbusch@kernel.org>, Sagi Grimberg <sagi@grimberg.me>
Cc: kernel-janitors@vger.kernel.org, LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] nvme: One function call less in nvme_update_disk_info()
Date: Fri, 5 Jul 2019 13:35:19 -0600 [thread overview]
Message-ID: <b701a461-4c89-3860-bc99-0662db2382c2@kernel.dk> (raw)
In-Reply-To: <38f864df-9c90-31a3-d78d-7aaf2d726e4f@web.de>
On 7/5/19 1:15 PM, Markus Elfring wrote:
> From: Markus Elfring <elfring@users.sourceforge.net>
> Date: Fri, 5 Jul 2019 21:08:12 +0200
>
> Avoid an extra function call by using a ternary operator instead of
> a conditional statement.
>
> This issue was detected by using the Coccinelle software.
>
> Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
> ---
> drivers/nvme/host/core.c | 5 +----
> 1 file changed, 1 insertion(+), 4 deletions(-)
>
> diff --git a/drivers/nvme/host/core.c b/drivers/nvme/host/core.c
> index b2dd4e391f5c..73888195bdb2 100644
> --- a/drivers/nvme/host/core.c
> +++ b/drivers/nvme/host/core.c
> @@ -1650,10 +1650,7 @@ static void nvme_update_disk_info(struct gendisk *disk,
> nvme_config_discard(disk, ns);
> nvme_config_write_zeroes(disk, ns);
>
> - if (id->nsattr & (1 << 0))
> - set_disk_ro(disk, true);
> - else
> - set_disk_ro(disk, false);
> + set_disk_ro(disk, id->nsattr & (1 << 0) ? true : false);
Let's please not, the original is much more readable.
--
Jens Axboe
prev parent reply other threads:[~2019-07-05 19:35 UTC|newest]
Thread overview: 2+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-07-05 19:15 Markus Elfring
2019-07-05 19:35 ` Jens Axboe [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=b701a461-4c89-3860-bc99-0662db2382c2@kernel.dk \
--to=axboe@kernel.dk \
--cc=Markus.Elfring@web.de \
--cc=hch@lst.de \
--cc=kbusch@kernel.org \
--cc=kernel-janitors@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-nvme@lists.infradead.org \
--cc=sagi@grimberg.me \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®