From: Jason Wang <jasowang@redhat.com>
To: "Michael S. Tsirkin" <mst@redhat.com>
Cc: Al Viro <viro@zeniv.linux.org.uk>,
linux-kernel@vger.kernel.org, netdev@vger.kernel.org
Subject: Re: [PATCH RFC] uaccess: user_access_begin_after_access_ok()
Date: Wed, 3 Jun 2020 14:23:08 +0800 [thread overview]
Message-ID: <b7de29fa-33f2-bbc1-08dc-d73b28e3ded5@redhat.com> (raw)
In-Reply-To: <20200603013600-mutt-send-email-mst@kernel.org>
On 2020/6/3 下午1:46, Michael S. Tsirkin wrote:
> On Wed, Jun 03, 2020 at 01:18:54PM +0800, Jason Wang wrote:
>> On 2020/6/3 下午12:18, Al Viro wrote:
>>> On Wed, Jun 03, 2020 at 11:57:11AM +0800, Jason Wang wrote:
>>>
>>>>> How widely do you hope to stretch the user_access areas, anyway?
>>>> To have best performance for small packets like 64B, if possible, we want to
>>>> disable STAC not only for the metadata access done by vhost accessors but
>>>> also the data access via iov iterator.
>>> If you want to try and convince Linus to go for that, make sure to Cc
>>> me on that thread. Always liked quality flame...
>>>
>>> The same goes for interval tree lookups with uaccess allowed. IOW, I _really_
>>> doubt that it's a good idea.
>>
>> I see. We are just seeking an approach to perform better in order to compete
>> with userspace dpdk backends.
>>
>> I tried another approach of using direct mapping + mmu notifier [1] but the
>> synchronization with MMU notifier is not easy to perform well.
>>
>> [1] https://patchwork.kernel.org/patch/11133009/
>>
>>
>>>>> Incidentally, who had come up with the name __vhost_get_user?
>>>>> Makes for lovey WTF moment for readers - esp. in vhost_put_user()...
>>>> I think the confusion comes since it does not accept userspace pointer (when
>>>> IOTLB is enabled).
>>>>
>>>> How about renaming it as vhost_read()/vhost_write() ?
>>> Huh?
>>>
>>> __vhost_get_user() is IOTLB remapping of userland pointer. It does not access
>>> userland memory. Neither for read, nor for write. It is used by vhost_get_user()
>>> and vhost_put_user().
>>>
>>> Why would you want to rename it into vhost_read _or_ vhost_write, and in any case,
>>> how do you give one function two names? IDGI...
>>
>> I get you know, I thought you're concerning the names of
>> vhost_get_user()/vhost_put_user() but actually __vhost_get_user().
>>
>> Maybe something like __vhost_fetch_uaddr() is better.
>>
>> Thanks
>
> It's basically vhost_translate_uaddr isn't it?
Yes.
>
> BTW now I re-read it I don't understand __vhost_get_user_slow:
>
>
> static void __user *__vhost_get_user_slow(struct vhost_virtqueue *vq,
> void __user *addr, unsigned int size,
> int type)
> {
> int ret;
>
> ret = translate_desc(vq, (u64)(uintptr_t)addr, size, vq->iotlb_iov,
> ARRAY_SIZE(vq->iotlb_iov),
> VHOST_ACCESS_RO);
>
> ..
> }
>
> how does this work? how can we cast a pointer to guest address without
> adding any offsets?
I'm not sure I get you here. What kind of offset did you mean?
Thanks
>
>
next prev parent reply other threads:[~2020-06-03 6:23 UTC|newest]
Thread overview: 37+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-06-02 8:45 Michael S. Tsirkin
2020-06-02 10:15 ` Jason Wang
2020-06-02 16:33 ` Al Viro
2020-06-02 17:18 ` Linus Torvalds
2020-06-02 17:44 ` Al Viro
2020-06-02 17:46 ` Al Viro
2020-06-02 20:32 ` Michael S. Tsirkin
2020-06-02 20:41 ` David Laight
2020-06-02 21:58 ` Al Viro
2020-06-03 8:08 ` David Laight
2020-06-02 20:43 ` Linus Torvalds
2020-06-03 6:01 ` Michael S. Tsirkin
[not found] ` <CAHk-=wi3=QuD30fRq8fYYTj9WmkgeZ0VR_Sh3DQHU+nmwj-jMg@mail.gmail.com>
2020-06-03 16:59 ` Linus Torvalds
2020-06-02 16:30 ` Al Viro
2020-06-02 20:42 ` Michael S. Tsirkin
2020-06-02 22:10 ` Al Viro
2020-06-03 5:17 ` Michael S. Tsirkin
2020-06-03 1:48 ` Al Viro
2020-06-03 3:57 ` Jason Wang
2020-06-03 4:18 ` Al Viro
2020-06-03 5:18 ` Jason Wang
2020-06-03 5:46 ` Michael S. Tsirkin
2020-06-03 6:23 ` Jason Wang [this message]
2020-06-03 6:30 ` Michael S. Tsirkin
2020-06-03 6:36 ` Jason Wang
2020-06-04 16:49 ` Michael S. Tsirkin
2020-06-05 10:03 ` Jason Wang
2020-06-06 20:08 ` Michael S. Tsirkin
2020-06-03 6:25 ` Michael S. Tsirkin
2020-06-03 5:29 ` Michael S. Tsirkin
2020-06-03 16:52 ` Al Viro
2020-06-04 6:10 ` Jason Wang
2020-06-04 14:59 ` Al Viro
2020-06-04 16:46 ` Michael S. Tsirkin
2020-06-04 10:10 ` Michael S. Tsirkin
2020-06-04 15:03 ` Al Viro
2020-06-04 16:47 ` Michael S. Tsirkin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=b7de29fa-33f2-bbc1-08dc-d73b28e3ded5@redhat.com \
--to=jasowang@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mst@redhat.com \
--cc=netdev@vger.kernel.org \
--cc=viro@zeniv.linux.org.uk \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome