From: Len Brown <lenb@kernel.org>
To: linux-acpi@vger.kernel.org, linux-pm@vger.kernel.org
Cc: linux-kernel@vger.kernel.org, Zhang Rui <rui.zhang@intel.com>
Subject: [PATCH 07/30] Thermal: rename structure thermal_cooling_device_instance to thermal_instance
Date: Tue, 9 Oct 2012 01:53:57 -0400 [thread overview]
Message-ID: <b81b6ba3d9ac5feb14388bb73ac5a39d9a7540dc.1349761836.git.len.brown@intel.com> (raw)
In-Reply-To: <1349762060-25334-1-git-send-email-lenb@kernel.org>
In-Reply-To: <e3f25e6e5836c4790fbe395ff42e241f372d859d.1349761836.git.len.brown@intel.com>
From: Zhang Rui <rui.zhang@intel.com>
This struct is used to describe the behavior for a thermal
cooling device on a certain trip point for a certain thremal zone.
thermal_cooling_device_instance is not accurate, as a cooling device
can be used for more than one trip point in one thermal zone device.
Signed-off-by: Zhang Rui <rui.zhang@intel.com>
Reviewed-by: Rafael J. Wysocki <rjw@sisk.pl>
Reviewed-by: Eduardo Valentin <eduardo.valentin@ti.com>
---
drivers/thermal/thermal_sys.c | 18 +++++++++---------
1 file changed, 9 insertions(+), 9 deletions(-)
diff --git a/drivers/thermal/thermal_sys.c b/drivers/thermal/thermal_sys.c
index 735e6e6..3eba397 100644
--- a/drivers/thermal/thermal_sys.c
+++ b/drivers/thermal/thermal_sys.c
@@ -46,7 +46,7 @@ MODULE_LICENSE("GPL");
* a certain cooling device on a certain trip point
* in a certain thermal zone
*/
-struct thermal_cooling_device_instance {
+struct thermal_instance {
int id;
char name[THERMAL_NAME_LENGTH];
struct thermal_zone_device *tz;
@@ -430,10 +430,10 @@ static ssize_t
thermal_cooling_device_trip_point_show(struct device *dev,
struct device_attribute *attr, char *buf)
{
- struct thermal_cooling_device_instance *instance;
+ struct thermal_instance *instance;
instance =
- container_of(attr, struct thermal_cooling_device_instance, attr);
+ container_of(attr, struct thermal_instance, attr);
if (instance->trip == THERMAL_TRIPS_NONE)
return sprintf(buf, "-1\n");
@@ -716,7 +716,7 @@ static void thermal_zone_device_passive(struct thermal_zone_device *tz,
int temp, int trip_temp, int trip)
{
enum thermal_trend trend;
- struct thermal_cooling_device_instance *instance;
+ struct thermal_instance *instance;
struct thermal_cooling_device *cdev;
long state, max_state;
@@ -812,8 +812,8 @@ int thermal_zone_bind_cooling_device(struct thermal_zone_device *tz,
struct thermal_cooling_device *cdev,
unsigned long upper, unsigned long lower)
{
- struct thermal_cooling_device_instance *dev;
- struct thermal_cooling_device_instance *pos;
+ struct thermal_instance *dev;
+ struct thermal_instance *pos;
struct thermal_zone_device *pos1;
struct thermal_cooling_device *pos2;
unsigned long max_state;
@@ -844,7 +844,7 @@ int thermal_zone_bind_cooling_device(struct thermal_zone_device *tz,
return -EINVAL;
dev =
- kzalloc(sizeof(struct thermal_cooling_device_instance), GFP_KERNEL);
+ kzalloc(sizeof(struct thermal_instance), GFP_KERNEL);
if (!dev)
return -ENOMEM;
dev->tz = tz;
@@ -909,7 +909,7 @@ int thermal_zone_unbind_cooling_device(struct thermal_zone_device *tz,
int trip,
struct thermal_cooling_device *cdev)
{
- struct thermal_cooling_device_instance *pos, *next;
+ struct thermal_instance *pos, *next;
mutex_lock(&tz->lock);
list_for_each_entry_safe(pos, next, &tz->cooling_devices, node) {
@@ -1095,7 +1095,7 @@ EXPORT_SYMBOL(thermal_cooling_device_unregister);
static void thermal_zone_trip_update(struct thermal_zone_device *tz,
int trip, long temp)
{
- struct thermal_cooling_device_instance *instance;
+ struct thermal_instance *instance;
struct thermal_cooling_device *cdev = NULL;
unsigned long cur_state, max_state;
long trip_temp;
--
1.8.0.rc1
next prev parent reply other threads:[~2012-10-09 6:10 UTC|newest]
Thread overview: 35+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-10-09 5:53 ACPI & Thermal patches for Linux-3.7-merge Len Brown
2012-10-09 5:53 ` [PATCH 01/30] Thermal: Introduce multiple cooling states support Len Brown
2012-10-09 5:53 ` [PATCH 02/30] Thermal: Introduce cooling states range support Len Brown
2012-10-09 5:53 ` [PATCH 03/30] Thermal: set upper and lower limits Len Brown
2012-10-09 5:53 ` [PATCH 04/30] Thermal: Introduce .get_trend() callback Len Brown
2012-10-09 5:53 ` [PATCH 05/30] Thermal: Remove tc1/tc2 in generic thermal layer Len Brown
2012-10-09 5:53 ` [PATCH 06/30] Thermal: Introduce thermal_zone_trip_update() Len Brown
2012-10-09 5:53 ` Len Brown [this message]
2012-10-09 5:53 ` [PATCH 08/30] Thermal: Rename thermal_zone_device.cooling_devices Len Brown
2012-10-09 5:53 ` [PATCH 09/30] Thermal: Rename thermal_instance.node to thermal_instance.tz_node Len Brown
2012-10-09 5:54 ` [PATCH 10/30] Thermal: List thermal_instance in thermal_cooling_device Len Brown
2012-10-09 5:54 ` [PATCH 11/30] Thermal: Introduce simple arbitrator for setting device cooling state Len Brown
2012-10-09 5:54 ` [PATCH 12/30] Thermal: Unify the code for both active and passive cooling Len Brown
2012-10-09 5:54 ` [PATCH 13/30] Thermal: Introduce locking for cdev.thermal_instances list Len Brown
2012-10-09 5:54 ` [PATCH 14/30] thermal: fix potential out-of-bounds memory access Len Brown
2012-10-09 5:54 ` [PATCH 15/30] thermal: add Renesas R-Car thermal sensor support Len Brown
2012-10-09 5:54 ` [PATCH 16/30] thermal: Fix potential NULL pointer accesses Len Brown
2012-10-09 5:54 ` [PATCH 17/30] Fix a build error Len Brown
2012-10-09 5:54 ` [PATCH 18/30] thermal: add generic cpufreq cooling implementation Len Brown
2012-10-09 5:54 ` [PATCH 19/30] hwmon: exynos4: move thermal sensor driver to driver/thermal directory Len Brown
2012-10-09 5:54 ` [PATCH 20/30] thermal: exynos5: add exynos5250 thermal sensor driver support Len Brown
2012-10-09 5:54 ` [PATCH 21/30] thermal: exynos: register the tmu sensor with the kernel thermal layer Len Brown
2012-10-09 5:54 ` [PATCH 22/30] ARM: exynos: add thermal sensor driver platform data support Len Brown
2012-10-09 5:54 ` [PATCH 23/30] thermal: exynos: Use devm_* functions Len Brown
2012-10-09 5:54 ` [PATCH 24/30] Thermal: Fix bug on cpu_cooling, cooling device's id conflict problem Len Brown
2012-10-09 5:54 ` [PATCH 25/30] thermal: Exynos: Fix NULL pointer dereference in exynos_unregister_thermal() Len Brown
2012-10-09 5:54 ` [PATCH 26/30] ACPI: EC: Make the GPE storm threshold a module parameter Len Brown
2012-10-09 5:54 ` [PATCH 27/30] ACPI: EC: Add a quirk for CLEVO M720T/M730T laptop Len Brown
2012-10-09 6:16 ` Jonathan Nieder
2012-10-09 6:22 ` Feng Tang
2012-10-09 6:59 ` Jonathan Nieder
2012-10-09 7:19 ` Feng Tang
2012-10-09 5:54 ` [PATCH 28/30] cpuidle / ACPI: fix potential NULL pointer dereference Len Brown
2012-10-09 5:54 ` [PATCH 29/30] ACPI idle, CPU hotplug: Fix NULL pointer dereference during hotplug Len Brown
2012-10-09 5:54 ` [PATCH 30/30] tools/power/acpi/acpidump: remove duplicated include from acpidump.c Len Brown
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=b81b6ba3d9ac5feb14388bb73ac5a39d9a7540dc.1349761836.git.len.brown@intel.com \
--to=lenb@kernel.org \
--cc=linux-acpi@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=rui.zhang@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®