From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752043AbdAQXuR (ORCPT ); Tue, 17 Jan 2017 18:50:17 -0500 Received: from mail-pg0-f65.google.com ([74.125.83.65]:36813 "EHLO mail-pg0-f65.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751385AbdAQXuP (ORCPT ); Tue, 17 Jan 2017 18:50:15 -0500 Subject: Re: [PATCH net-next v4 05/10] drivers: base: Add device_find_in_class_name() To: Andy Shevchenko References: <20170117232152.1661-1-f.fainelli@gmail.com> <20170117232152.1661-6-f.fainelli@gmail.com> Cc: netdev , Jason Cooper , Andrew Lunn , Sebastian Hesselbarth , Gregory Clement , Russell King , Vivien Didelot , "David S. Miller" , Greg Kroah-Hartman , "moderated list:ARM/Marvell Dove/MV78xx0/Orion SOC support" , open list From: Florian Fainelli Message-ID: Date: Tue, 17 Jan 2017 15:43:25 -0800 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.5.1 MIME-Version: 1.0 In-Reply-To: Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 8bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 01/17/2017 03:34 PM, Andy Shevchenko wrote: > On Wed, Jan 18, 2017 at 1:21 AM, Florian Fainelli wrote: >> Add a helper function to lookup a device reference given a class name. >> This is a preliminary patch to remove adhoc code from net/dsa/dsa.c and >> make it more generic. > > >> +static int device_class_name_match(struct device *dev, void *class) > > And why not const char *class? This was raised back in v2, and the same response applies: https://www.mail-archive.com/netdev@vger.kernel.org/msg147559.html Changing the signature of a callback is out of the scope of this patch series. -- Florian