From: "Boqun Feng" <boqun.feng@gmail.com>
To: "Greg Kroah-Hartman" <gregkh@linuxfoundation.org>,
"Danilo Krummrich" <dakr@kernel.org>
Cc: "Guilherme Giacomo Simoes" <trintaeoitogc@gmail.com>,
rafael@kernel.org, ojeda@kernel.org, alex.gaynor@gmail.com,
"Gary Guo" <gary@garyguo.net>,
bjorn3_gh@protonmail.com, benno.lossin@proton.me,
aliceryhl@google.com, mcgrof@kernel.org, russ.weight@linux.dev,
dakr@redhat.com, a.hindborg@kernel.org,
rust-for-linux@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v3] rust: device: change the from_raw() function
Date: Thu, 03 Oct 2024 10:18:01 +0800 [thread overview]
Message-ID: <bb2f6786-b99e-424d-b54e-c56d9c7f1f81@app.fastmail.com> (raw)
In-Reply-To: <2024100240-wrangle-condiment-3f0c@gregkh>
On Thu, Oct 3, 2024, at 12:07 AM, Greg KH wrote:
> On Wed, Oct 02, 2024 at 03:58:29PM +0200, Danilo Krummrich wrote:
>> On Tue, Oct 01, 2024 at 05:56:03PM -0300, Guilherme Giacomo Simoes wrote:
>> > The function Device::from_raw() increments a refcount by a call to
>> > bindings::get_device(ptr). This can be confused because usually
>> > from_raw() functions don't increment a refcount.
>> > Hence, rename Device::from_raw() to avoid confuion with other "from_raw"
>> > semantics.
>> >
>> > The new name of function should be "get_device" to be consistent with
>> > the function get_device() already exist in .c files.
>> >
>> > This function body also changed, because the `into()` will convert the
>> > `&'a Device` into `ARef<Device>` and also call `inc_ref` from the
>> > `AlwaysRefCounted` trait implemented for Device.
>> >
This work is because we have an issue, so this should really have a:
Closes: https://github.com/Rust-for-Linux/linux/issues/1088
tag.
Greg, could you add this when you queue this?
Guilherme, please add such a tag next time, so we can have things
tracked. Thanks!
Regards,
Boqun
>> > Signed-off-by: Guilherme Giacomo Simoes <trintaeoitogc@gmail.com>
>>
>> Acked-by: Danilo Krummrich <dakr@kernel.org>
>
> Thanks for the review, and Guilherme, for all of the revisions. I'll
> queue this up for this release soon so we don't get any code building on
> the old api.
>
> thanks,
>
> greg k-h
next prev parent reply other threads:[~2024-10-03 2:18 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-10-01 20:56 Guilherme Giacomo Simoes
2024-10-02 13:58 ` Danilo Krummrich
2024-10-02 16:07 ` Greg KH
2024-10-03 2:18 ` Boqun Feng [this message]
2024-10-03 11:30 ` Guilherme Giácomo Simões
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=bb2f6786-b99e-424d-b54e-c56d9c7f1f81@app.fastmail.com \
--to=boqun.feng@gmail.com \
--cc=a.hindborg@kernel.org \
--cc=alex.gaynor@gmail.com \
--cc=aliceryhl@google.com \
--cc=benno.lossin@proton.me \
--cc=bjorn3_gh@protonmail.com \
--cc=dakr@kernel.org \
--cc=dakr@redhat.com \
--cc=gary@garyguo.net \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mcgrof@kernel.org \
--cc=ojeda@kernel.org \
--cc=rafael@kernel.org \
--cc=russ.weight@linux.dev \
--cc=rust-for-linux@vger.kernel.org \
--cc=trintaeoitogc@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®