From: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
To: Andrew Morton <akpm@google.com>, linux-kernel@vger.kernel.org
Cc: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
Subject: [PATCHv2 1/5] lib: rename pack_hex_byte to hex_byte_pack
Date: Mon, 10 Oct 2011 17:33:35 +0300 [thread overview]
Message-ID: <bc1318a3244d9df71f44041d8a57d8f075f2cb5b.1318257114.git.andriy.shevchenko@linux.intel.com> (raw)
In-Reply-To: <CAKiorj5MJ8_ZH-J-7GjNQLoPNTshFdrrHfjptgpgi_4mchHJYw@mail.gmail.com>
As suggested by Andrew Morton in [1] there is better to have most significant
part first in the function name.
[1] https://lkml.org/lkml/2011/9/20/22
There is no functional change.
Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
---
include/linux/kernel.h | 7 ++++++-
lib/vsprintf.c | 14 +++++++-------
2 files changed, 13 insertions(+), 8 deletions(-)
diff --git a/include/linux/kernel.h b/include/linux/kernel.h
index a10ed77..4c0d3b2 100644
--- a/include/linux/kernel.h
+++ b/include/linux/kernel.h
@@ -376,13 +376,18 @@ extern const char hex_asc[];
#define hex_asc_lo(x) hex_asc[((x) & 0x0f)]
#define hex_asc_hi(x) hex_asc[((x) & 0xf0) >> 4]
-static inline char *pack_hex_byte(char *buf, u8 byte)
+static inline char *hex_byte_pack(char *buf, u8 byte)
{
*buf++ = hex_asc_hi(byte);
*buf++ = hex_asc_lo(byte);
return buf;
}
+static inline char * __deprecated pack_hex_byte(char *buf, u8 byte)
+{
+ return hex_byte_pack(buf, byte);
+}
+
extern int hex_to_bin(char ch);
extern int __must_check hex2bin(u8 *dst, const char *src, size_t count);
diff --git a/lib/vsprintf.c b/lib/vsprintf.c
index c1a3927..993599e 100644
--- a/lib/vsprintf.c
+++ b/lib/vsprintf.c
@@ -547,7 +547,7 @@ char *mac_address_string(char *buf, char *end, u8 *addr,
}
for (i = 0; i < 6; i++) {
- p = pack_hex_byte(p, addr[i]);
+ p = hex_byte_pack(p, addr[i]);
if (fmt[0] == 'M' && i != 5)
*p++ = separator;
}
@@ -667,13 +667,13 @@ char *ip6_compressed_string(char *p, const char *addr)
lo = word & 0xff;
if (hi) {
if (hi > 0x0f)
- p = pack_hex_byte(p, hi);
+ p = hex_byte_pack(p, hi);
else
*p++ = hex_asc_lo(hi);
- p = pack_hex_byte(p, lo);
+ p = hex_byte_pack(p, lo);
}
else if (lo > 0x0f)
- p = pack_hex_byte(p, lo);
+ p = hex_byte_pack(p, lo);
else
*p++ = hex_asc_lo(lo);
needcolon = true;
@@ -695,8 +695,8 @@ char *ip6_string(char *p, const char *addr, const char *fmt)
int i;
for (i = 0; i < 8; i++) {
- p = pack_hex_byte(p, *addr++);
- p = pack_hex_byte(p, *addr++);
+ p = hex_byte_pack(p, *addr++);
+ p = hex_byte_pack(p, *addr++);
if (fmt[0] == 'I' && i != 7)
*p++ = ':';
}
@@ -754,7 +754,7 @@ char *uuid_string(char *buf, char *end, const u8 *addr,
}
for (i = 0; i < 16; i++) {
- p = pack_hex_byte(p, addr[index[i]]);
+ p = hex_byte_pack(p, addr[index[i]]);
switch (i) {
case 3:
case 5:
--
1.7.6.3
next prev parent reply other threads:[~2011-10-10 14:34 UTC|newest]
Thread overview: 31+ messages / expand[flat|nested] mbox.gz Atom feed top
2011-09-16 12:50 [RFC][PATCH 1/5] lib: add unpack_hex_byte() Mimi Zohar
2011-09-16 12:50 ` [RFC][PATCH 2/5] lib: add error checking to hex2bin Mimi Zohar
2011-09-16 13:13 ` Andy Shevchenko
2011-09-19 21:20 ` Andrew Morton
2011-09-16 12:50 ` [RFC][PATCH 3/5] trusted-keys: check hex2bin result Mimi Zohar
2011-09-16 12:50 ` [RFC][PATCH 4/5] encrypted-keys: " Mimi Zohar
2011-09-16 12:50 ` [RFC][PATCH 5/5] target: " Mimi Zohar
2011-09-16 14:07 ` Tetsuo Handa
2011-09-16 20:21 ` Nicholas A. Bellinger
2011-09-19 11:19 ` Mimi Zohar
2011-09-16 13:11 ` [RFC][PATCH 1/5] lib: add unpack_hex_byte() Andy Shevchenko
2011-09-19 21:19 ` Andrew Morton
2011-09-19 22:35 ` Mimi Zohar
2011-09-19 22:38 ` Andrew Morton
2011-09-20 6:04 ` Andy Shevchenko
2011-09-20 6:26 ` Andrew Morton
2011-09-23 10:47 ` [PATCH 1/2] kernel.h: rename pack_hex_byte to hex_pack_byte Andy Shevchenko
2011-09-23 10:47 ` [PATCH 2/2] wireless: at76c50x: use native hex_pack_byte() method Andy Shevchenko
2011-09-27 11:51 ` [PATCHv2] " Andy Shevchenko
2011-09-27 12:01 ` [PATCHv2.1] " Andy Shevchenko
2011-09-23 20:18 ` [PATCH 1/2] kernel.h: rename pack_hex_byte to hex_pack_byte Andrew Morton
2011-09-27 10:51 ` Andy Shevchenko
2011-09-27 17:32 ` Andrew Morton
2011-10-10 14:33 ` Andy Shevchenko [this message]
2011-10-10 14:33 ` [PATCHv2 2/5] kgdb: follow rename pack_hex_byte to hex_byte_pack Andy Shevchenko
2011-10-10 14:55 ` Jesper Nilsson
2011-10-10 14:33 ` [PATCHv2 3/5] security: " Andy Shevchenko
2011-10-10 14:33 ` [PATCHv2 4/5] fat: " Andy Shevchenko
2011-10-10 20:02 ` OGAWA Hirofumi
2011-10-10 14:33 ` [PATCHv2 5/5] wireless: at76c50x: " Andy Shevchenko
2011-10-11 13:55 ` John W. Linville
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=bc1318a3244d9df71f44041d8a57d8f075f2cb5b.1318257114.git.andriy.shevchenko@linux.intel.com \
--to=andriy.shevchenko@linux.intel.com \
--cc=akpm@google.com \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®