mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Dmitry <dbaryshkov@gmail.com>
To: avorontsov@ru.mvista.com
Cc: linux-kernel@vger.kernel.org, cbou@mail.ru,
	"Andrew Morton" <akpm@linux-foundation.org>,
	"Mark Brown" <broonie@opensource.wolfsonmicro.com>
Subject: Re: [PATCH] power_supply: only register tosa_battery driver on tosa
Date: Mon, 3 Nov 2008 19:41:47 +0300	[thread overview]
Message-ID: <bc64b4640811030841h5bcc537fy4b645c6d293b7b46@mail.gmail.com> (raw)
In-Reply-To: <20081103162547.GA25546@oksana.dev.rtsoft.ru>

2008/11/3 Anton Vorontsov <avorontsov@ru.mvista.com>:
> On Mon, Nov 03, 2008 at 07:20:06PM +0300, Dmitry wrote:
>> 2008/11/3 Anton Vorontsov <avorontsov@ru.mvista.com>:
>> > On Sun, Nov 02, 2008 at 11:36:08PM +0300, Dmitry wrote:
>> >> 2008/10/29 Dmitry Baryshkov <dbaryshkov@gmail.com>:
>> >> > There are already several wm97xx-battery drivers. Do register the tosa one
>> >> > only on tosa machines.
>> >> >
>> >> > Signed-off-by: Dmitry Baryshkov <dbaryshkov@gmail.com>
>> >> > ---
>> >> >  drivers/power/tosa_battery.c |    3 +++
>> >> >  1 files changed, 3 insertions(+), 0 deletions(-)
>> >>
>> >> What about this patch?
>> >
>> > Sorry for the delay.
>> >
>> >> IMO it can and should be merged during 2.6.28-rc cycle.
>> >>
>> >> diff --git a/drivers/power/tosa_battery.c b/drivers/power/tosa_battery.c
>> >> index 2eab35a..4e52c22 100644
>> >> --- a/drivers/power/tosa_battery.c
>> >> +++ b/drivers/power/tosa_battery.c
>> >> @@ -469,6 +469,9 @@ static struct platform_driver tosa_bat_driver = {
>> >>
>> >>  static int __init tosa_bat_init(void)
>> >>  {
>> >> +     if (!machine_is_tosa())
>> >> +             return -EINVAL;
>> >> +
>> >
>> > I tend to reject this approach. You should rename the driver instead.
>> >
>> > I.e.
>> > -.driver.name    = "wm97xx-battery",
>> > -.driver.name    = "tosa-battery",
>> >
>> > And make sure that this won't break users of that driver (though
>> > I don't see any).
>>
>> The wm97xx-battery device is registered by
>> drivers/input/toucscreen/wm97xx-core.c
>
> Hmm.. So you can't rename the tosa driver, because then it won't
> work, correct?

Yup.
I see few ways to resolve this:
* write better wm97xx interface. Dunno if that is feasible or possible.
  One of the possible solutions is to pass battery and ts device names
  and data from within board data via ac97 layer to wm97xx-core. This
  will provide several benefits (e.g. then we can drop lots of parameters
  from wm97xx-core, which are really board parameters).
* Merge most of functionality of wm97xx-battery driver for Palms (by Marek),
  my tosa battery driver, name that The Only wm97xx-battery Driver. However
  on this path we will have to put lot's of code into hooks, which is
pretty much
  ugly IMO.


-- 
With best wishes
Dmitry

  reply	other threads:[~2008-11-03 16:41 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-10-29  9:04 Dmitry Baryshkov
2008-10-29  9:04 ` [PATCH] power_supply: change the way how wm97xx-bat driver is registered Dmitry Baryshkov
2008-11-02 20:36   ` Dmitry
2008-11-02 23:41     ` Marek Vasut
2008-11-03 15:11   ` Anton Vorontsov
2008-11-03 16:54     ` Jonathan Cameron
2008-11-03 17:21       ` Anton Vorontsov
2008-11-03 18:29     ` Dmitry Baryshkov
2008-11-03 19:34       ` Anton Vorontsov
2008-11-02 20:36 ` [PATCH] power_supply: only register tosa_battery driver on tosa Dmitry
2008-11-03 14:55   ` Anton Vorontsov
2008-11-03 16:20     ` Dmitry
2008-11-03 16:25       ` Anton Vorontsov
2008-11-03 16:41         ` Dmitry [this message]
2008-11-03 16:58           ` Anton Vorontsov
2008-11-03 17:09             ` Dmitry
2008-11-03 17:32               ` Anton Vorontsov
2008-11-03 18:14                 ` Dmitry
2008-11-03 17:41           ` Mark Brown

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=bc64b4640811030841h5bcc537fy4b645c6d293b7b46@mail.gmail.com \
    --to=dbaryshkov@gmail.com \
    --cc=akpm@linux-foundation.org \
    --cc=avorontsov@ru.mvista.com \
    --cc=broonie@opensource.wolfsonmicro.com \
    --cc=cbou@mail.ru \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®