From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1754761AbdKHDmB (ORCPT ); Tue, 7 Nov 2017 22:42:01 -0500 Received: from mail-pf0-f195.google.com ([209.85.192.195]:55430 "EHLO mail-pf0-f195.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752222AbdKHDl6 (ORCPT ); Tue, 7 Nov 2017 22:41:58 -0500 X-Google-Smtp-Source: ABhQp+Sh2x4IRXE9WS06FFOz0Z1gv5rpgIRIRTmzKbyD1Dk5t21m1HIyMp38VNloVp3BaOXFf0xQFw== Subject: Re: [PATCH v4 3/3] KVM: MMU: consider host cache mode in MMIO page check To: Xiao Guangrong , kvm@vger.kernel.org, x86@kernel.org, linux-kernel@vger.kernel.org, Paolo Bonzini , rkrcmar@redhat.com, Dan Williams , ivan.d.cuevas.escareno@intel.com, karthik.kumar@intel.com, Konrad Rzeszutek Wilk , Olif Chapman , Ingo Molnar References: <20171103055327.21684-1-haozhong.zhang@intel.com> <20171103055327.21684-4-haozhong.zhang@intel.com> <745df599-b65b-bcfe-a20c-05ae6d99a0b5@gmail.com> <20171103085130.itjzxoaorvw34vnm@hz-desktop> <20171103090244.swsna6h4hk5j4bdh@hz-desktop> <20171103092956.y6sbvvyh3dg3mjyw@hz-desktop> From: Xiao Guangrong Message-ID: Date: Wed, 8 Nov 2017 11:42:17 +0800 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.4.0 MIME-Version: 1.0 In-Reply-To: <20171103092956.y6sbvvyh3dg3mjyw@hz-desktop> Content-Type: text/plain; charset=utf-8; format=flowed Content-Language: en-US Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 11/03/2017 05:29 PM, Haozhong Zhang wrote: > On 11/03/17 17:24 +0800, Xiao Guangrong wrote: >> >> >> On 11/03/2017 05:02 PM, Haozhong Zhang wrote: >>> On 11/03/17 16:51 +0800, Haozhong Zhang wrote: >>>> On 11/03/17 14:54 +0800, Xiao Guangrong wrote: >>>>> >>>>> >>>>> On 11/03/2017 01:53 PM, Haozhong Zhang wrote: >>>>>> Some reserved pages, such as those from NVDIMM DAX devices, are >>>>>> not for MMIO, and can be mapped with cached memory type for better >>>>>> performance. However, the above check misconceives those pages as >>>>>> MMIO. Because KVM maps MMIO pages with UC memory type, the >>>>>> performance of guest accesses to those pages would be harmed. >>>>>> Therefore, we check the host memory type by lookup_memtype() in >>>>>> addition and only treat UC/UC- pages as MMIO. >>>>>> >>>>>> Signed-off-by: Haozhong Zhang >>>>>> Reported-by: Cuevas Escareno, Ivan D >>>>>> Reported-by: Kumar, Karthik >>>>>> --- >>>>>> arch/x86/kvm/mmu.c | 19 ++++++++++++++++++- >>>>>> 1 file changed, 18 insertions(+), 1 deletion(-) >>>>>> >>>>>> diff --git a/arch/x86/kvm/mmu.c b/arch/x86/kvm/mmu.c >>>>>> index 0b481cc9c725..e9ed0e666a83 100644 >>>>>> --- a/arch/x86/kvm/mmu.c >>>>>> +++ b/arch/x86/kvm/mmu.c >>>>>> @@ -2708,7 +2708,24 @@ static bool mmu_need_write_protect(struct kvm_vcpu *vcpu, gfn_t gfn, >>>>>> static bool kvm_is_mmio_pfn(kvm_pfn_t pfn) >>>>>> { >>>>>> if (pfn_valid(pfn)) >>>>>> - return !is_zero_pfn(pfn) && PageReserved(pfn_to_page(pfn)); >>>>>> + return !is_zero_pfn(pfn) && PageReserved(pfn_to_page(pfn)) && >>>>>> + /* >>>>>> + * Some reserved pages, such as those from >>>>>> + * NVDIMM DAX devices, are not for MMIO, and >>>>>> + * can be mapped with cached memory type for >>>>>> + * better performance. However, the above >>>>>> + * check misconceives those pages as MMIO. >>>>>> + * Because KVM maps MMIO pages with UC memory >>>>>> + * type, the performance of guest accesses to >>>>>> + * those pages would be harmed. Therefore, we >>>>>> + * check the host memory type in addition and >>>>>> + * only treat UC/UC- pages as MMIO. >>>>>> + * >>>>>> + * pat_pfn_is_uc() works only when PAT is enabled, >>>>>> + * so check pat_enabled() as well. >>>>>> + */ >>>>>> + (!pat_enabled() || >>>>>> + pat_pfn_is_uc(kvm_pfn_t_to_pfn_t(pfn))); >>>>> >>>>> Can it be compiled if !CONFIG_PAT? >>>> >>>> Yes. >>>> >>>> What I check via pat_enabled() is not only whether PAT support is >>>> compiled, but also whether PAT is enabled at runtime. >>>> >>>>> >>>>> It would be better if we move pat_enabled out of kvm as well, >>>> >>>> Surely I can combine them in one function like >>>> >>>> bool pat_pfn_is_uc(pfn_t pfn) >>>> { >>>> enum page_cache_mode cm; >>>> >>>> if (!pat_enabled()) >>>> return false; >>>> >>>> cm = lookup_memtype(pfn_t_to_phys(pfn)); >>>> >>>> return cm == _PAGE_CACHE_MODE_UC || cm == _PAGE_CACHE_MODE_UC_MINUS; >>>> } >>> >>> In addition, I think it's better to split this function into >>> pat_pfn_is_uc() and pat_pfn_is_uc_minus() to avoid additional >>> confusion. >> >> Why not use pat_pfn_is_uc_or_uc_minus(). :) > > Just in case that other places other than KVM do not need both of them. > I think we need not care the future case too much, it is not ABI anyway. i.e, it can be easily adjusted if it is really needed in the future. But it is not a big deal...