From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751478AbdJWDHk (ORCPT ); Sun, 22 Oct 2017 23:07:40 -0400 Received: from mx0b-001b2d01.pphosted.com ([148.163.158.5]:34198 "EHLO mx0a-001b2d01.pphosted.com" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1751113AbdJWDHj (ORCPT ); Sun, 22 Oct 2017 23:07:39 -0400 Subject: Re: [RFC] mm/swap: Rename pagevec_lru_move_fn() as pagevec_lruvec_move_fn() To: Michal Hocko , Anshuman Khandual References: <20171019083314.12614-1-khandual@linux.vnet.ibm.com> <20171019152918.2wrn6slrq7ashvpj@dhcp22.suse.cz> Cc: linux-mm@kvack.org, linux-kernel@vger.kernel.org From: Anshuman Khandual Date: Mon, 23 Oct 2017 08:37:31 +0530 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.5.1 MIME-Version: 1.0 In-Reply-To: <20171019152918.2wrn6slrq7ashvpj@dhcp22.suse.cz> Content-Type: text/plain; charset=windows-1252 Content-Transfer-Encoding: 7bit X-TM-AS-MML: disable x-cbid: 17102303-0020-0000-0000-000003C3B83A X-IBM-AV-DETECTION: SAVI=unused REMOTE=unused XFE=unused x-cbparentid: 17102303-0021-0000-0000-000042588A1A Message-Id: X-Proofpoint-Virus-Version: vendor=fsecure engine=2.50.10432:,, definitions=2017-10-23_01:,, signatures=0 X-Proofpoint-Spam-Details: rule=outbound_notspam policy=outbound score=0 spamscore=0 suspectscore=0 malwarescore=0 phishscore=0 adultscore=0 bulkscore=0 classifier=spam adjust=0 reason=mlx scancount=1 engine=8.0.1-1707230000 definitions=main-1710230043 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 10/19/2017 08:59 PM, Michal Hocko wrote: > On Thu 19-10-17 14:03:14, Anshuman Khandual wrote: >> The function pagevec_lru_move_fn() actually moves pages from various >> per cpu pagevecs into per node lruvecs with a custom function which >> knows how to handle individual pages present in any given pagevec. >> Because it does movement between pagevecs and lruvecs as whole not >> to an individual list element, the name should reflect it. > I find the original name quite understandable (and shorter). I do not > think this is worth changing. It is just a code churn without a good > reason. > Sure, I understand.