From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-2.2 required=3.0 tests=HEADER_FROM_DIFFERENT_DOMAINS, MAILING_LIST_MULTI,SPF_HELO_NONE,SPF_PASS,USER_AGENT_SANE_1 autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 5C838C47256 for ; Wed, 6 May 2020 03:47:48 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id 3CC1D20757 for ; Wed, 6 May 2020 03:47:48 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1726927AbgEFDrr (ORCPT ); Tue, 5 May 2020 23:47:47 -0400 Received: from szxga07-in.huawei.com ([45.249.212.35]:33852 "EHLO huawei.com" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1726477AbgEFDrr (ORCPT ); Tue, 5 May 2020 23:47:47 -0400 Received: from DGGEMS408-HUB.china.huawei.com (unknown [172.30.72.58]) by Forcepoint Email with ESMTP id EAB4A1CEDB2C3B6D3534; Wed, 6 May 2020 11:47:44 +0800 (CST) Received: from [127.0.0.1] (10.166.215.55) by DGGEMS408-HUB.china.huawei.com (10.3.19.208) with Microsoft SMTP Server id 14.3.487.0; Wed, 6 May 2020 11:47:41 +0800 Subject: Re: [PATCH 2/4] mm/swap: use SECTORS_PER_PAGE_SHIFT to clean up code From: "Leizhen (ThunderTown)" To: Matthew Wilcox CC: Minchan Kim , Nitin Gupta , "Sergey Senozhatsky" , Jens Axboe , linux-block , Andrew Morton , linux-mm , Alasdair Kergon , Mike Snitzer , dm-devel , Song Liu , linux-raid , linux-kernel References: <20200505115543.1660-1-thunder.leizhen@huawei.com> <20200505115543.1660-3-thunder.leizhen@huawei.com> <20200505172520.GI16070@bombadil.infradead.org> <32ba9907-60ad-27c0-c565-e7b5c80ab03c@huawei.com> Message-ID: Date: Wed, 6 May 2020 11:47:40 +0800 User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:60.0) Gecko/20100101 Thunderbird/60.7.0 MIME-Version: 1.0 In-Reply-To: <32ba9907-60ad-27c0-c565-e7b5c80ab03c@huawei.com> Content-Type: text/plain; charset="utf-8" Content-Language: en-US Content-Transfer-Encoding: 8bit X-Originating-IP: [10.166.215.55] X-CFilter-Loop: Reflected Sender: linux-kernel-owner@vger.kernel.org Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 2020/5/6 9:33, Leizhen (ThunderTown) wrote: > > > On 2020/5/6 1:25, Matthew Wilcox wrote: >> On Tue, May 05, 2020 at 07:55:41PM +0800, Zhen Lei wrote: >>> +++ b/mm/swapfile.c >>> @@ -177,8 +177,8 @@ static int discard_swap(struct swap_info_struct *si) >>> >>> /* Do not discard the swap header page! */ >>> se = first_se(si); >>> - start_block = (se->start_block + 1) << (PAGE_SHIFT - 9); >>> - nr_blocks = ((sector_t)se->nr_pages - 1) << (PAGE_SHIFT - 9); >>> + start_block = (se->start_block + 1) << SECTORS_PER_PAGE_SHIFT; >>> + nr_blocks = ((sector_t)se->nr_pages - 1) << SECTORS_PER_PAGE_SHIFT; >> >> Thinking about this some more, wouldn't this look better? >> >> start_block = page_sectors(se->start_block + 1); >> nr_block = page_sectors(se->nr_pages - 1); >> > > OK,That's fine, it's clearer. And in this way, there won't be more than 80 columns. Should we rename "page_sectors" to "page_to_sectors"? Because we may need to define "sectors_to_page" also. > >> >> . >>