mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Joe Perches <joe@perches.com>
To: Andy Shevchenko <andy.shevchenko@gmail.com>,
	Len Baker <len.baker@gmx.com>
Cc: Jonathan Cameron <jic23@kernel.org>,
	Lars-Peter Clausen <lars@metafoo.de>,
	David Laight <David.Laight@aculab.com>,
	Kees Cook <keescook@chromium.org>,
	linux-hardening@vger.kernel.org,
	linux-iio <linux-iio@vger.kernel.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v4] drivers/iio: Remove all strcpy() uses
Date: Sun, 15 Aug 2021 08:06:45 -0700	[thread overview]
Message-ID: <c08cfa8b6bbf07e1860d7dc93739e71ff5f4c0c4.camel@perches.com> (raw)
In-Reply-To: <CAHp75VdBuQTzCbz1CJciSA1+UOw0ZmJKAh8u2cbr5eDLSsRJEw@mail.gmail.com>

On Sat, 2021-08-14 at 22:36 +0300, Andy Shevchenko wrote:
> On Sat, Aug 14, 2021 at 4:55 PM Len Baker <len.baker@gmx.com> wrote:
> > 
> > strcpy() performs no bounds checking on the destination buffer. This
> > could result in linear overflows beyond the end of the buffer, leading
> > to all kinds of misbehaviors. So, remove all the uses and add
> > devm_kstrdup() or devm_kasprintf() instead.
> > 
> > This patch is an effort to clean up the proliferation of str*()
> > functions in the kernel and a previous step in the path to remove
> > the strcpy function from the kernel entirely [1].
> > 
> > [1] https://github.com/KSPP/linux/issues/88
> 
> Thank you very much for doing this!
> Now I like the result,
> Reviewed-by: Andy Shevchenko <andy.shevchenko@gmail.com>
[]
> > diff --git a/drivers/iio/imu/inv_mpu6050/inv_mpu_magn.c b/drivers/iio/imu/inv_mpu6050/inv_mpu_magn.c
[]
> > @@ -261,6 +261,7 @@ int inv_mpu_magn_set_rate(const struct inv_mpu6050_state *st, int fifo_rate)
> >   */
> >  int inv_mpu_magn_set_orient(struct inv_mpu6050_state *st)
> >  {
> > +       struct device *dev = regmap_get_device(st->map);
> >         const char *orient;
> >         char *str;
> >         int i;
> > @@ -281,19 +282,24 @@ int inv_mpu_magn_set_orient(struct inv_mpu6050_state *st)
> >                 /* z <- -z */
> >                 for (i = 0; i < 3; ++i) {
> >                         orient = st->orientation.rotation[6 + i];
> > -                       /* use length + 2 for adding minus sign if needed */
> > -                       str = devm_kzalloc(regmap_get_device(st->map),
> > -                                          strlen(orient) + 2, GFP_KERNEL);
> > -                       if (str == NULL)
> > +
> > +                       /*
> > +                        * The value is negated according to one of the following
> > +                        * rules:
> > +                        *
> > +                        * 1) Drop leading minus.
> > +                        * 2) Leave 0 as is.
> > +                        * 3) Add leading minus.
> > +                        */
> > +                       if (orient[0] == '-')
> > +                               str = devm_kstrdup(dev, orient + 1, GFP_KERNEL);
> > +                       else if (orient[0] == '0' && orient[1] == '\0')

bikeshed:

I think this change is less intelligible than the original strcmp.

And separately, perhaps for loop would be more readable as

	for (i = 6; i < 9; i++)

converting the 6 + i uses to just i.

> > +                               str = devm_kstrdup(dev, orient, GFP_KERNEL);
> > +                       else
> > +                               str = devm_kasprintf(dev, GFP_KERNEL, "-%s", orient);
> > +                       if (!str)
> >                                 return -ENOMEM;
> > -                       if (strcmp(orient, "0") == 0) {
> > -                               strcpy(str, orient);
> > -                       } else if (orient[0] == '-') {
> > -                               strcpy(str, &orient[1]);
> > -                       } else {
> > -                               str[0] = '-';
> > -                               strcpy(&str[1], orient);
> > -                       }
> > +
> >                         st->magn_orient.rotation[6 + i] = str;
> >                 }
> >                 break;



  parent reply	other threads:[~2021-08-15 15:06 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-08-14 13:55 Len Baker
2021-08-14 19:36 ` Andy Shevchenko
2021-08-15  8:19   ` Len Baker
2021-08-15 14:45     ` Jonathan Cameron
2021-08-15 15:59       ` Jonathan Cameron
2021-08-15 15:06   ` Joe Perches [this message]
2021-08-15 16:36     ` Len Baker
2021-08-15 16:58       ` Joe Perches
2021-08-15 17:12         ` Len Baker

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=c08cfa8b6bbf07e1860d7dc93739e71ff5f4c0c4.camel@perches.com \
    --to=joe@perches.com \
    --cc=David.Laight@aculab.com \
    --cc=andy.shevchenko@gmail.com \
    --cc=jic23@kernel.org \
    --cc=keescook@chromium.org \
    --cc=lars@metafoo.de \
    --cc=len.baker@gmx.com \
    --cc=linux-hardening@vger.kernel.org \
    --cc=linux-iio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®