From: maowenan <maowenan@huawei.com>
To: Willem de Bruijn <willemdebruijn.kernel@gmail.com>
Cc: David Miller <davem@davemloft.net>,
Eric Dumazet <edumazet@google.com>, <maximmi@mellanox.com>,
Paolo Abeni <pabeni@redhat.com>, <yuehaibing@huawei.com>,
Neil Horman <nhorman@tuxdriver.com>,
"Network Development" <netdev@vger.kernel.org>,
linux-kernel <linux-kernel@vger.kernel.org>,
<kernel-janitors@vger.kernel.org>
Subject: Re: [PATCH net] af_packet: refactoring code for prb_calc_retire_blk_tmo
Date: Fri, 20 Dec 2019 10:19:34 +0800 [thread overview]
Message-ID: <c0944cb6-eb63-b1e6-01da-4cddd2ab7f91@huawei.com> (raw)
In-Reply-To: <CA+FuTScgWi905_NhGNsRzpwaQ+OPwahj6NtKgPjLZRjuqJvhXQ@mail.gmail.com>
On 2019/12/19 21:56, Willem de Bruijn wrote:
> On Wed, Dec 18, 2019 at 8:37 PM Mao Wenan <maowenan@huawei.com> wrote:
>>
>> If __ethtool_get_link_ksettings() is failed and with
>> non-zero value, prb_calc_retire_blk_tmo() should return
>> DEFAULT_PRB_RETIRE_TOV firstly. Refactoring code and make
>> it more readable.
>>
>> Fixes: b43d1f9f7067 ("af_packet: set defaule value for tmo")
>
> This is a pure refactor, not a fix.
yes , it is not a fix.
>
> Code refactors make backporting fixes across releases harder, among
> other things. I think this code is better left as is. Either way, it
> would be a candidate for net-next, not net.
sorry, it would be net-next.
>
>> - unsigned int mbits = 0, msec = 0, div = 0, tmo = 0;
>> + unsigned int mbits = 0, msec = 1, div = 0, tmo = 0;
>
> Most of these do not need to be initialized here at all, really.
>
some of them do not need to be initialized,
msec=1 can be reserved because it can indicate tmo is for millisecond and msec
initialized value is 1ms.
next prev parent reply other threads:[~2019-12-20 2:19 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-12-19 1:33 Mao Wenan
2019-12-19 13:56 ` Willem de Bruijn
2019-12-20 2:19 ` maowenan [this message]
2019-12-23 10:42 ` [PATCH net-next v2] " Mao Wenan
2019-12-26 23:20 ` David Miller
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=c0944cb6-eb63-b1e6-01da-4cddd2ab7f91@huawei.com \
--to=maowenan@huawei.com \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=kernel-janitors@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=maximmi@mellanox.com \
--cc=netdev@vger.kernel.org \
--cc=nhorman@tuxdriver.com \
--cc=pabeni@redhat.com \
--cc=willemdebruijn.kernel@gmail.com \
--cc=yuehaibing@huawei.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®