From: Enric Balletbo i Serra <enric.balletbo@collabora.com>
To: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Cc: linux-kernel@vger.kernel.org,
Collabora Kernel ML <kernel@collabora.com>,
matthias.bgg@gmail.com, drinkcat@chromium.org,
hsinyi@chromium.org, Chun-Kuang Hu <chunkuang.hu@kernel.org>,
Daniel Vetter <daniel@ffwll.ch>, David Airlie <airlied@linux.ie>,
Philipp Zabel <p.zabel@pengutronix.de>,
dri-devel@lists.freedesktop.org,
linux-arm-kernel@lists.infradead.org,
linux-mediatek@lists.infradead.org
Subject: Re: [PATCH v2 3/7] drm/mediatek: mtk_dsi: Rename bridge to next_bridge
Date: Fri, 17 Apr 2020 16:53:02 +0200 [thread overview]
Message-ID: <c1319dc1-5fdf-7e7d-1410-a23ed1d87d67@collabora.com> (raw)
In-Reply-To: <20200416172435.GM4796@pendragon.ideasonboard.com>
Hi Laurent,
On 16/4/20 19:24, Laurent Pinchart wrote:
> Hi Enric,
>
> Thank you for the patch.
>
> On Thu, Apr 16, 2020 at 05:57:15PM +0200, Enric Balletbo i Serra wrote:
>> This is really a cosmetic change just to make a bit more readable the
>> code after convert the driver to drm_bridge. The bridge variable name
>> will be used by the encoder drm_bridge, and the chained bridge will be
>> named next_bridge.
>>
>> Signed-off-by: Enric Balletbo i Serra <enric.balletbo@collabora.com>
>> ---
>>
>> Changes in v2: None
>>
>> drivers/gpu/drm/mediatek/mtk_dsi.c | 9 +++++----
>> 1 file changed, 5 insertions(+), 4 deletions(-)
>>
>> diff --git a/drivers/gpu/drm/mediatek/mtk_dsi.c b/drivers/gpu/drm/mediatek/mtk_dsi.c
>> index cfa45d6abd74..44ee884cc31c 100644
>> --- a/drivers/gpu/drm/mediatek/mtk_dsi.c
>> +++ b/drivers/gpu/drm/mediatek/mtk_dsi.c
>> @@ -182,7 +182,7 @@ struct mtk_dsi {
>> struct drm_encoder encoder;
>> struct drm_connector conn;
>> struct drm_panel *panel;
>> - struct drm_bridge *bridge;
>> + struct drm_bridge *next_bridge;
>> struct phy *phy;
>>
>> void __iomem *regs;
>> @@ -903,8 +903,9 @@ static int mtk_dsi_create_conn_enc(struct drm_device *drm, struct mtk_dsi *dsi)
>> dsi->encoder.possible_crtcs = 1;
>>
>> /* If there's a bridge, attach to it and let it create the connector */
>
> Maybe s/bridge/next bridge/ here ? I expect this comment to go away
> though, as there will always be a next bridge when the driver switches
> to the DRM panel bridge helper.
>
I'll rename it to next bridge for coherency, however, as you point this message
is removed later.
> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
>
>> - if (dsi->bridge) {
>> - ret = drm_bridge_attach(&dsi->encoder, dsi->bridge, NULL, 0);
>> + if (dsi->next_bridge) {
>> + ret = drm_bridge_attach(&dsi->encoder, dsi->next_bridge, NULL,
>> + 0);
>> if (ret) {
>> DRM_ERROR("Failed to attach bridge to drm\n");
>> goto err_encoder_cleanup;
>> @@ -1185,7 +1186,7 @@ static int mtk_dsi_probe(struct platform_device *pdev)
>> }
>>
>> ret = drm_of_find_panel_or_bridge(dev->of_node, 0, 0,
>> - &dsi->panel, &dsi->bridge);
>> + &dsi->panel, &dsi->next_bridge);
>> if (ret)
>> goto err_unregister_host;
>>
>
next prev parent reply other threads:[~2020-04-17 14:53 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-04-16 15:57 [PATCH v2 0/7] Convert mtk-dsi to drm_bridge API and get EDID for ps8640 bridge Enric Balletbo i Serra
2020-04-16 15:57 ` [PATCH v2 1/7] drm/bridge: ps8640: Get the EDID from eDP control Enric Balletbo i Serra
2020-04-16 17:22 ` Laurent Pinchart
2020-04-17 14:51 ` Enric Balletbo i Serra
2020-04-16 15:57 ` [PATCH v2 2/7] drm/bridge_connector: Set default status connected for eDP connectors Enric Balletbo i Serra
2020-04-16 17:22 ` Laurent Pinchart
2020-04-16 15:57 ` [PATCH v2 3/7] drm/mediatek: mtk_dsi: Rename bridge to next_bridge Enric Balletbo i Serra
2020-04-16 17:24 ` Laurent Pinchart
2020-04-17 14:53 ` Enric Balletbo i Serra [this message]
2020-04-16 15:57 ` [PATCH v2 4/7] drm/mediatek: mtk_dsi: Convert to bridge driver Enric Balletbo i Serra
2020-04-16 15:57 ` [PATCH v2 5/7] drm/mediatek: mtk_dsi: Use simple encoder Enric Balletbo i Serra
2020-04-16 17:28 ` Laurent Pinchart
2020-04-16 15:57 ` [PATCH v2 6/7] drm/mediatek: mtk_dsi: Use the drm_panel_bridge API Enric Balletbo i Serra
2020-04-16 17:33 ` Laurent Pinchart
2020-04-16 15:57 ` [PATCH v2 7/7] drm/mediatek: mtk_dsi: Create connector for bridges Enric Balletbo i Serra
2020-04-16 17:35 ` Laurent Pinchart
2020-04-16 17:36 ` Laurent Pinchart
2020-04-16 21:33 ` Enric Balletbo i Serra
2020-04-16 21:45 ` Laurent Pinchart
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=c1319dc1-5fdf-7e7d-1410-a23ed1d87d67@collabora.com \
--to=enric.balletbo@collabora.com \
--cc=airlied@linux.ie \
--cc=chunkuang.hu@kernel.org \
--cc=daniel@ffwll.ch \
--cc=dri-devel@lists.freedesktop.org \
--cc=drinkcat@chromium.org \
--cc=hsinyi@chromium.org \
--cc=kernel@collabora.com \
--cc=laurent.pinchart@ideasonboard.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mediatek@lists.infradead.org \
--cc=matthias.bgg@gmail.com \
--cc=p.zabel@pengutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®