From: Ping-Ke Shih <pkshih@realtek.com>
To: Mehmet Fide <mehmet.fide@gmail.com>
Cc: Bitterblue Smith <rtl8821cerfe2@gmail.com>,
"linux-wireless@vger.kernel.org" <linux-wireless@vger.kernel.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"mehmet.fide@screeningeagle.com" <mehmet.fide@screeningeagle.com>
Subject: RE: [PATCH rtw-next] wifi: rtw88: honour the transmit power mac80211 asks for
Date: Tue, 22 Sep 2026 06:48:14 +0000 [thread overview]
Message-ID: <c164023223334f7095ef2a28f6bada33@realtek.com> (raw)
In-Reply-To: <20260922062641.1313856-1-mehmet.fide@gmail.com>
Mehmet Fide <mehmet.fide@gmail.com> wrote:
> When I wrote v1 I did not know that rtw88 already exposes
> set_sar_specs. I have since verified it on the RTL8822BU: it caps the
> per-path index from the given dBm and covers our exposure case, so we
> will use it. That leaves the patch as a consistency question rather
> than a need of ours: should rtw88 honour the level mac80211 hands over,
> as ath9k and most other drivers do, instead of accepting it and letting
> mac80211 report it as applied? If you want that, a v2 with your review
> points addressed is ready and I will send it. If you prefer SAR to be
> the only way to lower the power on these chips, I will drop it.
I don't lean to either, but ...
> > > + if (changed & IEEE80211_CONF_CHANGE_CHANNEL)
> > > + rtw_set_channel(rtwdev);
> > > + else if (changed & IEEE80211_CONF_CHANGE_POWER)
> >
> > Should it be 'if' instead of 'else if'?
>
> rtw_set_channel() ends with rtw_phy_set_tx_power_level(), so when the
> channel changed the tables are already programmed with the level kept
> in rtw_hal, and a second pass would program the same values again. The
> explicit call is only needed when the level changed on its own, so I
> kept the else. If you prefer the plain if for readability I will change
> it.
Here should add a comment to be clear. It might become not clean...
Then I'd prefer SAR.
Ping-Ke
next prev parent reply other threads:[~2026-09-22 6:48 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-09-17 14:19 Mehmet Fide
2026-09-22 1:56 ` Ping-Ke Shih
2026-09-22 6:26 ` Mehmet Fide
2026-09-22 6:48 ` Ping-Ke Shih [this message]
2026-09-22 6:59 ` Mehmet Fide
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=c164023223334f7095ef2a28f6bada33@realtek.com \
--to=pkshih@realtek.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-wireless@vger.kernel.org \
--cc=mehmet.fide@gmail.com \
--cc=mehmet.fide@screeningeagle.com \
--cc=rtl8821cerfe2@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®