mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Javier Martinez Canillas <javierm@redhat.com>
To: Pekka Paalanen <ppaalanen@gmail.com>,
	Thomas Zimmermann <tzimmermann@suse.de>
Cc: "Jani Nikula" <jani.nikula@intel.com>,
	"Daniel Vetter" <daniel.vetter@ffwll.ch>,
	"Michel Dänzer" <michel@daenzer.net>,
	linux-kernel@vger.kernel.org, dri-devel@lists.freedesktop.org,
	"Peter Robinson" <pbrobinson@gmail.com>
Subject: Re: [PATCH v4 0/6] Cleanups for the nomodeset kernel command line parameter logic
Date: Fri, 12 Nov 2021 11:35:19 +0100	[thread overview]
Message-ID: <c1cbe6b4-0c86-b7a5-c2df-0ac3052dec6a@redhat.com> (raw)
In-Reply-To: <20211112122239.26b3787c@eldfell>

On 11/12/21 11:22, Pekka Paalanen wrote:

[snip]

>>>   
>>>> As this is just returning bool without changing anything, the usual
>>>> word to use is "is". Since this function is also used at most once per
>>>> driver, which is rarely, it could have a long and descriptive name.
>>>>
>>>> For example:
>>>>
>>>> bool drm_is_modeset_driver_allowed(void);  
>>
>> I'd nominate
>>
>>    bool drm_native_drivers_enabled()
>>
>> This is what HW-specific drivers want to query in their init/probing 
>> code. The actual semantics of this decision is hidden from the driver. 
>> It's also easier to read than the other name IMHO
> 
> Ok, but what is a "native driver"? Or a "non-native driver"?
> Is that established kernel terminology?
>

For me the term "native" is also vague. I would prefer to call it platform
specific driver or non-generic driver instead. A problem is that "platform
driver" has a very specific meaning in the kernel, which are drivers for
devices in the "platform" bus (which is also a very overloaded term).
 
> I'd think a non-native driver is something that e.g. ndiswrapper is

Yeah, that's why I think that "generic" and "non-generic" is a better way
to describe the drivers that could be used for any platform as long as the
hardware was already initialized and a struct screen_info filled with data.

> loading. Is simpledrm like ndiswrapper in a sense? IIRC, simpledrm is
> the driver that would not consult this function, right?
>

Correct.

Or maybe just 'bool drm_modeset_enabled()' ? After all, that's really what
the "nomodeset" kernel param disables. The fact that DRM drivers abuse that
boolean semantics to also prevent the drivers to load is a different topic.
 
> 
> Thanks,
> pq
> 
Best regards,
-- 
Javier Martinez Canillas
Linux Engineering
Red Hat


  reply	other threads:[~2021-11-12 10:35 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-11-08 14:06 Javier Martinez Canillas
2021-11-08 14:06 ` [PATCH v4 1/6] drm: Don't print messages if drivers are disabled due nomodeset Javier Martinez Canillas
2021-11-08 14:06 ` [PATCH v4 2/6] drm/vboxvideo: Drop CONFIG_VGA_CONSOLE guard to call vgacon_text_force() Javier Martinez Canillas
2021-11-08 14:06 ` [PATCH v4 3/6] drm: Move nomodeset kernel parameter to the DRM subsystem Javier Martinez Canillas
2021-11-08 14:06 ` [PATCH v4 4/6] drm: Decouple nomodeset from CONFIG_VGA_CONSOLE Javier Martinez Canillas
2021-11-08 14:06 ` [PATCH v4 5/6] Documentation/admin-guide: Document nomodeset kernel parameter Javier Martinez Canillas
2021-11-08 14:06 ` [PATCH v4 6/6] drm: Make the nomodeset message less sensational Javier Martinez Canillas
2021-11-08 14:17 ` [PATCH v4 0/6] Cleanups for the nomodeset kernel command line parameter logic Thomas Zimmermann
2021-11-12  8:56   ` Pekka Paalanen
2021-11-12  9:39     ` Javier Martinez Canillas
2021-11-12 10:09       ` Thomas Zimmermann
2021-11-12 10:22         ` Pekka Paalanen
2021-11-12 10:35           ` Javier Martinez Canillas [this message]
2021-11-12 10:37           ` Jani Nikula
2021-11-12 10:57           ` Thomas Zimmermann
2021-11-12 11:20             ` Javier Martinez Canillas
2021-11-12 11:23               ` Thomas Zimmermann
2021-11-12 12:10               ` Pekka Paalanen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=c1cbe6b4-0c86-b7a5-c2df-0ac3052dec6a@redhat.com \
    --to=javierm@redhat.com \
    --cc=daniel.vetter@ffwll.ch \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=jani.nikula@intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=michel@daenzer.net \
    --cc=pbrobinson@gmail.com \
    --cc=ppaalanen@gmail.com \
    --cc=tzimmermann@suse.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®