From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-6.8 required=3.0 tests=BAYES_00, HEADER_FROM_DIFFERENT_DOMAINS,INCLUDES_PATCH,MAILING_LIST_MULTI,SPF_HELO_NONE, SPF_PASS autolearn=no autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id D6C02C4363D for ; Fri, 25 Sep 2020 12:02:33 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id 6B38521D7A for ; Fri, 25 Sep 2020 12:02:33 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1728330AbgIYMCc (ORCPT ); Fri, 25 Sep 2020 08:02:32 -0400 Received: from smtprelay0152.hostedemail.com ([216.40.44.152]:39266 "EHLO smtprelay.hostedemail.com" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1727521AbgIYMCb (ORCPT ); Fri, 25 Sep 2020 08:02:31 -0400 Received: from filter.hostedemail.com (clb03-v110.bra.tucows.net [216.40.38.60]) by smtprelay06.hostedemail.com (Postfix) with ESMTP id B368518225647; Fri, 25 Sep 2020 12:02:30 +0000 (UTC) X-Session-Marker: 6A6F6540706572636865732E636F6D X-HE-Tag: apple13_2f1784c27167 X-Filterd-Recvd-Size: 1751 Received: from XPS-9350.home (unknown [47.151.133.149]) (Authenticated sender: joe@perches.com) by omf03.hostedemail.com (Postfix) with ESMTPA; Fri, 25 Sep 2020 12:02:28 +0000 (UTC) Message-ID: Subject: Re: [PATCH] drm/stm: dsi: Use dev_ based logging From: Joe Perches To: Yannick Fertre , Philippe Cornu , Antonio Borneo , Vincent Abriou , David Airlie , Daniel Vetter , Maxime Coquelin , Alexandre Torgue , dri-devel@lists.freedesktop.org, linux-stm32@st-md-mailman.stormreply.com, linux-arm-kernel@lists.infradead.org, linux-kernel@vger.kernel.org Date: Fri, 25 Sep 2020 05:02:27 -0700 In-Reply-To: <20200925102233.18016-1-yannick.fertre@st.com> References: <20200925102233.18016-1-yannick.fertre@st.com> Content-Type: text/plain; charset="ISO-8859-1" User-Agent: Evolution 3.36.4-0ubuntu1 MIME-Version: 1.0 Content-Transfer-Encoding: 7bit Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Fri, 2020-09-25 at 12:22 +0200, Yannick Fertre wrote: > Standardize on the dev_ based logging and drop the include of drm_print.h. > Remove useless dsi_color_from_mipi function. [] > diff --git a/drivers/gpu/drm/stm/dw_mipi_dsi-stm.c b/drivers/gpu/drm/stm/dw_mipi_dsi-stm.c [] > - DRM_DEBUG_DRIVER("pll_in %ukHz pll_out %ukHz lane_mbps %uMHz\n", > - pll_in_khz, pll_out_khz, *lane_mbps); > + dev_dbg(dsi->dev, "pll_in %ukHz pll_out %ukHz lane_mbps %uMHz\n", pll_in_khz, pll_out_khz, > + *lane_mbps); The line wrapping change here is pretty pointless and IMO makes the code harder to read.