From: Sumit Saxena <sumit.saxena@avagotech.com>
To: Frans Klaver <fransklaver@gmail.com>
Cc: Nicholas Krause <xerofoify@gmail.com>,
Kashyap Desai <kashyap.desai@avagotech.com>,
Uday Lingala <uday.lingala@avagotech.com>,
JBottomley@odin.com,
"PDL,MEGARAIDLINUX" <megaraidlinux.pdl@avagotech.com>,
linux-scsi@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: RE: [PATCH] megaraid:Remove no longer required variable ret from the function megasas_sync_map_info
Date: Tue, 7 Jul 2015 16:34:51 +0530 [thread overview]
Message-ID: <c379ae3f27d2ffc8cdc6b9e3cf2b989a@mail.gmail.com> (raw)
In-Reply-To: <CAH6sp9P4giamp-AQ_Ec3g-x8dcSXhgZo-1Wt8R7P2-p0-8Bbsw@mail.gmail.com>
> -----Original Message-----
> From: Frans Klaver [mailto:fransklaver@gmail.com]
> Sent: Tuesday, July 07, 2015 3:37 PM
> To: Sumit Saxena
> Cc: Nicholas Krause; Kashyap Desai; Uday Lingala; JBottomley@odin.com;
> PDL,MEGARAIDLINUX; linux-scsi@vger.kernel.org;
> linux-kernel@vger.kernel.org
> Subject: Re: [PATCH] megaraid:Remove no longer required variable ret from
> the
> function megasas_sync_map_info
>
> Can't seem to find the original, so here's a reply to the ack mail.
>
> On Tue, Jul 7, 2015 at 10:49 AM, Sumit Saxena <sumit.saxena@avagotech.com>
> wrote:
> > -----Original Message-----
> > From: Nicholas Krause [mailto:xerofoify@gmail.com]
> > Sent: Monday, July 06, 2015 9:43 PM
> > To: kashyap.desai@avagotech.com
> > Cc: sumit.saxena@avagotech.com; uday.lingala@avagotech.com;
> > JBottomley@odin.com; megaraidlinux.pdl@avagotech.com;
> > linux-scsi@vger.kernel.org; linux-kernel@vger.kernel.org
> > Subject: [PATCH] megaraid:Remove no longer required variable ret from
> > the function megasas_sync_map_info
>
> Isn't something shorter like
>
> [PATCH] megaraid: remove pointless variable
>
> much more readable?
>
>
> > This removes the no longer required variable ret due to this variable
> > only ever being used at the end of the function megasas_sync_map_info
> > without changing it's value from the orginal setting of its value to
> > zero due to this just remove the variable ret and just return the
> > value of zero directly here in order to indicate to the caller the
> > call to this function has run successfully without any non recoverable
> > issues.
>
> No interpunction?
>
>
> > Signed-off-by: Nicholas Krause <xerofoify@gmail.com>
> > ---
> > drivers/scsi/megaraid/megaraid_sas_fusion.c | 4 ++--
> > 1 file changed, 2 insertions(+), 2 deletions(-)
> >
> > diff --git a/drivers/scsi/megaraid/megaraid_sas_fusion.c
> > b/drivers/scsi/megaraid/megaraid_sas_fusion.c
> > index 46a0f8f..b5a8c65 100644
> > --- a/drivers/scsi/megaraid/megaraid_sas_fusion.c
> > +++ b/drivers/scsi/megaraid/megaraid_sas_fusion.c
> > @@ -836,7 +836,7 @@ megasas_get_map_info(struct megasas_instance
> > *instance) int megasas_sync_map_info(struct megasas_instance
> > *instance) {
> > - int ret = 0, i;
> > + int i;
> > struct megasas_cmd *cmd;
> > struct megasas_dcmd_frame *dcmd;
> > u32 size_sync_info, num_lds;
> > @@ -906,7 +906,7 @@ megasas_sync_map_info(struct megasas_instance
> > *instance)
> >
> > instance->instancet->issue_dcmd(instance, cmd);
> >
> > - return ret;
> > + return 0;
> > }
> >
> > Acked-by: Sumit Saxena <sumit.saxena@avagotech.com>
>
> This ack in an outlook-style response confused the hell out of me ;).
Sorry for confusion. I just got new laptop with default outlook settings so
last message sent was in outlook-style, configured it now.
Thanks,
Sumit
>
> Thanks,
> Frans
prev parent reply other threads:[~2015-07-07 11:05 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <1436199198-16415-1-git-send-email-xerofoify@gmail.com>
2015-07-07 8:49 ` Sumit Saxena
2015-07-07 10:07 ` Frans Klaver
2015-07-07 11:04 ` Sumit Saxena [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=c379ae3f27d2ffc8cdc6b9e3cf2b989a@mail.gmail.com \
--to=sumit.saxena@avagotech.com \
--cc=JBottomley@odin.com \
--cc=fransklaver@gmail.com \
--cc=kashyap.desai@avagotech.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-scsi@vger.kernel.org \
--cc=megaraidlinux.pdl@avagotech.com \
--cc=uday.lingala@avagotech.com \
--cc=xerofoify@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome