From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753755AbeAVIyR (ORCPT ); Mon, 22 Jan 2018 03:54:17 -0500 Received: from esa6.microchip.iphmx.com ([216.71.154.253]:40767 "EHLO esa6.microchip.iphmx.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753728AbeAVIyN (ORCPT ); Mon, 22 Jan 2018 03:54:13 -0500 X-IronPort-AV: E=Sophos;i="5.44,434,1505804400"; d="scan'208";a="8067520" Subject: Re: [PATCH v2 10/16] pwm: Add PWM modes To: Rob Herring CC: , , , , , , , , , , , , , , , References: <1515766983-15151-1-git-send-email-claudiu.beznea@microchip.com> <1515766983-15151-11-git-send-email-claudiu.beznea@microchip.com> <20180119223452.doeqfd4aewkf5fla@rob-hp-laptop> From: Claudiu Beznea Message-ID: Date: Mon, 22 Jan 2018 10:54:07 +0200 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.5.0 MIME-Version: 1.0 In-Reply-To: <20180119223452.doeqfd4aewkf5fla@rob-hp-laptop> Content-Type: text/plain; charset="utf-8" Content-Language: en-US Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 20.01.2018 00:34, Rob Herring wrote: > On Fri, Jan 12, 2018 at 04:22:57PM +0200, Claudiu Beznea wrote: >> Define a macros for PWM modes to be used by device tree sources. >> >> Signed-off-by: Claudiu Beznea >> --- >> include/dt-bindings/pwm/pwm.h | 3 +++ >> 1 file changed, 3 insertions(+) >> >> diff --git a/include/dt-bindings/pwm/pwm.h b/include/dt-bindings/pwm/pwm.h >> index ab9a077e3c7d..b8617431f8ec 100644 >> --- a/include/dt-bindings/pwm/pwm.h >> +++ b/include/dt-bindings/pwm/pwm.h >> @@ -12,4 +12,7 @@ >> >> #define PWM_POLARITY_INVERTED (1 << 0) >> >> +#define PWM_DTMODE_NORMAL (1 << 0) > > Bit 0 is already taken. I think you mean (0 << 1)? I wanted to have the PWM modes in a new cell, so that the pwms binding to be something like: pwms= If you think it is mode feasible to also include PWM mode in the cell for PWM flags, please let me know. > > Personally, I'd just drop this define. A define for a 0 value makes more > sense when each state is equally used (like active high or low), but if > 0 is the more common case, then I don't the need for a define. I want it to have these defines like bit defines: PWM_DTMODE_NORMAL=0x1 PWM_DTMODE_COMPLEMENTARY=0x2 PWM_DTMODE_PUSH_PULL=0x4 Thank you, Claudiu Beznea > >> +#define PWM_DTMODE_COMPLEMENTARY (1 << 1) >> + >> #endif >> -- >> 2.7.4 >> >