mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Ben Horgan <ben.horgan@arm.com>
To: Jonathan Cameron <jonathan.cameron@huawei.com>
Cc: amitsinght@marvell.com, baisheng.gao@unisoc.com,
	baolin.wang@linux.alibaba.com, carl@os.amperecomputing.com,
	dave.martin@arm.com, david@kernel.org, dfustini@baylibre.com,
	fenghuay@nvidia.com, gshan@redhat.com, james.morse@arm.com,
	kobak@nvidia.com, lcherian@marvell.com,
	linux-arm-kernel@lists.infradead.org,
	linux-kernel@vger.kernel.org, peternewman@google.com,
	punit.agrawal@oss.qualcomm.com, quic_jiles@quicinc.com,
	reinette.chatre@intel.com, rohit.mathew@arm.com,
	scott@os.amperecomputing.com, sdonthineni@nvidia.com,
	tan.shaopeng@fujitsu.com, xhao@linux.alibaba.com,
	catalin.marinas@arm.com, will@kernel.org, corbet@lwn.net,
	maz@kernel.org, oupton@kernel.org, joey.gouly@arm.com,
	suzuki.poulose@arm.com, kvmarm@lists.linux.dev
Subject: Re: [PATCH v2 15/45] arm_mpam: resctrl: Add boilerplate cpuhp and domain allocation
Date: Tue, 6 Jan 2026 11:17:27 +0000	[thread overview]
Message-ID: <c6c0acfa-8a9f-4c97-a116-40a2d20f6827@arm.com> (raw)
In-Reply-To: <20260105174005.00001ba0@huawei.com>

Hi Jonathan,

On 1/5/26 17:40, Jonathan Cameron wrote:
> On Fri, 19 Dec 2025 18:11:17 +0000
> Ben Horgan <ben.horgan@arm.com> wrote:
> 
>> From: James Morse <james.morse@arm.com>
>>
>> resctrl has its own data structures to describe its resources. We can't use
>> these directly as we play tricks with the 'MBA' resource, picking the MPAM
>> controls or monitors that best apply. We may export the same component as
>> both L3 and MBA.
>>
>> Add mpam_resctrl_exports[] as the array of class->resctrl mappings we are
>> exporting, and add the cpuhp hooks that allocated and free the resctrl
>> domain structures.
>>
>> While we're here, plumb in a few other obvious things.
>>
>> CONFIG_ARM_CPU_RESCTRL is used to allow this code to be built even though
>> it can't yet be linked against resctrl.
>>
>> Signed-off-by: James Morse <james.morse@arm.com>
>> Signed-off-by: Ben Horgan <ben.horgan@arm.com>
>> ---
>> Domain list is an rcu list
>> Add synchronize_rcu() to free the deleted element
>> Code flow simplification (Jonathan)
> 
> Just trivial stuff and that one what do we loop over thing that
> we continued discussing in the RFC thread (I think you already
> tidied that up)  Nothing here to stop:
> Reviewed-by: Jonathan Cameron <jonathan.cameron@huawei.com>
> (which is another way of saying I'm not planning to read it again :)

Yes, I've already made that change locally :) and just added your other
suggestions below.

> 
> 
>> diff --git a/drivers/resctrl/mpam_resctrl.c b/drivers/resctrl/mpam_resctrl.c
>> new file mode 100644
>> index 000000000000..4beeeded00ff
>> --- /dev/null
>> +++ b/drivers/resctrl/mpam_resctrl.c
> 
>> +
>> +static int mpam_resctrl_pick_domain_id(int cpu, struct mpam_component *comp)
>> +{
>> +	struct mpam_class *class = comp->class;
>> +
>> +	if (class->type == MPAM_CLASS_CACHE)
>> +		return comp->comp_id;
>> +
>> +	/* TODO: repaint domain ids to match the L3 domain ids */
>> +	/*
>> +	 * Otherwise, expose the ID used by the firmware table code.
> Maybe more turns up in here. Otherwise, easily fits in single line comment.
>> +	 */
>> +	return comp->comp_id;
>> +}
> 
>> +static struct mpam_resctrl_dom *
>> +mpam_resctrl_get_domain_from_cpu(int cpu, struct mpam_resctrl_res *res)
>> +{
>> +	struct mpam_resctrl_dom *dom;
>> +	struct rdt_ctrl_domain *ctrl_d;
>> +	struct rdt_resource *r = &res->resctrl_res;
>> +
>> +	lockdep_assert_cpus_held();
>> +
>> +	list_for_each_entry_rcu(ctrl_d, &r->ctrl_domains, hdr.list) {
> 
> As a reminder, though I think you already changed this, discussion carried
> on wrt to the RFC version of this loop.
> 
>> +		dom = container_of(ctrl_d, struct mpam_resctrl_dom,
>> +				   resctrl_ctrl_dom);
>> +
>> +		if (cpumask_test_cpu(cpu, &dom->ctrl_comp->affinity))
>> +			return dom;
>> +	}
>> +
>> +	return NULL;
>> +}
> 
>> +
>> +void mpam_resctrl_offline_cpu(unsigned int cpu)
>> +{
>> +	resctrl_offline_cpu(cpu);
>> +
>> +	guard(mutex)(&domain_list_lock);
>> +	for (int i = 0; i < RDT_NUM_RESOURCES; i++) {
>> +		struct mpam_resctrl_res *res;
>> +		struct mpam_resctrl_dom *dom;
>> +		struct rdt_mon_domain *mon_d;
>> +		struct rdt_ctrl_domain *ctrl_d;
>> +		bool ctrl_dom_empty, mon_dom_empty;
>> +
>> +		res = &mpam_resctrl_controls[i];
>> +		if (!res->class)
>> +			continue;	// dummy resource
>> +
>> +		dom = mpam_resctrl_get_domain_from_cpu(cpu, res);
>> +		if (WARN_ON_ONCE(!dom))
>> +			continue;
>> +
>> +		ctrl_dom_empty = true;
>> +		if (exposed_alloc_capable) {
>> +			ctrl_d = &dom->resctrl_ctrl_dom;
>> +			ctrl_dom_empty = mpam_resctrl_offline_domain_hdr(cpu, &ctrl_d->hdr);
>> +			if (ctrl_dom_empty)
>> +				resctrl_offline_ctrl_domain(&res->resctrl_res, ctrl_d);
>> +		}
> really small thing but I'd do 
> 		} else {
> 			ctrl_dom_empty = true;
> 		}
> here to make it visually obvious why that is set to true. The initialize and override
> if we have more info pattern is to me less readable.
> 
>> +
>> +		mon_dom_empty = true;
>> +		if (exposed_mon_capable) {
>> +			mon_d = &dom->resctrl_mon_dom;
>> +			mon_dom_empty = mpam_resctrl_offline_domain_hdr(cpu, &mon_d->hdr);
>> +			if (mon_dom_empty)
>> +				resctrl_offline_mon_domain(&res->resctrl_res, mon_d);
>> +		}
> Similar for this one.
>> +
>> +		if (ctrl_dom_empty && mon_dom_empty)
>> +			kfree(dom);
>> +	}
>> +}
> 

-- 
Thanks,

Ben


  reply	other threads:[~2026-01-06 11:17 UTC|newest]

Thread overview: 120+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-12-19 18:11 [PATCH v2 00/45] arm_mpam: Add KVM/arm64 and resctrl glue code Ben Horgan
2025-12-19 18:11 ` [PATCH v2 01/45] arm_mpam: Stop using uninitialized variables in __ris_msmon_read() Ben Horgan
2025-12-23 11:58   ` Jonathan Cameron
2025-12-19 18:11 ` [PATCH v2 02/45] arm_mpam: Remove duplicate linux/srcu.h header Ben Horgan
2025-12-23 12:10   ` Jonathan Cameron
2025-12-19 18:11 ` [PATCH v2 03/45] arm_mpam: Use non-atomic bitops when modifying feature bitmap Ben Horgan
2026-01-05 16:34   ` Jonathan Cameron
2026-01-06 11:11     ` Ben Horgan
2025-12-19 18:11 ` [PATCH v2 04/45] arm64/sysreg: Add MPAMSM_EL1 register Ben Horgan
2026-01-05 16:36   ` Jonathan Cameron
2025-12-19 18:11 ` [PATCH v2 05/45] KVM: arm64: Preserve host MPAM configuration when changing traps Ben Horgan
2025-12-19 20:01   ` Oliver Upton
2026-01-02 11:43     ` Ben Horgan
2026-01-05 16:43   ` Jonathan Cameron
2025-12-19 18:11 ` [PATCH v2 06/45] KVM: arm64: Make MPAMSM_EL1 accesses UNDEF Ben Horgan
2026-01-05 16:47   ` Jonathan Cameron
2026-01-05 16:57     ` Ben Horgan
2025-12-19 18:11 ` [PATCH v2 07/45] arm64: mpam: Context switch the MPAM registers Ben Horgan
2026-01-05 17:04   ` Jonathan Cameron
2026-01-06 11:14     ` Ben Horgan
2026-01-06 14:03       ` Jonathan Cameron
2026-01-08 10:06   ` Shaopeng Tan (Fujitsu)
2026-01-09  9:28     ` Ben Horgan
2025-12-19 18:11 ` [PATCH v2 08/45] arm64: mpam: Re-initialise MPAM regs when CPU comes online Ben Horgan
2026-01-05 17:06   ` Jonathan Cameron
2025-12-19 18:11 ` [PATCH v2 09/45] arm64: mpam: Advertise the CPUs MPAM limits to the driver Ben Horgan
2026-01-05 17:08   ` Jonathan Cameron
2025-12-19 18:11 ` [PATCH v2 10/45] arm64: mpam: Add cpu_pm notifier to restore MPAM sysregs Ben Horgan
2026-01-05 17:09   ` Jonathan Cameron
2025-12-19 18:11 ` [PATCH v2 11/45] arm64: mpam: Initialise and context switch the MPAMSM_EL1 register Ben Horgan
2026-01-05 17:20   ` Jonathan Cameron
2025-12-19 18:11 ` [PATCH v2 12/45] arm64: mpam: Add helpers to change a task or cpu's MPAM PARTID/PMG values Ben Horgan
2026-01-05 17:21   ` Jonathan Cameron
2026-01-08 10:18   ` Shaopeng Tan (Fujitsu)
2026-01-09  9:37     ` Ben Horgan
2025-12-19 18:11 ` [PATCH v2 13/45] KVM: arm64: Force guest EL1 to use user-space's partid configuration Ben Horgan
2025-12-19 20:10   ` Oliver Upton
2026-01-02 11:48     ` Ben Horgan
2025-12-19 18:11 ` [PATCH v2 14/45] KVM: arm64: Use kernel-space partid configuration for hypercalls Ben Horgan
2025-12-19 18:11 ` [PATCH v2 15/45] arm_mpam: resctrl: Add boilerplate cpuhp and domain allocation Ben Horgan
2026-01-05 17:40   ` Jonathan Cameron
2026-01-06 11:17     ` Ben Horgan [this message]
2026-01-08 10:36   ` Shaopeng Tan (Fujitsu)
2026-01-09  9:55     ` Ben Horgan
2025-12-19 18:11 ` [PATCH v2 16/45] arm_mpam: resctrl: Sort the order of the domain lists Ben Horgan
2026-01-05 17:42   ` Jonathan Cameron
2025-12-19 18:11 ` [PATCH v2 17/45] arm_mpam: resctrl: Pick the caches we will use as resctrl resources Ben Horgan
2026-01-05 17:46   ` Jonathan Cameron
2025-12-19 18:11 ` [PATCH v2 18/45] arm_mpam: resctrl: Implement resctrl_arch_reset_all_ctrls() Ben Horgan
2026-01-05 17:51   ` Jonathan Cameron
2026-01-06 11:19     ` Ben Horgan
2026-01-09  3:45     ` Zeng Heng
2026-01-13 17:18       ` Ben Horgan
2025-12-19 18:11 ` [PATCH v2 19/45] arm_mpam: resctrl: Add resctrl_arch_get_config() Ben Horgan
2026-01-05 17:53   ` Jonathan Cameron
2025-12-19 18:11 ` [PATCH v2 20/45] arm_mpam: resctrl: Implement helpers to update configuration Ben Horgan
2026-01-05 17:58   ` Jonathan Cameron
2025-12-19 18:11 ` [PATCH v2 21/45] arm_mpam: resctrl: Add plumbing against arm64 task and cpu hooks Ben Horgan
2026-01-05 18:02   ` Jonathan Cameron
2025-12-19 18:11 ` [PATCH v2 22/45] arm_mpam: resctrl: Add CDP emulation Ben Horgan
2026-01-05 18:07   ` Jonathan Cameron
2026-01-06 11:21     ` Ben Horgan
2025-12-19 18:11 ` [PATCH v2 23/45] arm_mpam: resctrl: Add rmid index helpers Ben Horgan
2026-01-06 11:21   ` Jonathan Cameron
2026-01-06 11:33     ` Ben Horgan
2026-01-06 14:04       ` Jonathan Cameron
2026-01-06 15:23         ` Ben Horgan
2025-12-19 18:11 ` [PATCH v2 24/45] arm_mpam: resctrl: Convert to/from MPAMs fixed-point formats Ben Horgan
2026-01-06 11:55   ` Jonathan Cameron
2025-12-19 18:11 ` [PATCH v2 25/45] arm_mpam: resctrl: Add support for 'MB' resource Ben Horgan
2025-12-27  8:10   ` [PATCH v2 0/45] arm_mpam: Add KVM/arm64 and resctrl glue code Zeng Heng
2026-01-06 12:19   ` [PATCH v2 25/45] arm_mpam: resctrl: Add support for 'MB' resource Jonathan Cameron
2026-01-07 14:21     ` Ben Horgan
2026-01-08 10:42   ` Shaopeng Tan (Fujitsu)
2026-01-12 16:45     ` Ben Horgan
2025-12-19 18:11 ` [PATCH v2 26/45] arm_mpam: resctrl: Add kunit test for control format conversions Ben Horgan
2026-01-06 12:30   ` Jonathan Cameron
2025-12-19 18:11 ` [PATCH v2 27/45] arm_mpam: resctrl: Add support for csu counters Ben Horgan
2026-01-06 12:40   ` Jonathan Cameron
2026-01-08 10:44   ` Shaopeng Tan (Fujitsu)
2026-01-08 10:52     ` Ben Horgan
2025-12-19 18:11 ` [PATCH v2 28/45] arm_mpam: resctrl: Pick classes for use as mbm counters Ben Horgan
2026-01-06 14:01   ` Jonathan Cameron
2026-01-07 15:19     ` Ben Horgan
2025-12-19 18:11 ` [PATCH v2 29/45] arm_mpam: resctrl: Pre-allocate free running monitors Ben Horgan
2026-01-06 14:22   ` Jonathan Cameron
2026-01-08 14:25     ` Ben Horgan
2025-12-19 18:11 ` [PATCH v2 30/45] arm_mpam: resctrl: Pre-allocate assignable monitors Ben Horgan
2026-01-06 14:29   ` Jonathan Cameron
2026-01-08 14:33     ` Ben Horgan
2025-12-19 18:11 ` [PATCH v2 31/45] arm_mpam: resctrl: Add kunit test for ABMC/CDP interactions Ben Horgan
2025-12-19 18:11 ` [PATCH v2 32/45] arm_mpam: resctrl: Add resctrl_arch_config_cntr() for ABMC use Ben Horgan
2026-01-06 14:33   ` Jonathan Cameron
2025-12-19 18:11 ` [PATCH v2 33/45] arm_mpam: resctrl: Allow resctrl to allocate monitors Ben Horgan
2026-01-06 14:37   ` Jonathan Cameron
2025-12-19 18:11 ` [PATCH v2 34/45] arm_mpam: resctrl: Add resctrl_arch_rmid_read() and resctrl_arch_reset_rmid() Ben Horgan
2026-01-06 14:43   ` Jonathan Cameron
2025-12-19 18:11 ` [PATCH v2 35/45] arm_mpam: resctrl: Add resctrl_arch_cntr_read() & resctrl_arch_reset_cntr() Ben Horgan
2026-01-06 14:44   ` Jonathan Cameron
2025-12-19 18:11 ` [PATCH v2 36/45] arm_mpam: resctrl: Update the rmid reallocation limit Ben Horgan
2026-01-06 14:46   ` Jonathan Cameron
2025-12-19 18:11 ` [PATCH v2 37/45] arm_mpam: resctrl: Add empty definitions for assorted resctrl functions Ben Horgan
2026-01-06 14:48   ` Jonathan Cameron
2025-12-19 18:11 ` [PATCH v2 38/45] arm64: mpam: Select ARCH_HAS_CPU_RESCTRL Ben Horgan
2026-01-06 14:49   ` Jonathan Cameron
2025-12-19 18:11 ` [PATCH v2 39/45] arm_mpam: resctrl: Call resctrl_init() on platforms that can support resctrl Ben Horgan
2026-01-06 14:58   ` Jonathan Cameron
2026-01-08 14:53     ` Ben Horgan
2025-12-19 18:11 ` [PATCH v2 40/45] arm_mpam: Generate a configuration for min controls Ben Horgan
2026-01-06 15:09   ` Jonathan Cameron
2026-01-08 15:35     ` Ben Horgan
2025-12-19 18:11 ` [PATCH v2 41/45] arm_mpam: Add quirk framework Ben Horgan
2026-01-06 15:14   ` Jonathan Cameron
2026-01-06 15:15     ` Jonathan Cameron
2025-12-19 18:11 ` [PATCH v2 42/45] arm_mpam: Add workaround for T241-MPAM-1 Ben Horgan
2025-12-19 18:11 ` [PATCH v2 43/45] arm_mpam: Add workaround for T241-MPAM-4 Ben Horgan
2026-01-06 15:20   ` Jonathan Cameron
2025-12-19 18:11 ` [PATCH v2 44/45] arm_mpam: Add workaround for T241-MPAM-6 Ben Horgan
2025-12-19 18:11 ` [PATCH v2 45/45] arm_mpam: Quirk CMN-650's CSU NRDY behaviour Ben Horgan
2026-01-08 19:22 ` (subset) [PATCH v2 00/45] arm_mpam: Add KVM/arm64 and resctrl glue code Catalin Marinas

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=c6c0acfa-8a9f-4c97-a116-40a2d20f6827@arm.com \
    --to=ben.horgan@arm.com \
    --cc=amitsinght@marvell.com \
    --cc=baisheng.gao@unisoc.com \
    --cc=baolin.wang@linux.alibaba.com \
    --cc=carl@os.amperecomputing.com \
    --cc=catalin.marinas@arm.com \
    --cc=corbet@lwn.net \
    --cc=dave.martin@arm.com \
    --cc=david@kernel.org \
    --cc=dfustini@baylibre.com \
    --cc=fenghuay@nvidia.com \
    --cc=gshan@redhat.com \
    --cc=james.morse@arm.com \
    --cc=joey.gouly@arm.com \
    --cc=jonathan.cameron@huawei.com \
    --cc=kobak@nvidia.com \
    --cc=kvmarm@lists.linux.dev \
    --cc=lcherian@marvell.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=maz@kernel.org \
    --cc=oupton@kernel.org \
    --cc=peternewman@google.com \
    --cc=punit.agrawal@oss.qualcomm.com \
    --cc=quic_jiles@quicinc.com \
    --cc=reinette.chatre@intel.com \
    --cc=rohit.mathew@arm.com \
    --cc=scott@os.amperecomputing.com \
    --cc=sdonthineni@nvidia.com \
    --cc=suzuki.poulose@arm.com \
    --cc=tan.shaopeng@fujitsu.com \
    --cc=will@kernel.org \
    --cc=xhao@linux.alibaba.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®