From: Julien Thierry <jthierry@redhat.com>
To: linux-kernel@vger.kernel.org
Cc: jpoimboe@redhat.com, peterz@infradead.org, mbenes@suse.cz,
raphael.gault@arm.com, benh@kernel.crashing.org
Subject: Re: [PATCH v3 00/10] Make check implementation arch agnostic
Date: Fri, 4 Sep 2020 16:36:28 +0100 [thread overview]
Message-ID: <c74c803a-82de-188f-d2c7-6d75bfa8104a@redhat.com> (raw)
In-Reply-To: <20200904152755.32372-1-jthierry@redhat.com>
Hi,
Apologies again about the duplicate. It seems like I have issues sending
batched emails...
This thread can be ignored.
On 9/4/20 4:27 PM, Julien Thierry wrote:
> Hi,
>
> The current implementation of the check subcommand has various x86 bits
> here and there. In order to prepare objtool to provide check for other
> architectures, add some abstraction over the x86 specific bits, relying
> on objtool arch specific code to provide some necessary operations.
>
> This is part of the effort to implement check for arm64, initiated [1]
> by Raphael. The series is based on top of the separation of check & orc
> subcommands series[2].
>
> I've push both series base on top of tip/objtool/core at [3].
>
> - The first two patches make it simpler for new arches to provide their
> list of kernel headers, without worrying about modifications in the x86
> headers.
> - Patch 3 Moves arch specific macros to more suitable location
> - Patches 4 and 5 add abstraction to handle alternatives
> - Patch 6 adds abstraction to handle jump table
> - Patches 7-10 makes unwind hint definitions shared across architectures
>
> Changes since v2 [4]:
> - Rebased on v5.9-rc1
> - Under tools/objtool/arch/x86/, rename arch_special.c to special.c
> - Rename include/linux/frame.h to inclide/linux/objtool.h
> - Share unwind hint types across architectures
>
> [1] https://lkml.org/lkml/2019/8/16/400
> [2] https://lkml.org/lkml/2020/6/4/675
> [3] https://github.com/julien-thierry/linux/tree/arch-independent-check
> [4] https://lkml.org/lkml/2020/7/30/424
>
> Cheers,
>
> Julien
>
> -->
>
> Julien Thierry (9):
> objtool: Group headers to check in a single list
> objtool: Make sync-check consider the target architecture
> objtool: Move macros describing structures to arch-dependent code
> objtool: Abstract alternative special case handling
> objtool: Make relocation in alternative handling arch dependent
> headers: Rename frame.h
> objtool: Only include valid definitions depending on source file type
> objtool: Make unwind hints definitions available to other
> architectures
> objtool: Decode unwind hint register depending on architecture
>
> Raphael Gault (1):
> objtool: Refactor switch-tables code to support other architectures
>
> arch/x86/include/asm/nospec-branch.h | 2 +-
> arch/x86/include/asm/orc_types.h | 34 ----
> arch/x86/include/asm/unwind_hints.h | 50 +-----
> arch/x86/kernel/kprobes/core.c | 2 +-
> arch/x86/kernel/kprobes/opt.c | 2 +-
> arch/x86/kernel/reboot.c | 2 +-
> arch/x86/kernel/unwind_orc.c | 11 +-
> arch/x86/kvm/svm/svm.c | 2 +-
> arch/x86/kvm/vmx/nested.c | 2 +-
> arch/x86/kvm/vmx/vmx.c | 2 +-
> arch/x86/xen/enlighten_pv.c | 2 +-
> drivers/gpu/drm/vmwgfx/vmwgfx_msg.c | 3 +-
> include/linux/frame.h | 35 -----
> include/linux/objtool.h | 134 ++++++++++++++++
> kernel/bpf/core.c | 2 +-
> kernel/kexec_core.c | 2 +-
> tools/arch/x86/include/asm/orc_types.h | 34 ----
> tools/include/linux/objtool.h | 134 ++++++++++++++++
> tools/objtool/Makefile | 2 +-
> tools/objtool/arch.h | 2 +
> tools/objtool/arch/x86/Build | 1 +
> tools/objtool/arch/x86/decode.c | 37 +++++
> tools/objtool/arch/x86/include/arch_special.h | 20 +++
> tools/objtool/arch/x86/special.c | 145 ++++++++++++++++++
> tools/objtool/check.c | 137 ++---------------
> tools/objtool/check.h | 7 +-
> tools/objtool/objtool.h | 2 +
> tools/objtool/orc_dump.c | 7 +-
> tools/objtool/orc_gen.c | 5 +-
> tools/objtool/special.c | 48 +-----
> tools/objtool/special.h | 10 ++
> tools/objtool/sync-check.sh | 27 ++--
> tools/objtool/weak.c | 2 -
> 33 files changed, 561 insertions(+), 346 deletions(-)
> delete mode 100644 include/linux/frame.h
> create mode 100644 include/linux/objtool.h
> create mode 100644 tools/include/linux/objtool.h
> create mode 100644 tools/objtool/arch/x86/include/arch_special.h
> create mode 100644 tools/objtool/arch/x86/special.c
>
> --
> 2.21.3
>
--
Julien Thierry
next prev parent reply other threads:[~2020-09-04 15:36 UTC|newest]
Thread overview: 6+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-09-04 15:27 Julien Thierry
2020-09-04 15:27 ` [PATCH v3 01/10] objtool: Group headers to check in a single list Julien Thierry
2020-09-04 15:36 ` Julien Thierry [this message]
2020-09-04 15:30 [PATCH v3 00/10] Make check implementation arch agnostic Julien Thierry
2020-09-04 18:55 ` Josh Poimboeuf
2020-09-11 10:43 ` Miroslav Benes
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=c74c803a-82de-188f-d2c7-6d75bfa8104a@redhat.com \
--to=jthierry@redhat.com \
--cc=benh@kernel.crashing.org \
--cc=jpoimboe@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mbenes@suse.cz \
--cc=peterz@infradead.org \
--cc=raphael.gault@arm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®