mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "David Rheinsberg" <david@readahead.eu>
To: "Alice Ryhl" <aliceryhl@google.com>
Cc: "John Hubbard" <jhubbard@nvidia.com>,
	"Danilo Krummrich" <dakr@kernel.org>,
	"Alexandre Courbot" <acourbot@nvidia.com>,
	"Joel Fernandes" <joelagnelf@nvidia.com>,
	"Timur Tabi" <ttabi@nvidia.com>,
	"Alistair Popple" <apopple@nvidia.com>,
	"Eliot Courtney" <ecourtney@nvidia.com>,
	"Shashank Sharma" <shashanks@nvidia.com>,
	"Zhi Wang" <zhiw@nvidia.com>, "David Airlie" <airlied@gmail.com>,
	"Simona Vetter" <simona@ffwll.ch>,
	"Bjorn Helgaas" <bhelgaas@google.com>,
	"Miguel Ojeda" <ojeda@kernel.org>,
	"Alex Gaynor" <alex.gaynor@gmail.com>,
	"Boqun Feng" <boqun.feng@gmail.com>,
	"Gary Guo" <gary@garyguo.net>,
	"Björn Roy Baron" <bjorn3_gh@protonmail.com>,
	"Benno Lossin" <lossin@kernel.org>,
	"Andreas Hindborg" <a.hindborg@kernel.org>,
	"Trevor Gross" <tmgross@umich.edu>,
	rust-for-linux@vger.kernel.org,
	LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v7 16/31] rust: ptr: add const_align_up()
Date: Fri, 20 Mar 2026 11:27:32 +0100	[thread overview]
Message-ID: <c7e8c581-5072-4184-ba75-783233bd52fc@app.fastmail.com> (raw)
In-Reply-To: <CAH5fLgh1WMaUpLGTGpWiVjrnTtgFt=hhoutQqxV5DOtrGVsfkA@mail.gmail.com>

Hi Alice!

On Fri, Mar 20, 2026, at 10:47 AM, Alice Ryhl wrote:
> On Fri, Mar 20, 2026 at 10:27 AM David Rheinsberg <david@readahead.eu> wrote:
>> Kinda off-topic: why doesn't `Alignment` store a u8 that represents the exponent, rather than the power? The left-shift when needing the power should be effectively free, shouldn't it? It would avoid all the unsafety in the impl.
>
> For one, it mirrors the design of the unstable stdlib Alignment type.
> For another, it'd make Alignment::of and similar a pain to implement.

Fair enough!

>> Do you need this helper then at all? I assume it is added because `Alignable` cannot be used in const. But it hard-codes `usize` as type, yet does not reflect that in the name. It comes down to which one is more readable, I guess:
>>
>>     const_align_up(value, align)
>> vs
>>     value.checked_next_multiple_of(align.as_usize())
>>
>> Meh, I don't mind too much. Just wanted to point out that the standard library provides this exactly.
>
> The stdlib implementation probably invokes an expensive division
> operation in place of our bitwise-and operation when the argument is
> not a compile-time constant value.

Fortunately, it does not! Yay! `Alignment::as_nonzero()` has enough annotations to produce competitive assembly. If you care, see my example on x86_64 below, which uses:

align_up1: v.checked_next_multiple_of(align.as_nonzero())
align_up2: const_align_up(v, align)

Thanks
David


align_up1:
        lea     rax, [rsi - 1]
        and     rax, rdi
        sub     rsi, rax
        lea     rdx, [rsi + rdi]
        cmp     rdx, rdi
        setae   cl
        test    rax, rax
        sete    al
        cmove   rdx, rdi
        or      al, cl
        movzx   eax, al
        ret

align_up2:
        lea     rdx, [rdi + rsi]
        dec     rdx
        xor     eax, eax
        cmp     rdx, rdi
        setae   al
        neg     rsi
        and     rdx, rsi
        ret

  reply	other threads:[~2026-03-20 10:27 UTC|newest]

Thread overview: 66+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-03-17 22:53 [PATCH v7 00/31] gpu: nova-core: firmware: Hopper/Blackwell support John Hubbard
2026-03-17 22:53 ` [PATCH v7 01/31] gpu: nova-core: Hopper/Blackwell: basic GPU identification John Hubbard
2026-03-17 22:53 ` [PATCH v7 02/31] gpu: nova-core: factor .fwsignature* selection into a new find_gsp_sigs_section() John Hubbard
2026-03-17 22:53 ` [PATCH v7 03/31] gpu: nova-core: use GPU Architecture to simplify HAL selections John Hubbard
2026-03-17 22:53 ` [PATCH v7 04/31] gpu: nova-core: move GPU init into Gpu::new() John Hubbard
2026-03-23 12:45   ` Alexandre Courbot
2026-03-25  3:23     ` John Hubbard
2026-03-17 22:53 ` [PATCH v7 05/31] gpu: nova-core: set DMA mask width based on GPU architecture John Hubbard
2026-03-23 13:02   ` Alexandre Courbot
2026-03-25  3:26     ` John Hubbard
2026-03-17 22:53 ` [PATCH v7 06/31] gpu: nova-core: Hopper/Blackwell: skip GFW boot waiting John Hubbard
2026-03-23 13:13   ` Alexandre Courbot
2026-03-25  3:26     ` John Hubbard
2026-03-17 22:53 ` [PATCH v7 07/31] gpu: nova-core: move firmware image parsing code to firmware.rs John Hubbard
2026-03-23 13:19   ` Alexandre Courbot
2026-03-25  3:30     ` John Hubbard
2026-03-25 11:06       ` Alexandre Courbot
2026-03-25 11:18         ` Miguel Ojeda
2026-03-25 11:16       ` Miguel Ojeda
2026-03-17 22:53 ` [PATCH v7 08/31] gpu: nova-core: factor out an elf_str() function John Hubbard
2026-03-17 22:53 ` [PATCH v7 09/31] gpu: nova-core: don't assume 64-bit firmware images John Hubbard
2026-03-17 22:53 ` [PATCH v7 10/31] gpu: nova-core: add support for 32-bit " John Hubbard
2026-03-17 22:53 ` [PATCH v7 11/31] gpu: nova-core: add auto-detection of 32-bit, 64-bit " John Hubbard
2026-03-17 22:53 ` [PATCH v7 12/31] gpu: nova-core: Hopper/Blackwell: add FMC firmware image, in support of FSP John Hubbard
2026-03-17 22:53 ` [PATCH v7 13/31] gpu: nova-core: Hopper/Blackwell: add FSP falcon engine stub John Hubbard
2026-03-17 22:53 ` [PATCH v7 14/31] gpu: nova-core: Hopper/Blackwell: add FSP falcon EMEM operations John Hubbard
2026-03-17 22:53 ` [PATCH v7 15/31] gpu: nova-core: Hopper/Blackwell: add FSP message infrastructure John Hubbard
2026-03-17 22:53 ` [PATCH v7 16/31] rust: ptr: add const_align_up() John Hubbard
2026-03-20  8:37   ` David Rheinsberg
2026-03-20  8:44     ` Alice Ryhl
2026-03-20  8:58       ` David Rheinsberg
2026-03-20  9:03         ` Alice Ryhl
2026-03-20  9:26           ` David Rheinsberg
2026-03-20  9:47             ` Alice Ryhl
2026-03-20 10:27               ` David Rheinsberg [this message]
2026-03-20 11:12                 ` Alice Ryhl
2026-03-20 13:14                   ` David Rheinsberg
2026-03-20 13:16                     ` Miguel Ojeda
2026-03-20 13:26                       ` Alice Ryhl
2026-03-20  9:48   ` Alice Ryhl
2026-03-20 13:36     ` Gary Guo
2026-03-17 22:53 ` [PATCH v7 17/31] gpu: nova-core: Hopper/Blackwell: calculate reserved FB heap size John Hubbard
2026-03-17 22:53 ` [PATCH v7 18/31] gpu: nova-core: add MCTP/NVDM protocol types for firmware communication John Hubbard
2026-03-18  0:01   ` John Hubbard
2026-03-18  0:21     ` Danilo Krummrich
2026-03-18  0:56       ` Alexandre Courbot
2026-03-18 12:36       ` Gary Guo
2026-03-18 19:14         ` John Hubbard
2026-03-17 22:53 ` [PATCH v7 19/31] gpu: nova-core: Hopper/Blackwell: add FSP secure boot completion waiting John Hubbard
2026-03-17 22:53 ` [PATCH v7 20/31] gpu: nova-core: Hopper/Blackwell: add FMC signature extraction John Hubbard
2026-03-17 22:53 ` [PATCH v7 21/31] gpu: nova-core: Hopper/Blackwell: add FSP send/receive messaging John Hubbard
2026-03-17 22:53 ` [PATCH v7 22/31] gpu: nova-core: Hopper/Blackwell: add FspCotVersion type John Hubbard
2026-03-17 22:53 ` [PATCH v7 23/31] gpu: nova-core: Hopper/Blackwell: larger non-WPR heap John Hubbard
2026-03-17 22:53 ` [PATCH v7 24/31] gpu: nova-core: Hopper/Blackwell: add FSP Chain of Trust boot John Hubbard
2026-03-17 22:53 ` [PATCH v7 25/31] gpu: nova-core: Blackwell: use correct sysmem flush registers John Hubbard
2026-03-17 22:53 ` [PATCH v7 26/31] gpu: nova-core: make WPR heap sizing fallible John Hubbard
2026-03-17 22:53 ` [PATCH v7 27/31] gpu: nova-core: Hopper/Blackwell: larger WPR2 (GSP) heap John Hubbard
2026-03-18 16:12   ` kernel test robot
2026-03-18 17:59     ` John Hubbard
2026-03-17 22:53 ` [PATCH v7 28/31] gpu: nova-core: refactor SEC2 booter loading into BooterFirmware::run() John Hubbard
2026-03-17 22:53 ` [PATCH v7 29/31] gpu: nova-core: Hopper/Blackwell: add GSP lockdown release polling John Hubbard
2026-03-17 22:53 ` [PATCH v7 30/31] gpu: nova-core: Hopper/Blackwell: new location for PCI config mirror John Hubbard
2026-03-17 22:53 ` [PATCH v7 31/31] gpu: nova-core: Hopper/Blackwell: integrate FSP boot path into boot() John Hubbard
2026-03-18 17:02   ` kernel test robot
2026-03-18 17:59     ` John Hubbard
2026-03-18 20:25 ` [PATCH v7 00/31] gpu: nova-core: firmware: Hopper/Blackwell support John Hubbard

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=c7e8c581-5072-4184-ba75-783233bd52fc@app.fastmail.com \
    --to=david@readahead.eu \
    --cc=a.hindborg@kernel.org \
    --cc=acourbot@nvidia.com \
    --cc=airlied@gmail.com \
    --cc=alex.gaynor@gmail.com \
    --cc=aliceryhl@google.com \
    --cc=apopple@nvidia.com \
    --cc=bhelgaas@google.com \
    --cc=bjorn3_gh@protonmail.com \
    --cc=boqun.feng@gmail.com \
    --cc=dakr@kernel.org \
    --cc=ecourtney@nvidia.com \
    --cc=gary@garyguo.net \
    --cc=jhubbard@nvidia.com \
    --cc=joelagnelf@nvidia.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=lossin@kernel.org \
    --cc=ojeda@kernel.org \
    --cc=rust-for-linux@vger.kernel.org \
    --cc=shashanks@nvidia.com \
    --cc=simona@ffwll.ch \
    --cc=tmgross@umich.edu \
    --cc=ttabi@nvidia.com \
    --cc=zhiw@nvidia.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®