From: Karunika Choo <karunika.choo@arm.com>
To: Steven Price <steven.price@arm.com>, dri-devel@lists.freedesktop.org
Cc: nd@arm.com, Boris Brezillon <boris.brezillon@collabora.com>,
Liviu Dudau <liviu.dudau@arm.com>,
Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
Maxime Ripard <mripard@kernel.org>,
Thomas Zimmermann <tzimmermann@suse.de>,
David Airlie <airlied@gmail.com>, Simona Vetter <simona@ffwll.ch>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v4 0/8] drm/panthor: Add support for Mali-G1 GPUs
Date: Tue, 25 Nov 2025 13:47:55 +0000 [thread overview]
Message-ID: <c80da36c-84e5-4a1c-a467-3cc9c46bf956@arm.com> (raw)
In-Reply-To: <b28a4dfd-035e-429d-848c-dd67adfb8fa7@arm.com>
On 14/11/2025 16:33, Steven Price wrote:
> Hi Karunika,
>
> This series doesn't seem to cleanly apply on drm-misc-next (and I can't
> figure out what base you used). Would you mind doing a rebase and resend?
>
> Thanks,
> Steve
>
Hi Steve,
I've rebased on top of ac364014 and sent out a v5.
Hopefully it works.
v5: https://lore.kernel.org/all/20251125125548.3282320-1-karunika.choo@arm.com/
Kind regards,
karunika Choo
> On 07/11/2025 14:24, Karunika Choo wrote:
>> This patch series extends the Panthor driver with basic support for
>> Mali-G1 GPUs.
>>
>> The v14 architecture introduces several hardware and register-level
>> changes compared to prior GPUs. This series adds the necessary
>> architecture-specific support infrastructure, power control and reset
>> handling for Mali-G1 GPUs.
>>
>> Patch Breakdown:
>> [Patch 1-2]: Refactor panthor_hw to introduce architecture-specific
>> hooks and abstractions to support the v14 architecture.
>> These patches introduce architecture-specific HW binding
>> for function pointers.
>> [Patch 3-5]: Adds basic L2 power on/off and soft reset support for the
>> PWR_CONTROL block introduced in v14.
>> [Patch 6]: Update MCU halt and warm boot operations to reflect the
>> GLB_REQ.STATE changes in v14. This ensures that the MCU is
>> properly halted and the correct operations are performed
>> on warm boot depending on the FW version.
>> [Patch 7]: Align endpoint_req with changes introduced in v14, where
>> the register is widened to 64-bit and shifed down by
>> 4-bytes. This patch adds the necessary infrastructure to
>> discern the correct endpoint_req register to use.
>> [Patch 8]: Enables Mali-G1 support on Panthor by adding HW bindings
>> for v14 architecture, product names and path to FW binary.
>>
>> v4:
>> * Fixed include and forward declaration issues.
>> * Addressed code format issues.
>> * Picked up R-bs from Steve.
>> * Link to v3: https://lore.kernel.org/all/20251027161334.854650-1-karunika.choo@arm.com/
>> v3:
>> * Updated include logic to enable static inline functions in
>> panthor_hw.h for function pointers and feature checks.
>> * Fixed missed replacement of CSF_IFACE_VERSION check with
>> panthor_fw_has_glb_state() check.
>> * Link to v2: https://lore.kernel.org/all/20251024202117.3241292-1-karunika.choo@arm.com/
>> v2:
>> * Merged GPU_ID refactoring patch with the arch-specific panthor_hw
>> binding patch (formerly PATCH 01/10 and PATCH 02/10).
>> * Dropped panthor_hw feature bitmap patch in favor of functions that
>> performs the relevant architecture version checks.
>> * Fixed kernel test bot warnings.
>> * Replaced function pointer accessor MACROs with static inline
>> functions.
>> * Refined power control logic, removed unnecessary checks and redundant
>> stubs.
>> * Replaced explicit CSG_IFACE_VERSION checks with functions describing
>> the feature being checked for.
>> * General readability improvements, more consistent error handling,
>> behaviour clarifications, and formatting fixes.
>> * Link to v1: https://lore.kernel.org/all/20251014094337.1009601-1-karunika.choo@arm.com/
>>
>>
>> Karunika Choo (8):
>> drm/panthor: Add arch-specific panthor_hw binding
>> drm/panthor: Add architecture-specific function operations
>> drm/panthor: Introduce panthor_pwr API and power control framework
>> drm/panthor: Implement L2 power on/off via PWR_CONTROL
>> drm/panthor: Implement soft reset via PWR_CONTROL
>> drm/panthor: Support GLB_REQ.STATE field for Mali-G1 GPUs
>> drm/panthor: Support 64-bit endpoint_req register for Mali-G1
>> drm/panthor: Add support for Mali-G1 GPUs
>>
>> drivers/gpu/drm/panthor/Makefile | 1 +
>> drivers/gpu/drm/panthor/panthor_device.c | 18 +-
>> drivers/gpu/drm/panthor/panthor_device.h | 8 +
>> drivers/gpu/drm/panthor/panthor_fw.c | 131 +++++-
>> drivers/gpu/drm/panthor/panthor_fw.h | 32 +-
>> drivers/gpu/drm/panthor/panthor_gpu.c | 12 +-
>> drivers/gpu/drm/panthor/panthor_gpu.h | 1 +
>> drivers/gpu/drm/panthor/panthor_hw.c | 107 ++++-
>> drivers/gpu/drm/panthor/panthor_hw.h | 47 +-
>> drivers/gpu/drm/panthor/panthor_pwr.c | 549 +++++++++++++++++++++++
>> drivers/gpu/drm/panthor/panthor_pwr.h | 23 +
>> drivers/gpu/drm/panthor/panthor_regs.h | 79 ++++
>> drivers/gpu/drm/panthor/panthor_sched.c | 21 +-
>> 13 files changed, 989 insertions(+), 40 deletions(-)
>> create mode 100644 drivers/gpu/drm/panthor/panthor_pwr.c
>> create mode 100644 drivers/gpu/drm/panthor/panthor_pwr.h
>>
>> --
>> 2.49.0
>>
>
prev parent reply other threads:[~2025-11-25 13:48 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-11-07 14:24 Karunika Choo
2025-11-07 14:24 ` [PATCH v4 1/8] drm/panthor: Add arch-specific panthor_hw binding Karunika Choo
2025-11-07 14:24 ` [PATCH v4 2/8] drm/panthor: Add architecture-specific function operations Karunika Choo
2025-11-07 14:24 ` [PATCH v4 3/8] drm/panthor: Introduce panthor_pwr API and power control framework Karunika Choo
2025-11-10 9:18 ` Steven Price
2025-11-07 14:24 ` [PATCH v4 4/8] drm/panthor: Implement L2 power on/off via PWR_CONTROL Karunika Choo
2025-11-07 14:24 ` [PATCH v4 5/8] drm/panthor: Implement soft reset " Karunika Choo
2025-11-07 14:24 ` [PATCH v4 6/8] drm/panthor: Support GLB_REQ.STATE field for Mali-G1 GPUs Karunika Choo
2025-11-07 14:24 ` [PATCH v4 7/8] drm/panthor: Support 64-bit endpoint_req register for Mali-G1 Karunika Choo
2025-11-07 14:24 ` [PATCH v4 8/8] drm/panthor: Add support for Mali-G1 GPUs Karunika Choo
2025-11-14 16:33 ` [PATCH v4 0/8] " Steven Price
2025-11-25 13:47 ` Karunika Choo [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=c80da36c-84e5-4a1c-a467-3cc9c46bf956@arm.com \
--to=karunika.choo@arm.com \
--cc=airlied@gmail.com \
--cc=boris.brezillon@collabora.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=linux-kernel@vger.kernel.org \
--cc=liviu.dudau@arm.com \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mripard@kernel.org \
--cc=nd@arm.com \
--cc=simona@ffwll.ch \
--cc=steven.price@arm.com \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome