From: "Ilpo Järvinen" <ilpo.jarvinen@linux.intel.com>
To: "David E. Box" <david.e.box@linux.intel.com>
Cc: irenic.rajneesh@gmail.com, srinivas.pandruvada@linux.intel.com,
xi.pardee@linux.intel.com, Hans de Goede <hansg@kernel.org>,
LKML <linux-kernel@vger.kernel.org>,
platform-driver-x86@vger.kernel.org
Subject: Re: [PATCH V2 04/17] platform/x86/intel/pmt: Move header decode into common helper
Date: Tue, 7 Apr 2026 14:05:17 +0300 (EEST) [thread overview]
Message-ID: <c82ac37a-6e83-7c1e-bc60-22c9d7e27c24@linux.intel.com> (raw)
In-Reply-To: <20260325014819.1283566-5-david.e.box@linux.intel.com>
On Tue, 24 Mar 2026, David E. Box wrote:
> Unify PMT discovery table parsing by moving header decode logic into the
> class driver. A new helper, pmt_read_header(), now fills in the standard
> header fields from the discovery table, replacing the per-namespace
> pmt_header_decode callbacks in telemetry and crashlog.
>
> This centralizes the discovery table bit-field definitions in class.h,
> removes duplicate decode code from telemetry and crashlog, and prepares the
> PMT class for additional discovery sources.
>
> Signed-off-by: David E. Box <david.e.box@linux.intel.com>
> ---
>
> V2 changes:
> - Added PMT_GET_SIZE_BYTES(v), addressing Ilpo feedback on macro naming
> and unit clarity
> - Also in PMT_GET_SIZE_BYTES(v) change ((v) << 2) to ((v) * sizeof(u32))
> for clarity
> - Removed unused macros from crashlog.c per feedback from Ilpo
>
> drivers/platform/x86/intel/pmt/class.c | 37 +++++++++++++++-------
> drivers/platform/x86/intel/pmt/class.h | 15 +++++++--
> drivers/platform/x86/intel/pmt/crashlog.c | 23 --------------
> drivers/platform/x86/intel/pmt/telemetry.c | 26 ---------------
> 4 files changed, 39 insertions(+), 62 deletions(-)
>
> diff --git a/drivers/platform/x86/intel/pmt/class.c b/drivers/platform/x86/intel/pmt/class.c
> index 9b315334a69b..d652b21261f0 100644
> --- a/drivers/platform/x86/intel/pmt/class.c
> +++ b/drivers/platform/x86/intel/pmt/class.c
> @@ -8,6 +8,7 @@
> * Author: "Alexander Duyck" <alexander.h.duyck@linux.intel.com>
> */
>
> +#include <linux/bitfield.h>
> #include <linux/kernel.h>
> #include <linux/log2.h>
> #include <linux/intel_vsec.h>
> @@ -368,26 +369,40 @@ static int intel_pmt_dev_register(struct intel_pmt_entry *entry,
> return ret;
> }
>
> -int intel_pmt_dev_create(struct intel_pmt_entry *entry, struct intel_pmt_namespace *ns,
> - struct intel_vsec_device *intel_vsec_dev, int idx)
> +static int pmt_read_header(struct intel_vsec_device *ivdev, int idx,
> + struct intel_pmt_entry *entry)
> {
> - struct device *dev = &intel_vsec_dev->auxdev.dev;
> - struct resource *disc_res;
> - int ret;
> + struct intel_pmt_header *header = &entry->header;
> + struct device *dev = &ivdev->auxdev.dev;
> + u64 headers[2];
>
> - disc_res = &intel_vsec_dev->resource[idx];
> -
> - entry->disc_table = devm_ioremap_resource(dev, disc_res);
> + entry->disc_table = devm_ioremap_resource(dev, &ivdev->resource[idx]);
> if (IS_ERR(entry->disc_table))
> return PTR_ERR(entry->disc_table);
>
> + memcpy_fromio(headers, entry->disc_table, 2 * sizeof(u64));
> +
> + header->access_type = FIELD_GET(PMT_ACCESS_TYPE, headers[0]);
> + header->telem_type = FIELD_GET(PMT_TELEM_TYPE, headers[0]);
> + header->size = PMT_GET_SIZE_BYTES(headers[0]);
Hi David,
There might be something I'm missing that is not apparent from the code
alone, but when I look the old code in pmt_crashlog_header_decode(), it
has this:
#define SIZE_OFFSET 0xC
...
header->size = GET_SIZE(readl(disc_table + SIZE_OFFSET));
...I can't understand how this transformation is equivalent as it was
previously read from 0xC which would belong into header[1], right?
I think it warrants an explanation in changelog if it's an intended
change.
--
i.
> + header->guid = FIELD_GET(PMT_GUID32, headers[0]);
> + header->base_offset = FIELD_GET(PMT_BASE_OFFSET, headers[1]);
> +
> + return 0;
> +}
> +
> +int intel_pmt_dev_create(struct intel_pmt_entry *entry, struct intel_pmt_namespace *ns,
> + struct intel_vsec_device *intel_vsec_dev, int idx)
> +{
> + int ret;
> +
> if (ns->pmt_pre_decode) {
> ret = ns->pmt_pre_decode(intel_vsec_dev, entry);
> if (ret)
> return ret;
> }
>
> - ret = ns->pmt_header_decode(entry, dev);
> + ret = pmt_read_header(intel_vsec_dev, idx, entry);
> if (ret)
> return ret;
>
> @@ -397,11 +412,11 @@ int intel_pmt_dev_create(struct intel_pmt_entry *entry, struct intel_pmt_namespa
> return ret;
> }
>
> - ret = intel_pmt_populate_entry(entry, intel_vsec_dev, disc_res);
> + ret = intel_pmt_populate_entry(entry, intel_vsec_dev, &intel_vsec_dev->resource[idx]);
> if (ret)
> return ret;
>
> - return intel_pmt_dev_register(entry, ns, dev);
> + return intel_pmt_dev_register(entry, ns, &intel_vsec_dev->auxdev.dev);
> }
> EXPORT_SYMBOL_NS_GPL(intel_pmt_dev_create, "INTEL_PMT");
>
> diff --git a/drivers/platform/x86/intel/pmt/class.h b/drivers/platform/x86/intel/pmt/class.h
> index 8a0db0ef58c1..96ebb15f0053 100644
> --- a/drivers/platform/x86/intel/pmt/class.h
> +++ b/drivers/platform/x86/intel/pmt/class.h
> @@ -11,6 +11,19 @@
>
> #include "telemetry.h"
>
> +/* PMT Discovery Table DWORD 1 */
> +#define PMT_ACCESS_TYPE GENMASK_ULL(3, 0)
> +#define PMT_TELEM_TYPE GENMASK_ULL(7, 4)
> +#define PMT_SIZE GENMASK_ULL(27, 12)
> +#define PMT_GUID32 GENMASK_ULL(63, 32)
> +
> +/* PMT Discovery Table DWORD 2 */
> +#define PMT_BASE_OFFSET GENMASK_ULL(31, 0)
> +#define PMT_TELE_ID GENMASK_ULL(63, 32)
> +
> +/* Convert DWORD size to bytes */
> +#define PMT_GET_SIZE_BYTES(h) ((FIELD_GET(PMT_SIZE, h)) * sizeof(u32))
> +
> /* PMT access types */
> #define ACCESS_BARID 2
> #define ACCESS_LOCAL 3
> @@ -61,8 +74,6 @@ struct intel_pmt_entry {
> struct intel_pmt_namespace {
> const char *name;
> struct xarray *xa;
> - int (*pmt_header_decode)(struct intel_pmt_entry *entry,
> - struct device *dev);
> int (*pmt_pre_decode)(struct intel_vsec_device *ivdev,
> struct intel_pmt_entry *entry);
> int (*pmt_post_decode)(struct intel_vsec_device *ivdev,
> diff --git a/drivers/platform/x86/intel/pmt/crashlog.c b/drivers/platform/x86/intel/pmt/crashlog.c
> index f936daf99e4d..ef1826b15cf4 100644
> --- a/drivers/platform/x86/intel/pmt/crashlog.c
> +++ b/drivers/platform/x86/intel/pmt/crashlog.c
> @@ -26,14 +26,8 @@
>
> /* Crashlog Discovery Header */
> #define CONTROL_OFFSET 0x0
> -#define GUID_OFFSET 0x4
> -#define BASE_OFFSET 0x8
> -#define SIZE_OFFSET 0xC
> -#define GET_ACCESS(v) ((v) & GENMASK(3, 0))
> #define GET_TYPE(v) (((v) & GENMASK(7, 4)) >> 4)
> #define GET_VERSION(v) (((v) & GENMASK(19, 16)) >> 16)
> -/* size is in bytes */
> -#define GET_SIZE(v) ((v) * sizeof(u32))
>
> /*
> * Type 1 Version 0
> @@ -516,28 +510,11 @@ static int pmt_crashlog_pre_decode(struct intel_vsec_device *ivdev,
> return 0;
> }
>
> -static int pmt_crashlog_header_decode(struct intel_pmt_entry *entry,
> - struct device *dev)
> -{
> - void __iomem *disc_table = entry->disc_table;
> - struct intel_pmt_header *header = &entry->header;
> -
> - header->access_type = GET_ACCESS(readl(disc_table));
> - header->guid = readl(disc_table + GUID_OFFSET);
> - header->base_offset = readl(disc_table + BASE_OFFSET);
> -
> - /* Size is measured in DWORDS, but accessor returns bytes */
> - header->size = GET_SIZE(readl(disc_table + SIZE_OFFSET));
> -
> - return 0;
> -}
> -
> static DEFINE_XARRAY_ALLOC(crashlog_array);
> static struct intel_pmt_namespace pmt_crashlog_ns = {
> .name = "crashlog",
> .xa = &crashlog_array,
> .pmt_pre_decode = pmt_crashlog_pre_decode,
> - .pmt_header_decode = pmt_crashlog_header_decode,
> };
>
> /*
> diff --git a/drivers/platform/x86/intel/pmt/telemetry.c b/drivers/platform/x86/intel/pmt/telemetry.c
> index d22f633638be..80773e3c3efa 100644
> --- a/drivers/platform/x86/intel/pmt/telemetry.c
> +++ b/drivers/platform/x86/intel/pmt/telemetry.c
> @@ -27,14 +27,6 @@
>
> #include "class.h"
>
> -#define TELEM_SIZE_OFFSET 0x0
> -#define TELEM_GUID_OFFSET 0x4
> -#define TELEM_BASE_OFFSET 0x8
> -#define TELEM_ACCESS(v) ((v) & GENMASK(3, 0))
> -#define TELEM_TYPE(v) (((v) & GENMASK(7, 4)) >> 4)
> -/* size is in bytes */
> -#define TELEM_SIZE(v) (((v) & GENMASK(27, 12)) >> 10)
> -
> /* Used by client hardware to identify a fixed telemetry entry*/
> #define TELEM_CLIENT_FIXED_BLOCK_GUID 0x10000000
>
> @@ -69,23 +61,6 @@ static bool pmt_telem_region_overlaps(struct device *dev, u32 guid, u32 type)
> return false;
> }
>
> -static int pmt_telem_header_decode(struct intel_pmt_entry *entry,
> - struct device *dev)
> -{
> - void __iomem *disc_table = entry->disc_table;
> - struct intel_pmt_header *header = &entry->header;
> -
> - header->access_type = TELEM_ACCESS(readl(disc_table));
> - header->guid = readl(disc_table + TELEM_GUID_OFFSET);
> - header->base_offset = readl(disc_table + TELEM_BASE_OFFSET);
> -
> - /* Size is measured in DWORDS, but accessor returns bytes */
> - header->size = TELEM_SIZE(readl(disc_table));
> - header->telem_type = TELEM_TYPE(readl(entry->disc_table));
> -
> - return 0;
> -}
> -
> static int pmt_telem_post_decode(struct intel_vsec_device *ivdev,
> struct intel_pmt_entry *entry)
> {
> @@ -135,7 +110,6 @@ static DEFINE_XARRAY_ALLOC(telem_array);
> static struct intel_pmt_namespace pmt_telem_ns = {
> .name = "telem",
> .xa = &telem_array,
> - .pmt_header_decode = pmt_telem_header_decode,
> .pmt_post_decode = pmt_telem_post_decode,
> .pmt_add_endpoint = pmt_telem_add_endpoint,
> };
>
next prev parent reply other threads:[~2026-04-07 11:05 UTC|newest]
Thread overview: 28+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-03-25 1:48 [PATCH V2 00/17] Add ACPI-based PMT discovery support for Intel PMC David E. Box
2026-03-25 1:48 ` [PATCH V2 01/17] platform/x86/intel/pmt: Add pre/post decode hooks around header parsing David E. Box
2026-03-25 1:48 ` [PATCH V2 02/17] platform/x86/intel/pmt/crashlog: Split init into pre-decode David E. Box
2026-03-25 1:48 ` [PATCH V2 03/17] platform/x86/intel/pmt/telemetry: Move overlap check to post-decode hook David E. Box
2026-04-07 11:05 ` Ilpo Järvinen
2026-03-25 1:48 ` [PATCH V2 04/17] platform/x86/intel/pmt: Move header decode into common helper David E. Box
2026-04-07 11:05 ` Ilpo Järvinen [this message]
2026-03-25 1:48 ` [PATCH V2 05/17] platform/x86/intel/pmt: Pass discovery index instead of resource David E. Box
2026-04-07 11:07 ` Ilpo Järvinen
2026-03-25 1:48 ` [PATCH V2 06/17] platform/x86/intel/pmt: Unify header fetch and add ACPI source David E. Box
2026-04-07 12:14 ` Ilpo Järvinen
2026-03-25 1:48 ` [PATCH V2 07/17] platform/x86/intel/pmc: Add PMC SSRAM Kconfig description David E. Box
2026-04-07 12:16 ` Ilpo Järvinen
2026-03-25 1:48 ` [PATCH V2 08/17] platform/x86/intel/pmc: Add ACPI PWRM telemetry driver for Nova Lake S David E. Box
2026-04-07 12:56 ` Ilpo Järvinen
2026-03-25 1:48 ` [PATCH V2 09/17] platform/x86/intel/pmc/ssram: Rename probe and PCI ID table for consistency David E. Box
2026-03-25 1:48 ` [PATCH V2 10/17] platform/x86/intel/pmc/ssram: Use fixed-size static pmc array David E. Box
2026-04-07 13:08 ` Ilpo Järvinen
2026-03-25 1:48 ` [PATCH V2 11/17] platform/x86/intel/pmc/ssram: Refactor DEVID/PWRMBASE extraction into helper David E. Box
2026-04-07 13:18 ` Ilpo Järvinen
2026-03-25 1:48 ` [PATCH V2 12/17] platform/x86/intel/pmc/ssram: Add PCI platform data David E. Box
2026-03-25 1:48 ` [PATCH V2 13/17] platform/x86/intel/pmc/ssram: Refactor memory barrier for reentrant probe David E. Box
2026-03-25 1:48 ` [PATCH V2 14/17] platform/x86/intel/pmc/ssram_telemetry: Fix cleanup pattern for __free() variables David E. Box
2026-04-07 13:33 ` Ilpo Järvinen
2026-04-17 22:28 ` David Box
2026-03-25 1:48 ` [PATCH V2 15/17] platform/x86/intel/pmc/ssram: Add ACPI discovery scaffolding David E. Box
2026-03-25 1:48 ` [PATCH V2 16/17] platform/x86/intel/pmc/ssram: Make PMT registration optional David E. Box
2026-03-25 1:48 ` [PATCH V2 17/17] platform/x86/intel/pmc: Add NVL PCI IDs for SSRAM telemetry discovery David E. Box
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=c82ac37a-6e83-7c1e-bc60-22c9d7e27c24@linux.intel.com \
--to=ilpo.jarvinen@linux.intel.com \
--cc=david.e.box@linux.intel.com \
--cc=hansg@kernel.org \
--cc=irenic.rajneesh@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=platform-driver-x86@vger.kernel.org \
--cc=srinivas.pandruvada@linux.intel.com \
--cc=xi.pardee@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome