mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Zheng Qixing <zhengqixing@huaweicloud.com>
To: Li Nan <linan666@huaweicloud.com>
Cc: linux-raid@vger.kernel.org, linux-kernel@vger.kernel.org,
	yi.zhang@huawei.com, yangerkun@huawei.com, houtao1@huawei.com,
	linan122@h-partners.com, song@kernel.org, yukuai@fnnas.com,
	Zheng Qixing <zhengqixing@huawei.com>
Subject: Re: [RFC PATCH 5/5] md/raid1: introduce rectify action to repair badblocks
Date: Mon, 19 Jan 2026 10:51:26 +0800	[thread overview]
Message-ID: <ca387132-4e33-4084-92dc-5418e2801acb@huaweicloud.com> (raw)
In-Reply-To: <905c81d3-a235-dd36-e17b-37acb8a6128b@huaweicloud.com>

Hi,

>> @@ -700,21 +738,34 @@ static enum sync_action __get_recovery_sync_action(struct mddev *mddev)
>>     static enum sync_action get_recovery_sync_action(struct mddev *mddev)
>>   {
>> +    if (test_bit(MD_RECOVERY_BADBLOCKS_RECTIFY, &mddev->recovery))
>> +        return ACTION_RECTIFY;
>>       return __get_recovery_sync_action(mddev);
>>   }
>>     static void init_recovery_position(struct mddev *mddev)
>>   {
>>       mddev->resync_min = 0;
>> +    mddev->rectify_min = 0;
>> +}
>
> As mentioned in patch 1, can we directly reuse resync_min?


To keep rectify's progress separate from check and repair, it's better to use
a dedicated variable to record it.

I'll update the other suggestions in v2.


Thanks,

Qixing


  reply	other threads:[~2026-01-19  2:51 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-12-31  7:09 [RFC PATCH 0/5] md/raid1: introduce a new sync " Zheng Qixing
2025-12-31  7:09 ` [RFC PATCH 1/5] md: add helpers for requested sync action Zheng Qixing
2026-01-06 12:59   ` Li Nan
2026-01-08  3:31     ` Zheng Qixing
2025-12-31  7:09 ` [RFC PATCH 2/5] md: clear stale sync flags when frozen before sync starts Zheng Qixing
2026-01-06 13:07   ` Li Nan
2025-12-31  7:09 ` [RFC PATCH 3/5] md: simplify sync action print in status_resync Zheng Qixing
2026-01-06 13:24   ` Li Nan
2025-12-31  7:09 ` [RFC PATCH 4/5] md: introduce MAX_RAID_DISKS macro to replace magic number Zheng Qixing
2025-12-31 18:00   ` John Stoffel
2026-01-04  2:06     ` Zheng Qixing
2025-12-31  7:09 ` [RFC PATCH 5/5] md/raid1: introduce rectify action to repair badblocks Zheng Qixing
2026-01-06 13:43   ` Li Nan
2026-01-19  2:51     ` Zheng Qixing [this message]
2026-01-14  3:11   ` Li Nan
2026-01-19  3:06     ` Zheng Qixing
2025-12-31 11:11 ` [RFC PATCH 0/5] md/raid1: introduce a new sync " Roman Mamedov
2026-01-06  2:44   ` Zheng Qixing
2026-01-06 13:50     ` Roman Mamedov
2026-01-06 15:36     ` Pascal Hambourg
2026-01-08  1:32       ` Zheng Qixing

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ca387132-4e33-4084-92dc-5418e2801acb@huaweicloud.com \
    --to=zhengqixing@huaweicloud.com \
    --cc=houtao1@huawei.com \
    --cc=linan122@h-partners.com \
    --cc=linan666@huaweicloud.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-raid@vger.kernel.org \
    --cc=song@kernel.org \
    --cc=yangerkun@huawei.com \
    --cc=yi.zhang@huawei.com \
    --cc=yukuai@fnnas.com \
    --cc=zhengqixing@huawei.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®