From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by smtp.lore.kernel.org (Postfix) with ESMTP id E3F9CE92719 for ; Thu, 5 Oct 2023 17:32:49 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S231787AbjJERcs (ORCPT ); Thu, 5 Oct 2023 13:32:48 -0400 Received: from lindbergh.monkeyblade.net ([23.128.96.19]:52890 "EHLO lindbergh.monkeyblade.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S231203AbjJERcU (ORCPT ); Thu, 5 Oct 2023 13:32:20 -0400 Received: from madras.collabora.co.uk (madras.collabora.co.uk [46.235.227.172]) by lindbergh.monkeyblade.net (Postfix) with ESMTPS id 53FE419A4 for ; Thu, 5 Oct 2023 10:28:23 -0700 (PDT) Received: from [192.168.2.166] (109-252-153-31.dynamic.spd-mgts.ru [109.252.153.31]) (using TLSv1.3 with cipher TLS_AES_128_GCM_SHA256 (128/128 bits) key-exchange X25519 server-signature RSA-PSS (4096 bits) server-digest SHA256) (No client certificate requested) (Authenticated sender: dmitry.osipenko) by madras.collabora.co.uk (Postfix) with ESMTPSA id 67AC76607334; Thu, 5 Oct 2023 18:28:20 +0100 (BST) DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=collabora.com; s=mail; t=1696526901; bh=7WOYOnPo936SlriKU/i8Mk9uJTSewjYiMlJ/Gb48yCo=; h=Date:Subject:To:Cc:References:From:In-Reply-To:From; b=A7mKszfMS6cci2WZndgsbTaEqM3I+WUX0RgO9Hc5+ptdOr9Xksjgy8Aj1MzNeir+g cy4rj2oBy2k+mqhc8/K0jXHkcYSm/8gzre6OfvYCGJMKrK6Yb5UZhQKAv5lD4pzzYl zfEnROQkdhCxGzWGTATkb6jp8rXEiPzbLcb19/rsH4Pv/g+hM1KNADfKSqauuOjHdy dyXn6sSG2klYogaW6QsERkMCsipNOymnhXSMV/ZwRklbL9r5CvXO7kyaNqTsgeWhvd XxC9GOMTB3lLayIGNwShdQYy9zW4kEzi9ZqVCF/hotLIG5L3bItqrKgFhhym308zK+ mEj476wzE9iZw== Message-ID: Date: Thu, 5 Oct 2023 20:28:17 +0300 MIME-Version: 1.0 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:102.0) Gecko/20100101 Thunderbird/102.13.0 Subject: Re: [PATCH v17 13/18] drm/shmem-helper: Add memory shrinker Content-Language: en-US To: Boris Brezillon Cc: David Airlie , Gerd Hoffmann , Gurchetan Singh , Chia-I Wu , Daniel Vetter , Maarten Lankhorst , Maxime Ripard , Thomas Zimmermann , =?UTF-8?Q?Christian_K=c3=b6nig?= , Qiang Yu , Steven Price , Emma Anholt , Melissa Wen , dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org, kernel@collabora.com, virtualization@lists.linux-foundation.org References: <20230914232721.408581-1-dmitry.osipenko@collabora.com> <20230914232721.408581-14-dmitry.osipenko@collabora.com> <20230915104633.0d5c3932@collabora.com> <454c464e-4534-7ec3-6d38-49b7df83c7be@collabora.com> <20230926093517.11a172ad@collabora.com> <20231003130909.3b470a43@collabora.com> From: Dmitry Osipenko In-Reply-To: <20231003130909.3b470a43@collabora.com> Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 7bit Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 10/3/23 14:09, Boris Brezillon wrote: > Unmap tends to refer to a VM related operation (removing a mapping in > the CPU or GPU VM), so it's confusing too IMHO. What we do here is > return pages to the shmem file logic, so they can be reclaimed. > > Given the drm_gem function doing that is called drm_gem_put_pages(), > maybe rename it drm_gem_shmem_shrinker_put_pages_locked(), and rename > drm_gem_shmem_swapin_locked() into > drm_gem_shmem_shrinker_get_pages_locked(), to be consistent. The swapin is a common term and function naming scheme among DRM drivers. That name shouldn't be changed. The drm_gem_shmem_shrinker_put_pages_locked() sounds okay, let's use it. -- Best regards, Dmitry