mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Alexey Budankov <alexey.budankov@linux.intel.com>
To: Jiri Olsa <jolsa@redhat.com>
Cc: Arnaldo Carvalho de Melo <acme@kernel.org>,
	Namhyung Kim <namhyung@kernel.org>,
	Alexander Shishkin <alexander.shishkin@linux.intel.com>,
	Peter Zijlstra <peterz@infradead.org>,
	Ingo Molnar <mingo@redhat.com>, Andi Kleen <ak@linux.intel.com>,
	linux-kernel <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v9 02/15] tools/libperf: add properties to struct pollfd *entries objects
Date: Mon, 6 Jul 2020 16:05:48 +0300	[thread overview]
Message-ID: <cd132d6b-89ec-1408-f4da-44020e13d4b2@linux.intel.com> (raw)
In-Reply-To: <20200706122413.GB3401866@krava>


On 06.07.2020 15:24, Jiri Olsa wrote:
> On Fri, Jul 03, 2020 at 10:41:45AM +0300, Alexey Budankov wrote:
>>
>> Store boolean properties per struct pollfd *entries object in a
>> bitmap of int size. Implement fdarray_prop__nonfilterable property
>> to skip object from counting by fdarray_filter().
> 
> ok, I think can do it like this, few comments below
> 
> thanks,
> jirka
> 
>>
>> Signed-off-by: Alexey Budankov <alexey.budankov@linux.intel.com>
>> ---
>>  tools/lib/api/fd/array.c                 | 17 +++++++++--------
>>  tools/lib/api/fd/array.h                 | 18 +++++++++++++-----
>>  tools/lib/perf/evlist.c                  | 10 +++++-----
>>  tools/lib/perf/include/internal/evlist.h |  2 +-
>>  tools/perf/tests/fdarray.c               |  2 +-
>>  tools/perf/util/evlist.c                 |  2 +-
>>  6 files changed, 30 insertions(+), 21 deletions(-)

<SNIP>

>>
>> diff --git a/tools/lib/api/fd/array.h b/tools/lib/api/fd/array.h
>> index b39557d1a88f..19b6a34aeea5 100644
>> --- a/tools/lib/api/fd/array.h
>> +++ b/tools/lib/api/fd/array.h
>> @@ -21,10 +21,18 @@ struct fdarray {
>>  	int	       nr_alloc;
>>  	int	       nr_autogrow;
>>  	struct pollfd *entries;
>> -	union {
>> -		int    idx;
>> -		void   *ptr;
>> -	} *priv;
>> +	struct {
>> +		union {
>> +			int    idx;
>> +			void   *ptr;
>> +		} priv;
>> +		int bits;
>> +	} *prop;
>> +};
> 
> why not keeping the 'priv' as a struct, like:
> 
> 	struct {
> 		union {
> 			int    idx;
> 			void   *ptr;
> 		};
> 		unsigned int flags;
> 	} *priv;
> 
> I think we would have much less changes, also please rename bits
> to flags and use some unsigned type for that

Well, I supposed that priv is short for private what means the layout
of struct priv object is opaque to fdarray implementation and it just
passes the object as a void pointer to external callbacks (e.g in __filter()).
So I preserved this semantics and wrapped and extended priv object
with with flags field. It can be implemented with struct priv if you like.

> 
>> +
>> +enum fdarray_props {
>> +	fdarray_prop__default	    = 0x00000000,
>> +	fdarray_prop__nonfilterable = 0x00000001
>>  };
> 
> s/fdarray_props/fdarray_flag/

Accepted.

Alexey

  reply	other threads:[~2020-07-06 13:06 UTC|newest]

Thread overview: 33+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-03  7:38 [PATCH v9 00/15] perf: support enable and disable commands in stat and record modes Alexey Budankov
2020-07-03  7:41 ` [PATCH v9 01/15] tools/libperf: avoid fds moving by fdarray__filter() Alexey Budankov
2020-07-03  7:41 ` [PATCH v9 02/15] tools/libperf: add properties to struct pollfd *entries objects Alexey Budankov
2020-07-06 12:24   ` Jiri Olsa
2020-07-06 13:05     ` Alexey Budankov [this message]
2020-07-03  7:42 ` [PATCH v9 03/15] tools/libperf: don't count nonfilterable fds by fdarray__filter() Alexey Budankov
2020-07-03  7:43 ` [PATCH v9 04/15] perf evlist: introduce control file descriptors Alexey Budankov
2020-07-03  7:43 ` [PATCH v9 05/15] perf evlist: implement control command handling functions Alexey Budankov
2020-07-03  7:44 ` [PATCH v9 06/15] perf stat: factor out body of event handling loop for system wide Alexey Budankov
2020-07-03  7:45 ` [PATCH v9 07/15] perf stat: move target check to loop control statement Alexey Budankov
2020-07-03  7:45 ` [PATCH v9 08/15] perf stat: factor out body of event handling loop for fork case Alexey Budankov
2020-07-03  7:46 ` [PATCH v9 09/15] perf stat: factor out event handling loop into dispatch_events() Alexey Budankov
2020-07-06 12:27   ` Jiri Olsa
2020-07-06 13:07     ` Alexey Budankov
2020-07-03  7:46 ` [PATCH v9 10/15] perf stat: extend -D,--delay option with -1 value Alexey Budankov
2020-07-03  7:47 ` [PATCH v9 11/15] perf stat: implement control commands handling Alexey Budankov
2020-07-06 12:34   ` Jiri Olsa
2020-07-06 14:47     ` Alexey Budankov
2020-07-06 19:34       ` Jiri Olsa
2020-07-07 13:07         ` Alexey Budankov
2020-07-07 13:14           ` Jiri Olsa
2020-07-07 13:24             ` Alexey Budankov
2020-07-07 14:23               ` Jiri Olsa
2020-07-07 14:55                 ` Alexey Budankov
2020-07-07 16:05                   ` Jiri Olsa
2020-07-07 16:43                     ` Alexey Budankov
2020-07-07 17:19                   ` Alexey Budankov
2020-07-06 12:37   ` Jiri Olsa
2020-07-06 13:10     ` Alexey Budankov
2020-07-03  7:47 ` [PATCH v9 12/15] perf stat: introduce --control fd:ctl-fd[,ack-fd] options Alexey Budankov
2020-07-03  7:48 ` [PATCH v9 13/15] perf record: extend -D,--delay option with -1 value Alexey Budankov
2020-07-03  7:49 ` [PATCH v9 14/15] perf record: implement control commands handling Alexey Budankov
2020-07-03  7:49 ` [PATCH v9 15/15] perf record: introduce --control fd:ctl-fd[,ack-fd] options Alexey Budankov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=cd132d6b-89ec-1408-f4da-44020e13d4b2@linux.intel.com \
    --to=alexey.budankov@linux.intel.com \
    --cc=acme@kernel.org \
    --cc=ak@linux.intel.com \
    --cc=alexander.shishkin@linux.intel.com \
    --cc=jolsa@redhat.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=namhyung@kernel.org \
    --cc=peterz@infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome