From: John Garry <john.g.garry@oracle.com>
To: Xingui Yang <yangxingui@huawei.com>,
yanaijie@huawei.com, jejb@linux.ibm.com,
martin.petersen@oracle.com
Cc: linux-scsi@vger.kernel.org, linux-kernel@vger.kernel.org,
linuxarm@huawei.com, liyihang9@h-partners.com,
liuyonglong@huawei.com, kangfenglong@huawei.com
Subject: Re: [PATCH v4 2/2] scsi: libsas: Add linkrate and sas_addr change detection in rediscover
Date: Fri, 29 May 2026 15:09:03 +0100 [thread overview]
Message-ID: <cd70e2a4-91e1-4237-bdd0-7568b2dbdc9f@oracle.com> (raw)
In-Reply-To: <20260526015418.2022398-3-yangxingui@huawei.com>
On 26/05/2026 02:54, Xingui Yang wrote:
> In sas_rediscover_dev(), when detecting a "flutter" condition (same SAS
> address and compatible device type), the code assumes the device remains
> unchanged and only handles SATA pending state recovery. However, this
> approach misses two important scenarios:
>
> First, the flutter detection only compares SAS address and device type,
> ignoring potential linkrate changes that may have already occurred.
>
> Second, after sas_ex_phy_discover() re-queries the expander phy, both
> linkrate and attached SAS address may be updated. The current code does
> not validate these changes against the existing child device.
>
> Additionally, the replace code path (different SAS address detected)
> has a sysfs duplication issue: sas_unregister_devs_sas_addr() only marks
> the device as gone, but the actual sysfs cleanup happens later in
> sas_destruct_devices(). Calling sas_discover_new() immediately after
> unregister causes sysfs_warn_dup() errors.
>
> Introduce sas_is_flutter() to check whether it is a true flutter with
> validation for linkrate and sas_addr changes. It returns true for normal
> flutter and false when changes are detected requiring rediscovery.
>
> Introduce sas_rediscover_phy() to handle async rediscovery for both
> flutter and replace cases. When invoked:
> - Set phy_change_count and ex_change_count to -1 to force revalidation
> - Unregister the device via sas_unregister_devs_sas_addr()
> - Queue DISCE_REVALIDATE_DOMAIN event
>
> The old device sysfs is cleaned up by sas_destruct_devices() at the end
> of current revalidation work. The new event triggers discovery via
> sas_discover_new() since attached_sas_addr is cleared, avoiding the
> sysfs duplication issue.
>
> Signed-off-by: Xingui Yang <yangxingui@huawei.com>
> Suggested-by: John Garry <john.g.garry@oracle.com>
> ---
> drivers/scsi/libsas/sas_expander.c | 67 +++++++++++++++++++++++-------
> 1 file changed, 53 insertions(+), 14 deletions(-)
>
> diff --git a/drivers/scsi/libsas/sas_expander.c b/drivers/scsi/libsas/sas_expander.c
> index f55ae9a979cd..4e8e1b339889 100644
> --- a/drivers/scsi/libsas/sas_expander.c
> +++ b/drivers/scsi/libsas/sas_expander.c
> @@ -1962,6 +1962,56 @@ static bool dev_type_flutter(enum sas_device_type new, enum sas_device_type old)
> return false;
> }
>
> +static void sas_rediscover_phy(struct domain_device *dev, int phy_id,
most of the expander phy symbols have _ex_phy ending
> + bool last)
> +{
> + struct expander_device *ex = &dev->ex_dev;
> + struct ex_phy *phy = &ex->ex_phy[phy_id];
> +
> + phy->phy_change_count = -1;
> + ex->ex_change_count = -1;
> + sas_unregister_devs_sas_addr(dev, phy_id, last);
> + sas_discover_event(dev->port, DISCE_REVALIDATE_DOMAIN);
> +}
> +
> +static bool sas_is_flutter(struct domain_device *dev, int phy_id,
sas_dev_is_flutter may be a better name
> + u8 *sas_addr, enum sas_device_type type)
> +{
> + struct expander_device *ex = &dev->ex_dev;
> + struct ex_phy *phy = &ex->ex_phy[phy_id];
> + struct domain_device *child_dev;
> + char *action = "";
> +
> + if (SAS_ADDR(sas_addr) != SAS_ADDR(phy->attached_sas_addr) ||
> + !dev_type_flutter(type, phy->attached_dev_type))
> + return false;
> +
> + child_dev = sas_ex_to_dev(dev, phy_id);
> +
> + sas_ex_phy_discover(dev, phy_id);
why not check the return code for error?
> +
> + if (child_dev && dev_is_sata(child_dev) &&
> + phy->attached_dev_type == SAS_SATA_PENDING) {
> + action = ", needs recovery";
> + } else if (child_dev && child_dev->linkrate != phy->linkrate) {
> + pr_info("ex %016llx phy%02d linkrate changed from %d to %d\n",
> + SAS_ADDR(dev->sas_addr), phy_id,
> + child_dev->linkrate, phy->linkrate);
> + return false;
> + } else if (child_dev &&
Can you factor out the child_dev checks for all if/else legs?
> + SAS_ADDR(child_dev->sas_addr) != SAS_ADDR(phy->attached_sas_addr)) {
> + pr_info("ex %016llx phy%02d sas_addr changed from %016llx to %016llx\n",
> + SAS_ADDR(dev->sas_addr), phy_id,
> + SAS_ADDR(child_dev->sas_addr),
> + SAS_ADDR(phy->attached_sas_addr));
> + return false;
> + }
> +
> + pr_debug("ex %016llx phy%02d broadcast flutter%s\n",
> + SAS_ADDR(dev->sas_addr), phy_id, action);
> + return true;
> +}
> +
> static int sas_rediscover_dev(struct domain_device *dev, int phy_id,
> bool last, int sibling)
> {
> @@ -2015,27 +2065,16 @@ static int sas_rediscover_dev(struct domain_device *dev, int phy_id,
> if (res == 0)
> sas_set_ex_phy(dev, phy_id, disc_resp);
> goto out_free_resp;
> - } else if (SAS_ADDR(sas_addr) == SAS_ADDR(phy->attached_sas_addr) &&
> - dev_type_flutter(type, phy->attached_dev_type)) {
> - struct domain_device *ata_dev = sas_ex_to_ata(dev, phy_id);
> - char *action = "";
> -
> - sas_ex_phy_discover(dev, phy_id);
> + }
>
> - if (ata_dev && phy->attached_dev_type == SAS_SATA_PENDING)
> - action = ", needs recovery";
> - pr_debug("ex %016llx phy%02d broadcast flutter%s\n",
> - SAS_ADDR(dev->sas_addr), phy_id, action);
> + if (sas_is_flutter(dev, phy_id, sas_addr, type))
> goto out_free_resp;
> - }
>
> /* we always have to delete the old device when we went here */
> pr_info("ex %016llx phy%02d replace %016llx\n",
> SAS_ADDR(dev->sas_addr), phy_id,
> SAS_ADDR(phy->attached_sas_addr));
> - sas_unregister_devs_sas_addr(dev, phy_id, last);
> -
> - res = sas_discover_new(dev, phy_id);
> + sas_rediscover_phy(dev, phy_id, last);
> out_free_resp:
> kfree(disc_resp);
> return res;
Can res still hold non-zero value from earlier?
next prev parent reply other threads:[~2026-05-29 14:09 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-05-26 1:54 [PATCH v4 0/2] libsas: rediscover improvements for linkrate/sas_addr changes Xingui Yang
2026-05-26 1:54 ` [PATCH v4 1/2] scsi: libsas: refactor sas_ex_to_ata() using new helper sas_ex_to_dev() Xingui Yang
2026-05-26 1:54 ` [PATCH v4 2/2] scsi: libsas: Add linkrate and sas_addr change detection in rediscover Xingui Yang
2026-05-29 14:09 ` John Garry [this message]
2026-05-30 2:04 ` yangxingui
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=cd70e2a4-91e1-4237-bdd0-7568b2dbdc9f@oracle.com \
--to=john.g.garry@oracle.com \
--cc=jejb@linux.ibm.com \
--cc=kangfenglong@huawei.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-scsi@vger.kernel.org \
--cc=linuxarm@huawei.com \
--cc=liuyonglong@huawei.com \
--cc=liyihang9@h-partners.com \
--cc=martin.petersen@oracle.com \
--cc=yanaijie@huawei.com \
--cc=yangxingui@huawei.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®