mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Franck Bui-Huu" <vagabon.xyz@gmail.com>
To: "Miguel Ojeda" <maxextreme@gmail.com>
Cc: akpm@osdl.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 2.6.19-rc1 full] drivers: add LCD support
Date: Mon, 23 Oct 2006 18:51:14 +0200	[thread overview]
Message-ID: <cda58cb80610230951l4a1319bbs6956fea5143c021a@mail.gmail.com> (raw)
In-Reply-To: <653402b90610230921j595446a4xda5e6d9444e108da@mail.gmail.com>

On 10/23/06, Miguel Ojeda <maxextreme@gmail.com> wrote:
> On 10/23/06, Franck Bui-Huu <vagabon.xyz@gmail.com> wrote:
> >
> > [ note I'm not familiar with lcds...just try to understand what you've
> >   done ]
> >
> > What I was worry about is that you actually wrote a frame buffer
> > driver, which are normally located in drivers/video, and put it in a
> > new directory drivers/auxdisplay. So now we have two places for frame
> > buffer drivers. It looks like, now some frame buffer drivers in
> > drivers/video should be moved in drivers/auxdisplay, shouldn't it ?
> >
> > Maybe just a stupid idea but why not restructuring the thing like:
> >
> >                 drivers
> >                 |-- display
> >                 |      |-- video
> >                 |      |-- aux
> >                 |      |-- fbmem.c
> >                 |      |-- ...
> >
> >
>
> Yes, I got your idea in your first message, and well, that was
> discussed (however, not being a fbdev), and the people thought that
> putting them together will, maybe, cause confusion; so having them out
> from drivers/video should be better. Your idea, which merge them into
> a "drivers/display" could be a good one, but I don't think people will
> like to change such critical tree right now. Also, I'm not the one who
> maintain such tree, so my opinion won't make changes about that ;)
>

well, if it is the right thing to do, why not doing it. (note: I don't
claim it's the right thing to do though). Futhermore such change is
going to move a lot of files _but_ if after the move it compiles, then
it works...

> >
> > Another point: does the ks0108 controller is only used with the 'cfag'
> > display ? If not, suppose I'm using the same controller with another
> > lcd different from 'cfga'...Am I supposed to reuse your code in
> > cfag12864b.c ?
> >
>
> No. You are supposed to _use_ the ks0108's exported functions: I split
> the code into the ks0108 and the cfag12864b because I thought it was
> the logical way, as the cfag12864b LCD just send the data through two
> different ks0108 controllers. The same way, you can use the ks0108's
> exported functions to create another whateverlcd.c which has one or
> more ks0108 controllers.
>

So, to sum up, if I have a lcd named 'foo_lcd' which use 4 ks0108
controllers (256x128), and want to make your fb driver work on it, I
need to copy your  cfag12864b.c file, rename it to foo_lcd256128.c and
just change the number of controllers, is that correct ?

> >
> > BTW, did you try to mmap your fbdev ? Does it work ?
> >
>
> Why it shouldn't? It doesn't work for you? AFAIK, it is a usual fbdev,
> and you can map any fbdev as they are simple character file devices.
>

well you actually haven't answered to the initial question... I
suspect it won't work since you haven't setup "info->fix.smem_start"
anywhere. But I may be wrong since I don't know fb code.

-- 
               Franck

  reply	other threads:[~2006-10-23 16:51 UTC|newest]

Thread overview: 29+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2006-10-13  2:32 Miguel Ojeda Sandonis
2006-10-13 12:43 ` Paulo Marques
2006-10-18 14:55 ` Franck Bui-Huu
2006-10-23  8:41   ` Franck Bui-Huu
2006-10-23 12:56     ` Miguel Ojeda
2006-10-23 15:35       ` Franck Bui-Huu
2006-10-23 16:21         ` Miguel Ojeda
2006-10-23 16:51           ` Franck Bui-Huu [this message]
2006-10-26 14:45             ` Miguel Ojeda
2006-10-27 20:08               ` Franck Bui-Huu
2006-10-27 20:38                 ` Miguel Ojeda
2006-10-30  8:43                   ` Franck Bui-Huu
2006-10-30 13:35                     ` Miguel Ojeda
2006-10-23 16:05       ` Franck Bui-Huu
2006-10-23 16:08         ` Miguel Ojeda
2006-10-23 17:15           ` Franck Bui-Huu
2006-10-26 14:55             ` Miguel Ojeda
2006-10-27 20:03               ` Franck Bui-Huu
2006-10-27 20:25                 ` Miguel Ojeda
2006-10-30  9:26                   ` Franck Bui-Huu
2006-10-30 13:22                     ` Paulo Marques
2006-10-30 14:11                       ` Miguel Ojeda
2006-10-30 15:21                         ` Paulo Marques
2006-10-30 17:32                           ` Miguel Ojeda
2006-10-30 20:45                             ` Paulo Marques
2006-10-31  8:10                       ` Franck Bui-Huu
2006-10-31 14:12                         ` Miguel Ojeda
2006-10-31 14:54                         ` Paulo Marques
2006-10-30 13:47                     ` Miguel Ojeda

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=cda58cb80610230951l4a1319bbs6956fea5143c021a@mail.gmail.com \
    --to=vagabon.xyz@gmail.com \
    --cc=akpm@osdl.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=maxextreme@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome