mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Stanimir Varbanov <stanimir.varbanov@linaro.org>
To: Alexandre Courbot <acourbot@chromium.org>, vgarodia@codeaurora.org
Cc: Stanimir Varbanov <stanimir.varbanov@linaro.org>,
	Hans Verkuil <hverkuil@xs4all.nl>,
	Mauro Carvalho Chehab <mchehab@kernel.org>,
	robh@kernel.org, mark.rutland@arm.com,
	Andy Gross <andy.gross@linaro.org>, Arnd Bergmann <arnd@arndb.de>,
	bjorn.andersson@linaro.org,
	Linux Media Mailing List <linux-media@vger.kernel.org>,
	LKML <linux-kernel@vger.kernel.org>,
	linux-arm-msm@vger.kernel.org, linux-soc@vger.kernel.org,
	devicetree@vger.kernel.org, linux-media-owner@vger.kernel.org
Subject: Re: [PATCH v9 1/5] venus: firmware: add routine to reset ARM9
Date: Mon, 1 Oct 2018 17:30:40 +0300	[thread overview]
Message-ID: <cdc7769d-8bea-ac78-355e-07347ac8aaf1@linaro.org> (raw)
In-Reply-To: <CAPBb6MUo6X+L7UYgmw8qUe_2CiZEBKGxaREFhZGRU1jGq0fO=g@mail.gmail.com>

Hi,

On 09/20/2018 06:31 AM, Alexandre Courbot wrote:
> On Thu, Sep 20, 2018 at 2:55 AM Vikash Garodia <vgarodia@codeaurora.org> wrote:
>>
>> On 2018-09-19 20:30, Stanimir Varbanov wrote:
>>> Hi Alex,
>>>
>>> On 09/19/2018 10:32 AM, Alexandre Courbot wrote:
>>>> On Wed, Sep 19, 2018 at 8:43 AM Vikash Garodia
>>>> <vgarodia@codeaurora.org> wrote:
>>>>>
>>>>> Add routine to reset the ARM9 and brings it out of reset. Also
>>>>> abstract the Venus CPU state handling with a new function. This
>>>>> is in preparation to add PIL functionality in venus driver.
>>>>>
>>>>> Signed-off-by: Vikash Garodia <vgarodia@codeaurora.org>
>>>>> ---
>>>>>  drivers/media/platform/qcom/venus/core.h         |  2 ++
>>>>>  drivers/media/platform/qcom/venus/firmware.c     | 33
>>>>> ++++++++++++++++++++++++
>>>>>  drivers/media/platform/qcom/venus/firmware.h     | 11 ++++++++
>>>>>  drivers/media/platform/qcom/venus/hfi_venus.c    | 13 +++-------
>>>>>  drivers/media/platform/qcom/venus/hfi_venus_io.h |  7 +++++
>>>>>  5 files changed, 57 insertions(+), 9 deletions(-)
>>>>>
>>>>> diff --git a/drivers/media/platform/qcom/venus/core.h
>>>>> b/drivers/media/platform/qcom/venus/core.h
>>>>> index 2f02365..dfd5c10 100644
>>>>> --- a/drivers/media/platform/qcom/venus/core.h
>>>>> +++ b/drivers/media/platform/qcom/venus/core.h
>>>>> @@ -98,6 +98,7 @@ struct venus_caps {
>>>>>   * @dev:               convenience struct device pointer
>>>>>   * @dev_dec:   convenience struct device pointer for decoder device
>>>>>   * @dev_enc:   convenience struct device pointer for encoder device
>>>>> + * @no_tz:     a flag that suggests presence of trustzone
>>>>
>>>> Looks like it suggests the absence of trustzone?
>>>>
>>>> Actually I would rename it as use_tz and set it if TrustZone is used.
>>>> This would avoid double-negative statements like what we see below.
>>>
>>> I find this suggestion reasonable.
>>
>> Initially i planned to keep it as a positive flag. The reason behind
>> keeping it
>> as no_tz was to keep the default value of this flag to 0 indicating tz
>> is present
>> by default.
>> I can switch it to use_tz though and set it in firmware_init after the
>> presence of
>> firmware node is checked.
> 
> Making sure the flag is explicitly initialized instead of relying on
> default initialization is another good reason to have that change
> IMHO. :)

Vikash, care to send a new version, or will fix that with follow up patches?

-- 
regards,
Stan

  reply	other threads:[~2018-10-01 14:30 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-09-18 23:43 [PATCH v9 0/5] Venus updates - PIL Vikash Garodia
2018-09-18 23:43 ` [PATCH v9 1/5] venus: firmware: add routine to reset ARM9 Vikash Garodia
2018-09-19  7:32   ` Alexandre Courbot
2018-09-19 15:00     ` Stanimir Varbanov
2018-09-19 17:55       ` Vikash Garodia
2018-09-20  3:31         ` Alexandre Courbot
2018-10-01 14:30           ` Stanimir Varbanov [this message]
2018-10-01 15:44             ` Vikash Garodia
2018-09-18 23:43 ` [PATCH v9 2/5] venus: firmware: move load firmware in a separate function Vikash Garodia
2018-09-18 23:43 ` [PATCH v9 3/5] venus: firmware: register separate platform_device for firmware loader Vikash Garodia
2018-09-26  7:51   ` Stanimir Varbanov
2018-09-18 23:43 ` [PATCH v9 4/5] venus: firmware: add no TZ boot and shutdown routine Vikash Garodia
2018-09-18 23:43 ` [PATCH v9 5/5] dt-bindings: media: Document bindings for venus firmware device Vikash Garodia
2018-09-19  7:32   ` Alexandre Courbot
2018-09-25 15:24   ` Rob Herring
2018-09-26  6:14     ` Vikash Garodia

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=cdc7769d-8bea-ac78-355e-07347ac8aaf1@linaro.org \
    --to=stanimir.varbanov@linaro.org \
    --cc=acourbot@chromium.org \
    --cc=andy.gross@linaro.org \
    --cc=arnd@arndb.de \
    --cc=bjorn.andersson@linaro.org \
    --cc=devicetree@vger.kernel.org \
    --cc=hverkuil@xs4all.nl \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-media-owner@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=linux-soc@vger.kernel.org \
    --cc=mark.rutland@arm.com \
    --cc=mchehab@kernel.org \
    --cc=robh@kernel.org \
    --cc=vgarodia@codeaurora.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®