From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by smtp.lore.kernel.org (Postfix) with ESMTP id 02D08C7618D for ; Thu, 6 Apr 2023 12:29:25 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S237697AbjDFM3Y (ORCPT ); Thu, 6 Apr 2023 08:29:24 -0400 Received: from lindbergh.monkeyblade.net ([23.128.96.19]:35200 "EHLO lindbergh.monkeyblade.net" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S237338AbjDFM3W (ORCPT ); Thu, 6 Apr 2023 08:29:22 -0400 Received: from szxga02-in.huawei.com (szxga02-in.huawei.com [45.249.212.188]) by lindbergh.monkeyblade.net (Postfix) with ESMTPS id B81606EB7 for ; Thu, 6 Apr 2023 05:29:17 -0700 (PDT) Received: from kwepemm600013.china.huawei.com (unknown [172.30.72.56]) by szxga02-in.huawei.com (SkyGuard) with ESMTP id 4Psggp6NZBzSkrd; Thu, 6 Apr 2023 20:25:26 +0800 (CST) Received: from [10.174.178.46] (10.174.178.46) by kwepemm600013.china.huawei.com (7.193.23.68) with Microsoft SMTP Server (version=TLS1_2, cipher=TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256) id 15.1.2507.23; Thu, 6 Apr 2023 20:29:13 +0800 Subject: Re: [PATCH] ubifs: remove unnecessary kobject_del() To: Yangtao Li CC: , , References: <20230405130747.66006-1-frank.li@vivo.com> <20230406090813.24111-1-frank.li@vivo.com> From: Zhihao Cheng Message-ID: Date: Thu, 6 Apr 2023 20:29:13 +0800 User-Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:68.0) Gecko/20100101 Thunderbird/68.5.0 MIME-Version: 1.0 In-Reply-To: <20230406090813.24111-1-frank.li@vivo.com> Content-Type: text/plain; charset="gbk"; format=flowed Content-Transfer-Encoding: 7bit X-Originating-IP: [10.174.178.46] X-ClientProxiedBy: dggems701-chm.china.huawei.com (10.3.19.178) To kwepemm600013.china.huawei.com (7.193.23.68) X-CFilter-Loop: Reflected Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Hi, >> I think we should still reserve the 'redundant' kobject_del(), >> removing it won't bring any performance improvement. > > Since it's redundant, why not to remove it. > In my personal view, 'redundant' means removing kobject_del() is okay, it won't bring any bugs. But removing it won't make code more readability or gain any performance improvement, so it could be reserved. Whether to remove kobject_del() depends on UBIFS maintainer, I just help to check if the modification could affect the normal logic.