From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753837AbdLDMgt (ORCPT ); Mon, 4 Dec 2017 07:36:49 -0500 Received: from esa2.microchip.iphmx.com ([68.232.149.84]:64647 "EHLO esa2.microchip.iphmx.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751864AbdLDMgr (ORCPT ); Mon, 4 Dec 2017 07:36:47 -0500 X-IronPort-AV: E=Sophos;i="5.45,359,1508828400"; d="scan'208";a="9312377" Subject: Re: [PATCH] eeprom: at24: correctly set the size for at24mac402 To: Bartosz Golaszewski , Andy Shevchenko CC: Heiner Kallweit , linux-i2c , "linux-kernel@vger.kernel.org" , References: <20171127210613.9140-1-brgl@bgdev.pl> From: Claudiu Beznea Message-ID: Date: Mon, 4 Dec 2017 14:36:43 +0200 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.4.0 MIME-Version: 1.0 In-Reply-To: Content-Type: text/plain; charset="utf-8" Content-Language: en-US Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 28.11.2017 12:44, Bartosz Golaszewski wrote: > 2017-11-28 11:25 GMT+01:00 Andy Shevchenko : >> On Mon, Nov 27, 2017 at 11:06 PM, Bartosz Golaszewski wrote: >>> There's an ilog2() expansion in AT24_DEVICE_MAGIC() which rounds down >>> the actual size of EUI-48 byte array in at24mac402 eeproms to 4 from 6, >>> making it impossible to read it all. >>> >>> Fix it by manually adjusting the value in probe(). >>> >>> This patch contains a temporary fix that is suitable for stable >>> branches. Eventually we'll probably remove the call to ilog2() while >>> converting the magic values to actual structs. >> >>> + /* >>> + * REVISIT: the size of the EUI-48 byte array is 6 in at24mac402, while >>> + * the call to ilog2() in AT24_DEVICE_MAGIC() rounds it down to 4. >>> + * >>> + * Eventually we'll get rid of the magic values altoghether in favor of >>> + * real structs, but for now just manually set the right size. >>> + */ >>> + if (chip.flags & AT24_FLAG_MAC && chip.byte_len == 4) >> >> I didn't check, but do we need to test for len == 4 at all? >> >>> + chip.byte_len = 6; >> >> -- >> With Best Regards, >> Andy Shevchenko > > Yes, because the fix is only relevant for at24mac402 whose MAC byte > array is 6 bytes long, while the one in at24mac602 is 8 bytes and the > driver doesn't truncate the byte_len for it. >>From my point of view, I think all chips in at24_ids[] array should be checked about restrictions regarding the size truncation (especially the ones from the initial commit: "2b7a5056a0a7ff17d5d2 i2c: New-style EEPROM driver using device IDs" which introduces AT24_DEVICE_MAGIC() macro) and if none of them has such restrictions we should get rid of the ilog2() restrictions. Just my 2 cents... Claudiu > > Thanks, > Bartosz >