mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Neil Armstrong <neil.armstrong@linaro.org>
To: Dario Binacchi <dario.binacchi@amarulasolutions.com>,
	linux-kernel@vger.kernel.org
Cc: linux-amarula@amarulasolutions.com,
	David Airlie <airlied@gmail.com>,
	Jessica Zhang <jesszhan0024@gmail.com>,
	Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
	Maxime Ripard <mripard@kernel.org>,
	Michael Walle <mwalle@kernel.org>,
	Simona Vetter <simona@ffwll.ch>,
	Thomas Zimmermann <tzimmermann@suse.de>,
	dri-devel@lists.freedesktop.org
Subject: Re: [PATCH 1/3] drm/panel: ilitek-ili9806e: prepare for multiple bus support
Date: Fri, 9 Jan 2026 10:01:38 +0100	[thread overview]
Message-ID: <cfa5724f-6cb6-4458-be20-9b4d518dd693@linaro.org> (raw)
In-Reply-To: <20260106154446.2735701-2-dario.binacchi@amarulasolutions.com>

On 1/6/26 16:43, Dario Binacchi wrote:
> This change clarifies that the current implementation is specific to the
> MIPI-DSI interface. By separating the core config from the DSI-specific
> one, we prepare the driver for future support of other buses (like
> SPI) while maintaining backward compatibility through the default
> assignment in Kconfig.
> 
> Signed-off-by: Dario Binacchi <dario.binacchi@amarulasolutions.com>
> ---
> 
>   MAINTAINERS                                            |  2 +-
>   drivers/gpu/drm/panel/Kconfig                          | 10 +++++++++-
>   drivers/gpu/drm/panel/Makefile                         |  2 +-
>   ...l-ilitek-ili9806e.c => panel-ilitek-ili9806e-dsi.c} |  2 +-
>   4 files changed, 12 insertions(+), 4 deletions(-)
>   rename drivers/gpu/drm/panel/{panel-ilitek-ili9806e.c => panel-ilitek-ili9806e-dsi.c} (99%)
> 
> diff --git a/MAINTAINERS b/MAINTAINERS
> index a0dd762f5648..40a77e5fd2fd 100644
> --- a/MAINTAINERS
> +++ b/MAINTAINERS
> @@ -7909,7 +7909,7 @@ F:	drivers/gpu/drm/panel/panel-ilitek-ili9805.c
>   DRM DRIVER FOR ILITEK ILI9806E PANELS
>   M:	Michael Walle <mwalle@kernel.org>
>   S:	Maintained
> -F:	drivers/gpu/drm/panel/panel-ilitek-ili9806e.c
> +F:	drivers/gpu/drm/panel/panel-ilitek-ili9806e-dsi.c
>   
>   DRM DRIVER FOR JADARD JD9365DA-H3 MIPI-DSI LCD PANELS
>   M:	Jagan Teki <jagan@edgeble.ai>
> diff --git a/drivers/gpu/drm/panel/Kconfig b/drivers/gpu/drm/panel/Kconfig
> index 7a83804fedca..9ab72f3ab32e 100644
> --- a/drivers/gpu/drm/panel/Kconfig
> +++ b/drivers/gpu/drm/panel/Kconfig
> @@ -260,12 +260,20 @@ config DRM_PANEL_ILITEK_ILI9805
>   config DRM_PANEL_ILITEK_ILI9806E
>   	tristate "Ilitek ILI9806E-based panels"
>   	depends on OF
> -	depends on DRM_MIPI_DSI

You may need to check if this symbol is used in a kernel config and rename it,
and I think this one should be renamed as _CORE, with the tristate and help
text removed, the DSI and SPI should simply select it.

But first in this patch, just remove this entry and re-introduce an hidden
code config on the next patch.

>   	depends on BACKLIGHT_CLASS_DEVICE
>   	help
>   	  Say Y if you want to enable support for panels based on the
>   	  Ilitek ILI9806E controller.
>   
> +config DRM_PANEL_ILITEK_ILI9806E_DSI
> +	tristate "Ilitek ILI9806E DSI panel"
> +	depends on DRM_MIPI_DSI
> +	depends on DRM_PANEL_ILITEK_ILI9806E
> +	default DRM_PANEL_ILITEK_ILI9806E
> +	help
> +	  Say Y here if you want to be able to access the Ilitek
> +	  ILI9806E panel using DSI.
> +
>   config DRM_PANEL_ILITEK_ILI9881C
>   	tristate "Ilitek ILI9881C-based panels"
>   	depends on OF
> diff --git a/drivers/gpu/drm/panel/Makefile b/drivers/gpu/drm/panel/Makefile
> index b9562a6fdcb3..00071a983242 100644
> --- a/drivers/gpu/drm/panel/Makefile
> +++ b/drivers/gpu/drm/panel/Makefile
> @@ -26,7 +26,7 @@ obj-$(CONFIG_DRM_PANEL_HYDIS_HV101HD1) += panel-hydis-hv101hd1.o
>   obj-$(CONFIG_DRM_PANEL_ILITEK_IL9322) += panel-ilitek-ili9322.o
>   obj-$(CONFIG_DRM_PANEL_ILITEK_ILI9341) += panel-ilitek-ili9341.o
>   obj-$(CONFIG_DRM_PANEL_ILITEK_ILI9805) += panel-ilitek-ili9805.o
> -obj-$(CONFIG_DRM_PANEL_ILITEK_ILI9806E) += panel-ilitek-ili9806e.o
> +obj-$(CONFIG_DRM_PANEL_ILITEK_ILI9806E_DSI) += panel-ilitek-ili9806e-dsi.o
>   obj-$(CONFIG_DRM_PANEL_ILITEK_ILI9881C) += panel-ilitek-ili9881c.o
>   obj-$(CONFIG_DRM_PANEL_ILITEK_ILI9882T) += panel-ilitek-ili9882t.o
>   obj-$(CONFIG_DRM_PANEL_INNOLUX_EJ030NA) += panel-innolux-ej030na.o
> diff --git a/drivers/gpu/drm/panel/panel-ilitek-ili9806e.c b/drivers/gpu/drm/panel/panel-ilitek-ili9806e-dsi.c
> similarity index 99%
> rename from drivers/gpu/drm/panel/panel-ilitek-ili9806e.c
> rename to drivers/gpu/drm/panel/panel-ilitek-ili9806e-dsi.c
> index 18aa6222b0c5..e02e28b67e29 100644
> --- a/drivers/gpu/drm/panel/panel-ilitek-ili9806e.c
> +++ b/drivers/gpu/drm/panel/panel-ilitek-ili9806e-dsi.c
> @@ -561,5 +561,5 @@ module_mipi_dsi_driver(ili9806e_dsi_driver);
>   
>   MODULE_AUTHOR("Gunnar Dibbern <gunnar.dibbern@lht.dlh.de>");
>   MODULE_AUTHOR("Michael Walle <mwalle@kernel.org>");
> -MODULE_DESCRIPTION("Ilitek ILI9806E Controller Driver");
> +MODULE_DESCRIPTION("Ilitek ILI9806E LCD DSI Controller Driver");
>   MODULE_LICENSE("GPL");


  reply	other threads:[~2026-01-09  9:01 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-01-06 15:43 [PATCH 0/3] drm/panel: ilitek-ili9806e: add Rocktech RK050HR345-CT106A support Dario Binacchi
2026-01-06 15:43 ` [PATCH 1/3] drm/panel: ilitek-ili9806e: prepare for multiple bus support Dario Binacchi
2026-01-09  9:01   ` Neil Armstrong [this message]
2026-01-06 15:43 ` [PATCH 2/3] dt-bindings: ili9806e: add Rocktech RK050HR345-CT106A display Dario Binacchi
2026-01-07  8:09   ` Krzysztof Kozlowski
2026-01-06 15:43 ` [PATCH 3/3] drm/panel: ilitek-ili9806e: add Rocktech RK050HR345-CT106A SPI panel Dario Binacchi

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=cfa5724f-6cb6-4458-be20-9b4d518dd693@linaro.org \
    --to=neil.armstrong@linaro.org \
    --cc=airlied@gmail.com \
    --cc=dario.binacchi@amarulasolutions.com \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=jesszhan0024@gmail.com \
    --cc=linux-amarula@amarulasolutions.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=maarten.lankhorst@linux.intel.com \
    --cc=mripard@kernel.org \
    --cc=mwalle@kernel.org \
    --cc=simona@ffwll.ch \
    --cc=tzimmermann@suse.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®