From: Kieran Bingham <kieran.bingham+renesas@ideasonboard.com>
To: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Cc: linux-renesas-soc@vger.kernel.org,
David Airlie <airlied@linux.ie>,
"open list:DRM DRIVERS FOR RENESAS"
<dri-devel@lists.freedesktop.org>,
open list <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 07/17] drm: rcar-du: Add R8A77965 support
Date: Fri, 27 Apr 2018 11:14:34 +0100 [thread overview]
Message-ID: <cfe1b007-de3e-d8c0-90f8-4be8f36b324d@ideasonboard.com> (raw)
In-Reply-To: <1954980.A0ABKULED7@avalon>
On 26/04/18 21:43, Laurent Pinchart wrote:
> Hi Kieran,
>
> Thank you for the patch.
>
> On Thursday, 26 April 2018 19:53:36 EEST Kieran Bingham wrote:
>> The R8A77965 (M3-N) SoC provides VGA, HDMI and LVDS output.
>>
>> This platform is unusual in that the VGA is connected to DU3 leaving DU2
>> unpopulated. This is reflected by the channel_mask accordingly.
>
> I'd write s/VGA/DPAD/g (or s/VGA/RGB/g) as the DPAD output can be used for
> other purposes than VGA.
>
>> Signed-off-by: Kieran Bingham <kieran.bingham+renesas@ideasonboard.com>
>> ---
>> drivers/gpu/drm/rcar-du/rcar_du_drv.c | 29 +++++++++++++++++++++++++++
>> 1 file changed, 29 insertions(+)
>>
>> diff --git a/drivers/gpu/drm/rcar-du/rcar_du_drv.c
>> b/drivers/gpu/drm/rcar-du/rcar_du_drv.c index d6ebc628fc22..4d195ff8c569
>> 100644
>> --- a/drivers/gpu/drm/rcar-du/rcar_du_drv.c
>> +++ b/drivers/gpu/drm/rcar-du/rcar_du_drv.c
>> @@ -246,6 +246,34 @@ static const struct rcar_du_device_info
>> rcar_du_r8a7796_info = { .dpll_ch = BIT(1),
>> };
>>
>> +static const struct rcar_du_device_info rcar_du_r8a77965_info = {
>> + .gen = 3,
>> + .features = RCAR_DU_FEATURE_CRTC_IRQ_CLOCK
>> + | RCAR_DU_FEATURE_EXT_CTRL_REGS
>> + | RCAR_DU_FEATURE_VSP1_SOURCE,
>> + .channel_mask = BIT(0) | BIT(1) | BIT(3),
>
> Depending on what you think of my suggestions for patch 05/17, you might want
> to reverse the bit order here.
Done.
>
>> + .routes = {
>> + /*
>> + * R8A77965 has one RGB output, one LVDS output and one HDMI
>> + * output.
>> + */
>> + [RCAR_DU_OUTPUT_DPAD0] = {
>> + .possible_crtcs = BIT(2),
>> + .port = 0,
>> + },
>> + [RCAR_DU_OUTPUT_HDMI0] = {
>> + .possible_crtcs = BIT(1),
>> + .port = 1,
>> + },
>> + [RCAR_DU_OUTPUT_LVDS0] = {
>> + .possible_crtcs = BIT(0),
>
> I wonder whether it wouldn't be easier to read if we replaced possible_crtcs
> with possible_channels, as this structure describes the hardware and had its
> num_crtcs field replaced with a channel_mask. This would require converting
> the possible_channels field to a possible_crtcs field in
> rcar_du_modeset_init(), and I think that no change would be needed in
> rcar_du_group_setup_defr8() (but please double check). On the other hand, no
> code would be simplified, and rcar_du_modeset_init() would gain some
> additional complexity, so it might not be worth it.
I think we can leave this for now and consider it later if worth while.
>
> Either way this patch looks good to me.
>
> Reviewed-by: Laurent Pinchart <laurent.pinchart@ideasonboard.com>
Thanks, collected.
--
Kieran
>
>> + .port = 2,
>> + },
>> + },
>> + .num_lvds = 1,
>> + .dpll_ch = BIT(1),
>> +};
>> +
>> static const struct rcar_du_device_info rcar_du_r8a77970_info = {
>> .gen = 3,
>> .features = RCAR_DU_FEATURE_CRTC_IRQ_CLOCK
>> @@ -277,6 +305,7 @@ static const struct of_device_id rcar_du_of_table[] = {
>> { .compatible = "renesas,du-r8a7794", .data = &rcar_du_r8a7794_info },
>> { .compatible = "renesas,du-r8a7795", .data = &rcar_du_r8a7795_info },
>> { .compatible = "renesas,du-r8a7796", .data = &rcar_du_r8a7796_info },
>> + { .compatible = "renesas,du-r8a77965", .data = &rcar_du_r8a77965_info },
>> { .compatible = "renesas,du-r8a77970", .data = &rcar_du_r8a77970_info },
>> { }
>> };
>
next prev parent reply other threads:[~2018-04-27 10:14 UTC|newest]
Thread overview: 43+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <20180426165346.494-1-kieran.bingham+renesas@ideasonboard.com>
2018-04-26 16:53 ` [PATCH 01/17] dt-bindings: display: renesas: du: Increase indent in output table Kieran Bingham
2018-04-26 20:08 ` Laurent Pinchart
2018-04-26 16:53 ` [PATCH 02/17] dt-bindings: display: renesas: du: Document the R8A77965 bindings Kieran Bingham
2018-04-26 16:57 ` Kieran Bingham
2018-04-26 20:10 ` Laurent Pinchart
2018-04-27 8:40 ` Kieran Bingham
2018-04-26 16:53 ` [PATCH 03/17] pinctrl: sh-pfc: r8a77965: Add DU RGB output pins, groups and functions Kieran Bingham
2018-04-26 20:16 ` Laurent Pinchart
2018-04-26 16:53 ` [PATCH 04/17] drm: rcar-du: Use the correct naming for ODPM fields in DEFR6 Kieran Bingham
2018-04-26 20:18 ` Laurent Pinchart
2018-04-26 16:53 ` [PATCH 05/17] drm: rcar-du: Split CRTC handling to support hardware indexing Kieran Bingham
2018-04-26 20:30 ` Laurent Pinchart
2018-04-27 10:15 ` Kieran Bingham
2018-04-26 16:53 ` [PATCH 06/17] drm: rcar-du: Allow DU groups to work with " Kieran Bingham
2018-04-26 20:36 ` Laurent Pinchart
2018-04-27 10:10 ` Kieran Bingham
2018-04-26 16:53 ` [PATCH 07/17] drm: rcar-du: Add R8A77965 support Kieran Bingham
2018-04-26 20:43 ` Laurent Pinchart
2018-04-27 10:14 ` Kieran Bingham [this message]
2018-04-26 16:53 ` [PATCH 08/17] arm64: dts: r8a77965: Provide sysc header definitions Kieran Bingham
2018-04-26 20:53 ` Laurent Pinchart
2018-04-26 16:53 ` [PATCH 09/17] arm64: dts: r8a77965: Use the correct CPG header Kieran Bingham
2018-04-26 21:16 ` Laurent Pinchart
2018-04-26 16:53 ` [PATCH 10/17] arm64: dts: r8a77965: Add FCPF and FCPV instances Kieran Bingham
2018-04-26 21:06 ` Laurent Pinchart
2018-04-26 16:53 ` [PATCH 11/17] arm64: dts: r8a77965: Add VSP instances Kieran Bingham
2018-04-26 21:11 ` Laurent Pinchart
2018-04-27 16:33 ` Kieran Bingham
2018-06-08 9:29 ` Geert Uytterhoeven
2018-06-08 11:00 ` Laurent Pinchart
2018-04-26 16:53 ` [PATCH 12/17] arm64: dts: r8a77965: Populate the DU instance placeholder Kieran Bingham
2018-04-26 21:15 ` Laurent Pinchart
2018-04-27 16:34 ` Kieran Bingham
2018-04-26 16:53 ` [PATCH 13/17] arm64: dts: r8a77965: Add HDMI encoder instance Kieran Bingham
2018-04-26 21:17 ` Laurent Pinchart
2018-04-26 16:53 ` [PATCH 14/17] arm64: dts: r8a77965-salvator-x: Add DU external dot clocks Kieran Bingham
2018-04-26 21:18 ` Laurent Pinchart
2018-04-26 16:53 ` [PATCH 15/17] arm64: dts: r8a77965-salvator-x: Enable HDMI output Kieran Bingham
2018-04-26 21:21 ` Laurent Pinchart
2018-04-27 16:22 ` Kieran Bingham
2018-04-26 16:53 ` [PATCH 16/17] arm64: dts: r8a77965-salvator-xs: Add DU external dot clocks Kieran Bingham
2018-04-26 21:22 ` Laurent Pinchart
2018-04-26 16:53 ` [PATCH 17/17] arm64: dts: r8a77965-salvator-xs: Enable HDMI output Kieran Bingham
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=cfe1b007-de3e-d8c0-90f8-4be8f36b324d@ideasonboard.com \
--to=kieran.bingham+renesas@ideasonboard.com \
--cc=airlied@linux.ie \
--cc=dri-devel@lists.freedesktop.org \
--cc=kieran.bingham@ideasonboard.com \
--cc=laurent.pinchart@ideasonboard.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-renesas-soc@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®