From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1759220AbcCDJus (ORCPT ); Fri, 4 Mar 2016 04:50:48 -0500 Received: from cn.fujitsu.com ([59.151.112.132]:15356 "EHLO heian.cn.fujitsu.com" rhost-flags-OK-FAIL-OK-FAIL) by vger.kernel.org with ESMTP id S1759904AbcCDJtV (ORCPT ); Fri, 4 Mar 2016 04:49:21 -0500 X-IronPort-AV: E=Sophos;i="5.22,518,1449504000"; d="scan'208";a="4234069" From: Zhao Lei To: , , , , , Subject: [PATCH v2 0/2] cpuacct: rename parameter in cpuusage_write for readability Date: Fri, 4 Mar 2016 17:47:04 +0800 Message-ID: X-Mailer: git-send-email 1.8.5.1 MIME-Version: 1.0 Content-Type: text/plain X-yoursite-MailScanner-ID: 314B542AC84A.A54A4 X-yoursite-MailScanner: Found to be clean X-yoursite-MailScanner-From: zhaolei@cn.fujitsu.com Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org The name of 'reset' makes a little confusion in reading, we would say, if we want to reset usage, return -EINVAL. That's not true. Actually, we want to say, we only allow user to do a reset. This patch rename reset to val and add a comment here, making the code more readable. Changelog v1->v2: 1: Rebase on top of 4.5-rc6 2: Fix little spelling typo in description. 3: Fix line over 80 characters 4: Add Acked-by: Tejun Heo Yang Dongsheng (2): cpuacct: rename parameter in cpuusage_write for readability cpuacct: split usage into user_usage and sys_usage. kernel/sched/cpuacct.c | 151 ++++++++++++++++++++++++++++++++++++++++++------- 1 file changed, 129 insertions(+), 22 deletions(-) -- 1.8.5.1