mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Uwe Kleine-König (The Capable Hub)" <u.kleine-koenig@baylibre.com>
To: Arnd Bergmann <arnd@arndb.de>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Cc: linux-kernel@vger.kernel.org
Subject: [PATCH v2 0/2] misc: pch_phub: Two cleanups
Date: Sun, 24 May 2026 12:38:24 +0200	[thread overview]
Message-ID: <cover.1779618644.git.u.kleine-koenig@baylibre.com> (raw)

Hello,

v1 of this series is available at
https://lore.kernel.org/cover.1779360001.git.u.kleine-koenig@baylibre.com.

Sashiko[1] found a few issues that are addressed here:

 - Drop various members from pch_phub_reg (patch #1)
 - Also handle ioh_type comparisons against magic constants
 - Using an enum shifts the values used to identify the different
   hardware variants. For the corner case where new pci ids are added at
   runtime to the driver 0 is special. I think this doesn't matter in
   practise but I noted that in the commit log.

@Greg: I already received mail that you picked up v1 of this series. I
hope it's not too late to drop it still?! Please tell me if you don't
want to drop it any more, then I send incremental patches for the issues
addressed here.

Best regards
Uwe

[1] https://sashiko.dev/#/patchset/cover.1779360001.git.u.kleine-koenig%40baylibre.com

Uwe Kleine-König (The Capable Hub) (2):
  misc: pch_phub: Drop two unused functions
  misc: pch_phub: Introduce an enum for device indentification

 drivers/misc/pch_phub.c | 181 +++++-----------------------------------
 1 file changed, 19 insertions(+), 162 deletions(-)


base-commit: 254f49634ee16a731174d2ae34bc50bd5f45e731
-- 
2.47.3


             reply	other threads:[~2026-05-24 10:38 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-05-24 10:38 Uwe Kleine-König (The Capable Hub) [this message]
2026-05-24 10:38 ` [PATCH v2 1/2] misc: pch_phub: Drop two unused functions Uwe Kleine-König (The Capable Hub)
2026-05-24 10:38 ` [PATCH v2 2/2] misc: pch_phub: Introduce an enum for device indentification Uwe Kleine-König (The Capable Hub)
2026-05-24 13:51 ` [PATCH v2 0/2] misc: pch_phub: Two cleanups Greg Kroah-Hartman
2026-05-26  8:54   ` Uwe Kleine-König (The Capable Hub)

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=cover.1779618644.git.u.kleine-koenig@baylibre.com \
    --to=u.kleine-koenig@baylibre.com \
    --cc=arnd@arndb.de \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-kernel@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome