From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751525AbdJWDWp (ORCPT ); Sun, 22 Oct 2017 23:22:45 -0400 Received: from mx0a-001b2d01.pphosted.com ([148.163.156.1]:53754 "EHLO mx0a-001b2d01.pphosted.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751082AbdJWDWo (ORCPT ); Sun, 22 Oct 2017 23:22:44 -0400 Subject: Re: [PATCH] mm/swap: Use page flags to determine LRU list in __activate_page() To: Michal Hocko , Anshuman Khandual References: <20171019145657.11199-1-khandual@linux.vnet.ibm.com> <20171019153322.c4uqalws7l7fdzcx@dhcp22.suse.cz> Cc: linux-mm@kvack.org, linux-kernel@vger.kernel.org, akpm@linux-foundation.org, shli@kernel.org From: Anshuman Khandual Date: Mon, 23 Oct 2017 08:52:34 +0530 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.5.1 MIME-Version: 1.0 In-Reply-To: <20171019153322.c4uqalws7l7fdzcx@dhcp22.suse.cz> Content-Type: text/plain; charset=windows-1252 Content-Transfer-Encoding: 7bit X-TM-AS-MML: disable x-cbid: 17102303-0040-0000-0000-000003E5BD02 X-IBM-AV-DETECTION: SAVI=unused REMOTE=unused XFE=unused x-cbparentid: 17102303-0041-0000-0000-000025E822E3 Message-Id: X-Proofpoint-Virus-Version: vendor=fsecure engine=2.50.10432:,, definitions=2017-10-23_02:,, signatures=0 X-Proofpoint-Spam-Details: rule=outbound_notspam policy=outbound score=0 spamscore=0 suspectscore=0 malwarescore=0 phishscore=0 adultscore=0 bulkscore=0 classifier=spam adjust=0 reason=mlx scancount=1 engine=8.0.1-1707230000 definitions=main-1710230047 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 10/19/2017 09:03 PM, Michal Hocko wrote: > On Thu 19-10-17 20:26:57, Anshuman Khandual wrote: >> Its already assumed that the PageActive flag is clear on the input >> page, hence page_lru(page) will pick the base LRU for the page. In >> the same way page_lru(page) will pick active base LRU, once the >> flag PageActive is set on the page. This change of LRU list should >> happen implicitly through the page flags instead of being hard >> coded. > > The patch description tells what but it doesn't explain _why_? Does the > resulting code is better, more optimized or is this a pure readability > thing? Not really. Not only it removes couple of lines of code but it also makes it look more logical from function flow point of view as well. > > All I can see is that page_lru is more complex and a large part of it > can be optimized away which has been done manually here. I suspect the > compiler can deduce the same thing. Why not ? I mean, that is the essence of the function page_lru() which should get us the exact LRU list the page should be on and hence we should not hand craft these manually.