mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Fenghua Yu <fenghua.yu@intel.com>
To: Babu Moger <babu.moger@amd.com>, <corbet@lwn.net>,
	<reinette.chatre@intel.com>, <tglx@linutronix.de>,
	<mingo@redhat.com>, <bp@alien8.de>
Cc: <dave.hansen@linux.intel.com>, <x86@kernel.org>, <hpa@zytor.com>,
	<paulmck@kernel.org>, <akpm@linux-foundation.org>,
	<quic_neeraju@quicinc.com>, <rdunlap@infradead.org>,
	<damien.lemoal@opensource.wdc.com>, <songmuchun@bytedance.com>,
	<peterz@infradead.org>, <jpoimboe@kernel.org>,
	<pbonzini@redhat.com>, <chang.seok.bae@intel.com>,
	<pawan.kumar.gupta@linux.intel.com>, <jmattson@google.com>,
	<daniel.sneddon@linux.intel.com>, <sandipan.das@amd.com>,
	<tony.luck@intel.com>, <james.morse@arm.com>,
	<linux-doc@vger.kernel.org>, <linux-kernel@vger.kernel.org>,
	<bagasdotme@gmail.com>, <eranian@google.com>,
	<christophe.leroy@csgroup.eu>, <jarkko@kernel.org>,
	<adrian.hunter@intel.com>, <quic_jiles@quicinc.com>,
	<peternewman@google.com>
Subject: Re: [PATCH v9 8/9] x86/resctrl: Display CLOSID for resource group
Date: Mon, 11 Sep 2023 11:08:27 -0700	[thread overview]
Message-ID: <d0bd1c6f-f1df-5355-5fc8-4fbd3be7d1e2@intel.com> (raw)
In-Reply-To: <20230907235128.19120-9-babu.moger@amd.com>

Hi, Babu,

On 9/7/23 16:51, Babu Moger wrote:
> In x86, hardware uses CLOSID to identify a control group. When a user
> creates a control group this information is not visible to the user.
> It can help resctrl debugging.
> 
> Add CLOSID(ctrl_hw_id) to the control groups display in resctrl
> interface. Users can see this detail when resctrl is mounted with
> "-o debug" option.
> 
> Other architectures do not use "CLOSID". Use the names ctrl_hw_id
> to refer to "CLOSID" in an effort to keep the naming generic.
> 
> For example:
>   $cat /sys/fs/resctrl/ctrl_grp1/ctrl_hw_id
>   1
> 
> Signed-off-by: Babu Moger <babu.moger@amd.com>
> ---
>   Documentation/arch/x86/resctrl.rst     |  4 ++++
>   arch/x86/kernel/cpu/resctrl/internal.h |  3 +++
>   arch/x86/kernel/cpu/resctrl/rdtgroup.c | 23 +++++++++++++++++++++++
>   3 files changed, 30 insertions(+)
> 
> diff --git a/Documentation/arch/x86/resctrl.rst b/Documentation/arch/x86/resctrl.rst
> index 28d35aaa74b4..54691c8b832d 100644
> --- a/Documentation/arch/x86/resctrl.rst
> +++ b/Documentation/arch/x86/resctrl.rst
> @@ -352,6 +352,10 @@ When control is enabled all CTRL_MON groups will also contain:
>   	file. On successful pseudo-locked region creation the mode will
>   	automatically change to "pseudo-locked".
>   
> +"ctrl_hw_id":
> +	Available only with debug option. The identifier used by hardware
> +	for the control group. On x86 this is the CLOSID.
> +
>   When monitoring is enabled all MON groups will also contain:
>   
>   "mon_data":
> diff --git a/arch/x86/kernel/cpu/resctrl/internal.h b/arch/x86/kernel/cpu/resctrl/internal.h
> index 38b99a21ccd8..ccdbed615d41 100644
> --- a/arch/x86/kernel/cpu/resctrl/internal.h
> +++ b/arch/x86/kernel/cpu/resctrl/internal.h
> @@ -299,6 +299,9 @@ struct rdtgroup {
>    *		--> RFTYPE_CTRL (Files only for CTRL group)
>    *		    Files: mode, schemata, size
>    *
> + *			--> RFTYPE_DEBUG (Files to help resctrl debugging)
> + *			    File: ctrl_hw_id
> + *
>    */
>   #define RFTYPE_INFO			BIT(0)
>   #define RFTYPE_BASE			BIT(1)
> diff --git a/arch/x86/kernel/cpu/resctrl/rdtgroup.c b/arch/x86/kernel/cpu/resctrl/rdtgroup.c
> index 67b315f3a26c..8be0fb323ad3 100644
> --- a/arch/x86/kernel/cpu/resctrl/rdtgroup.c
> +++ b/arch/x86/kernel/cpu/resctrl/rdtgroup.c
> @@ -779,6 +779,22 @@ static int rdtgroup_tasks_show(struct kernfs_open_file *of,
>   	return ret;
>   }
>   
> +static int rdtgroup_closid_show(struct kernfs_open_file *of,
> +				struct seq_file *s, void *v)
> +{
> +	struct rdtgroup *rdtgrp;
> +	int ret = 0;
> +
> +	rdtgrp = rdtgroup_kn_lock_live(of->kn);
> +	if (rdtgrp)
> +		seq_printf(s, "%u\n", rdtgrp->closid);
> +	else
> +		ret = -ENOENT;
> +	rdtgroup_kn_unlock(of->kn);
> +
> +	return ret;
> +}
> +
>   #ifdef CONFIG_PROC_CPU_RESCTRL
>   
>   /*
> @@ -1863,6 +1879,13 @@ static struct rftype res_common_files[] = {
>   		.seq_show	= rdtgroup_size_show,
>   		.fflags		= RFTYPE_CTRL_BASE,
>   	},
> +	{
> +		.name		= "ctrl_hw_id",
> +		.mode		= 0444,
> +		.kf_ops		= &rdtgroup_kf_single_ops,
> +		.seq_show	= rdtgroup_closid_show,

Is it better to rename "rdtgroup_closid_show" as arch neutral name 
"rdtgroup_ctrl_hw_id_show"? So the name is arch neutral and reflects the 
ctrl_hw_id. So this can eventually go to generic fs code without 
renaming it. The getting closid implementation in the function will be 
arch specific.

> +		.fflags		= RFTYPE_CTRL_BASE | RFTYPE_DEBUG,
> +	},
>   
>   };
>   

Thanks.

-Fenghua

  reply	other threads:[~2023-09-11 21:30 UTC|newest]

Thread overview: 26+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-09-07 23:51 [PATCH v9 0/9] x86/resctrl: Miscellaneous resctrl features Babu Moger
2023-09-07 23:51 ` [PATCH v9 1/9] x86/resctrl: Add multiple tasks to the resctrl group at once Babu Moger
2023-09-11 17:51   ` Fenghua Yu
2023-09-07 23:51 ` [PATCH v9 2/9] x86/resctrl: Simplify rftype flag definitions Babu Moger
2023-09-07 23:51 ` [PATCH v9 3/9] x86/resctrl: Rename rftype flags for consistency Babu Moger
2023-09-07 23:51 ` [PATCH v9 4/9] x86/resctrl: Add comments on RFTYPE flags hierarchy Babu Moger
2023-09-11 17:56   ` Fenghua Yu
2023-09-07 23:51 ` [PATCH v9 5/9] x86/resctrl: Unwind the errors inside rdt_enable_ctx() Babu Moger
2023-09-11 22:58   ` Reinette Chatre
2023-09-12 16:54     ` Moger, Babu
2023-09-07 23:51 ` [PATCH v9 6/9] x86/resctrl: Move default group file creation to mount Babu Moger
2023-09-11 17:58   ` Fenghua Yu
2023-09-11 23:05   ` Reinette Chatre
2023-09-07 23:51 ` [PATCH v9 7/9] x86/resctrl: Introduce "-o debug" mount option Babu Moger
2023-09-07 23:51 ` [PATCH v9 8/9] x86/resctrl: Display CLOSID for resource group Babu Moger
2023-09-11 18:08   ` Fenghua Yu [this message]
2023-09-11 21:53     ` Reinette Chatre
2023-09-07 23:51 ` [PATCH v9 9/9] x86/resctrl: Display RMID of " Babu Moger
2023-09-11 18:14   ` Fenghua Yu
2023-09-12 17:18     ` Moger, Babu
2023-09-11 23:08   ` Reinette Chatre
2023-09-12 17:39     ` Moger, Babu
2023-09-12 17:57       ` Reinette Chatre
2023-09-12 19:45         ` Moger, Babu
2023-09-11 23:08 ` [PATCH v9 0/9] x86/resctrl: Miscellaneous resctrl features Reinette Chatre
2023-09-12 16:53   ` Moger, Babu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=d0bd1c6f-f1df-5355-5fc8-4fbd3be7d1e2@intel.com \
    --to=fenghua.yu@intel.com \
    --cc=adrian.hunter@intel.com \
    --cc=akpm@linux-foundation.org \
    --cc=babu.moger@amd.com \
    --cc=bagasdotme@gmail.com \
    --cc=bp@alien8.de \
    --cc=chang.seok.bae@intel.com \
    --cc=christophe.leroy@csgroup.eu \
    --cc=corbet@lwn.net \
    --cc=damien.lemoal@opensource.wdc.com \
    --cc=daniel.sneddon@linux.intel.com \
    --cc=dave.hansen@linux.intel.com \
    --cc=eranian@google.com \
    --cc=hpa@zytor.com \
    --cc=james.morse@arm.com \
    --cc=jarkko@kernel.org \
    --cc=jmattson@google.com \
    --cc=jpoimboe@kernel.org \
    --cc=linux-doc@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=paulmck@kernel.org \
    --cc=pawan.kumar.gupta@linux.intel.com \
    --cc=pbonzini@redhat.com \
    --cc=peternewman@google.com \
    --cc=peterz@infradead.org \
    --cc=quic_jiles@quicinc.com \
    --cc=quic_neeraju@quicinc.com \
    --cc=rdunlap@infradead.org \
    --cc=reinette.chatre@intel.com \
    --cc=sandipan.das@amd.com \
    --cc=songmuchun@bytedance.com \
    --cc=tglx@linutronix.de \
    --cc=tony.luck@intel.com \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®