From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1758019AbdJMMY6 (ORCPT ); Fri, 13 Oct 2017 08:24:58 -0400 Received: from mail.kernel.org ([198.145.29.99]:59888 "EHLO mail.kernel.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753276AbdJMMY5 (ORCPT ); Fri, 13 Oct 2017 08:24:57 -0400 DMARC-Filter: OpenDMARC Filter v1.3.2 mail.kernel.org 6A83621874 Authentication-Results: mail.kernel.org; dmarc=none (p=none dis=none) header.from=kernel.org Authentication-Results: mail.kernel.org; spf=none smtp.mailfrom=chao@kernel.org Subject: Re: [f2fs-dev] [PATCH] f2fs: add bug_on when f2fs_gc even fails to get one victim To: Yunlong Song , jaegeuk@kernel.org, yuchao0@huawei.com, yunlong.song@icloud.com Cc: linux-fsdevel@vger.kernel.org, miaoxie@huawei.com, linux-kernel@vger.kernel.org, linux-f2fs-devel@lists.sourceforge.net References: <1507729864-118702-1-git-send-email-yunlong.song@huawei.com> <7a3f0052-86e0-4e46-c89b-048d6137b820@kernel.org> From: Chao Yu Message-ID: Date: Fri, 13 Oct 2017 20:24:15 +0800 User-Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Thunderbird/52.4.0 MIME-Version: 1.0 In-Reply-To: Content-Type: text/plain; charset=utf-8 Content-Language: en-US Content-Transfer-Encoding: 8bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 2017/10/13 19:20, Yunlong Song wrote: > Yep, both are OK, since I do not care it is foreground or background. Here it just needs to do gc. But you only set need_gc as true for foreground GC case. Thanks, > > On 2017/10/13 19:09, Chao Yu wrote: >> On 2017/10/11 21:51, Yunlong Song wrote: >>> This can help us to debug on some corner case. >>> >>> Signed-off-by: Yunlong Song >>> --- >>>   fs/f2fs/gc.c | 6 +++++- >>>   1 file changed, 5 insertions(+), 1 deletion(-) >>> >>> diff --git a/fs/f2fs/gc.c b/fs/f2fs/gc.c >>> index 197ebf4..960503e 100644 >>> --- a/fs/f2fs/gc.c >>> +++ b/fs/f2fs/gc.c >>> @@ -986,6 +986,7 @@ int f2fs_gc(struct f2fs_sb_info *sbi, bool sync, >>>           .ilist = LIST_HEAD_INIT(gc_list.ilist), >>>           .iroot = RADIX_TREE_INIT(GFP_NOFS), >>>       }; >>> +    bool need_gc = false; >> How about changing variable name to need_fggc for better readability? >> >> Thanks, >> >>>         trace_f2fs_gc_begin(sbi->sb, sync, background, >>>                   get_pages(sbi, F2FS_DIRTY_NODES), >>> @@ -1018,8 +1019,10 @@ int f2fs_gc(struct f2fs_sb_info *sbi, bool sync, >>>               if (ret) >>>                   goto stop; >>>           } >>> -        if (has_not_enough_free_secs(sbi, 0, 0)) >>> +        if (has_not_enough_free_secs(sbi, 0, 0)) { >>>               gc_type = FG_GC; >>> +            need_gc = true; >>> +        } >>>       } >>>         /* f2fs_balance_fs doesn't need to do BG_GC in critical path. */ >>> @@ -1028,6 +1031,7 @@ int f2fs_gc(struct f2fs_sb_info *sbi, bool sync, >>>           goto stop; >>>       } >>>       if (!__get_victim(sbi, &segno, gc_type)) { >>> +        f2fs_bug_on(sbi, !total_freed && need_gc); >>>           ret = -ENODATA; >>>           goto stop; >>>       } >>> >> . >> >