mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Shameerali Kolothum Thodi <shameerali.kolothum.thodi@huawei.com>
To: Max Gurtovoy <mgurtovoy@nvidia.com>,
	"kvm@vger.kernel.org" <kvm@vger.kernel.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"linux-crypto@vger.kernel.org" <linux-crypto@vger.kernel.org>
Cc: "alex.williamson@redhat.com" <alex.williamson@redhat.com>,
	"jgg@nvidia.com" <jgg@nvidia.com>,
	liulongfang <liulongfang@huawei.com>,
	"Zengtao (B)" <prime.zeng@hisilicon.com>,
	Jonathan Cameron <jonathan.cameron@huawei.com>,
	"Wangzhou (B)" <wangzhou1@hisilicon.com>
Subject: RE: [PATCH v3 3/6] hisi_acc_qm: Move PCI device IDs to common header
Date: Fri, 24 Sep 2021 08:18:52 +0000	[thread overview]
Message-ID: <d21236b3bdfc44e698a66de4b1444a85@huawei.com> (raw)
In-Reply-To: <fd1624d5-4661-75e7-6c28-bfbfd877f889@nvidia.com>



> -----Original Message-----
> From: Max Gurtovoy [mailto:mgurtovoy@nvidia.com]
> Sent: 22 September 2021 16:11
> To: Shameerali Kolothum Thodi <shameerali.kolothum.thodi@huawei.com>;
> kvm@vger.kernel.org; linux-kernel@vger.kernel.org;
> linux-crypto@vger.kernel.org
> Cc: alex.williamson@redhat.com; jgg@nvidia.com; Linuxarm
> <linuxarm@huawei.com>; liulongfang <liulongfang@huawei.com>; Zengtao (B)
> <prime.zeng@hisilicon.com>; Jonathan Cameron
> <jonathan.cameron@huawei.com>; Wangzhou (B) <wangzhou1@hisilicon.com>
> Subject: Re: [PATCH v3 3/6] hisi_acc_qm: Move PCI device IDs to common
> header
> 
> 
> On 9/15/2021 12:50 PM, Shameer Kolothum wrote:
> > Move the PCI Device IDs of HiSilicon ACC devices to
> > a common header and use a uniform naming convention.
> >
> > This will be useful when we introduce the vfio PCI
> > HiSilicon ACC live migration driver in subsequent patches.
> >
> > Signed-off-by: Shameer Kolothum
> <shameerali.kolothum.thodi@huawei.com>
> > ---
> >   drivers/crypto/hisilicon/hpre/hpre_main.c | 12 +++++-------
> >   drivers/crypto/hisilicon/sec2/sec_main.c  |  2 --
> >   drivers/crypto/hisilicon/zip/zip_main.c   | 11 ++++-------
> >   include/linux/hisi_acc_qm.h               |  7 +++++++
> >   4 files changed, 16 insertions(+), 16 deletions(-)
> >
> > diff --git a/drivers/crypto/hisilicon/hpre/hpre_main.c
> b/drivers/crypto/hisilicon/hpre/hpre_main.c
> > index 65a641396c07..1de67b5baae3 100644
> > --- a/drivers/crypto/hisilicon/hpre/hpre_main.c
> > +++ b/drivers/crypto/hisilicon/hpre/hpre_main.c
> > @@ -68,8 +68,6 @@
> >   #define HPRE_REG_RD_INTVRL_US		10
> >   #define HPRE_REG_RD_TMOUT_US		1000
> >   #define HPRE_DBGFS_VAL_MAX_LEN		20
> > -#define HPRE_PCI_DEVICE_ID		0xa258
> > -#define HPRE_PCI_VF_DEVICE_ID		0xa259
> >   #define HPRE_QM_USR_CFG_MASK		GENMASK(31, 1)
> >   #define HPRE_QM_AXI_CFG_MASK		GENMASK(15, 0)
> >   #define HPRE_QM_VFG_AX_MASK		GENMASK(7, 0)
> > @@ -111,8 +109,8 @@
> >   static const char hpre_name[] = "hisi_hpre";
> >   static struct dentry *hpre_debugfs_root;
> >   static const struct pci_device_id hpre_dev_ids[] = {
> > -	{ PCI_DEVICE(PCI_VENDOR_ID_HUAWEI, HPRE_PCI_DEVICE_ID) },
> > -	{ PCI_DEVICE(PCI_VENDOR_ID_HUAWEI, HPRE_PCI_VF_DEVICE_ID) },
> > +	{ PCI_DEVICE(PCI_VENDOR_ID_HUAWEI, HPRE_PF_PCI_DEVICE_ID) },
> > +	{ PCI_DEVICE(PCI_VENDOR_ID_HUAWEI, HPRE_VF_PCI_DEVICE_ID) },
> >   	{ 0, }
> >   };
> >
> > @@ -242,7 +240,7 @@ MODULE_PARM_DESC(uacce_mode,
> UACCE_MODE_DESC);
> >
> >   static int pf_q_num_set(const char *val, const struct kernel_param *kp)
> >   {
> > -	return q_num_set(val, kp, HPRE_PCI_DEVICE_ID);
> > +	return q_num_set(val, kp, HPRE_PF_PCI_DEVICE_ID);
> >   }
> >
> >   static const struct kernel_param_ops hpre_pf_q_num_ops = {
> > @@ -921,7 +919,7 @@ static int hpre_debugfs_init(struct hisi_qm *qm)
> >   	qm->debug.sqe_mask_len = HPRE_SQE_MASK_LEN;
> >   	hisi_qm_debug_init(qm);
> >
> > -	if (qm->pdev->device == HPRE_PCI_DEVICE_ID) {
> > +	if (qm->pdev->device == HPRE_PF_PCI_DEVICE_ID) {
> >   		ret = hpre_ctrl_debug_init(qm);
> >   		if (ret)
> >   			goto failed_to_create;
> > @@ -958,7 +956,7 @@ static int hpre_qm_init(struct hisi_qm *qm, struct
> pci_dev *pdev)
> >   	qm->sqe_size = HPRE_SQE_SIZE;
> >   	qm->dev_name = hpre_name;
> >
> > -	qm->fun_type = (pdev->device == HPRE_PCI_DEVICE_ID) ?
> > +	qm->fun_type = (pdev->device == HPRE_PF_PCI_DEVICE_ID) ?
> >   			QM_HW_PF : QM_HW_VF;
> >   	if (qm->fun_type == QM_HW_PF) {
> >   		qm->qp_base = HPRE_PF_DEF_Q_BASE;
> > diff --git a/drivers/crypto/hisilicon/sec2/sec_main.c
> b/drivers/crypto/hisilicon/sec2/sec_main.c
> > index 90551bf38b52..890ff6ab18dd 100644
> > --- a/drivers/crypto/hisilicon/sec2/sec_main.c
> > +++ b/drivers/crypto/hisilicon/sec2/sec_main.c
> > @@ -20,8 +20,6 @@
> >
> >   #define SEC_VF_NUM			63
> >   #define SEC_QUEUE_NUM_V1		4096
> > -#define SEC_PF_PCI_DEVICE_ID		0xa255
> > -#define SEC_VF_PCI_DEVICE_ID		0xa256
> >
> >   #define SEC_BD_ERR_CHK_EN0		0xEFFFFFFF
> >   #define SEC_BD_ERR_CHK_EN1		0x7ffff7fd
> > diff --git a/drivers/crypto/hisilicon/zip/zip_main.c
> b/drivers/crypto/hisilicon/zip/zip_main.c
> > index 7148201ce76e..f35b8fd1ecfe 100644
> > --- a/drivers/crypto/hisilicon/zip/zip_main.c
> > +++ b/drivers/crypto/hisilicon/zip/zip_main.c
> > @@ -15,9 +15,6 @@
> >   #include <linux/uacce.h>
> >   #include "zip.h"
> >
> > -#define PCI_DEVICE_ID_ZIP_PF		0xa250
> > -#define PCI_DEVICE_ID_ZIP_VF		0xa251
> > -
> >   #define HZIP_QUEUE_NUM_V1		4096
> >
> >   #define HZIP_CLOCK_GATE_CTRL		0x301004
> > @@ -246,7 +243,7 @@ MODULE_PARM_DESC(uacce_mode,
> UACCE_MODE_DESC);
> >
> >   static int pf_q_num_set(const char *val, const struct kernel_param *kp)
> >   {
> > -	return q_num_set(val, kp, PCI_DEVICE_ID_ZIP_PF);
> > +	return q_num_set(val, kp, ZIP_PF_PCI_DEVICE_ID);
> >   }
> >
> >   static const struct kernel_param_ops pf_q_num_ops = {
> > @@ -268,8 +265,8 @@ module_param_cb(vfs_num, &vfs_num_ops,
> &vfs_num, 0444);
> >   MODULE_PARM_DESC(vfs_num, "Number of VFs to enable(1-63),
> 0(default)");
> >
> >   static const struct pci_device_id hisi_zip_dev_ids[] = {
> > -	{ PCI_DEVICE(PCI_VENDOR_ID_HUAWEI, PCI_DEVICE_ID_ZIP_PF) },
> > -	{ PCI_DEVICE(PCI_VENDOR_ID_HUAWEI, PCI_DEVICE_ID_ZIP_VF) },
> > +	{ PCI_DEVICE(PCI_VENDOR_ID_HUAWEI, ZIP_PF_PCI_DEVICE_ID) },
> > +	{ PCI_DEVICE(PCI_VENDOR_ID_HUAWEI, ZIP_VF_PCI_DEVICE_ID) },
> >   	{ 0, }
> >   };
> >   MODULE_DEVICE_TABLE(pci, hisi_zip_dev_ids);
> > @@ -834,7 +831,7 @@ static int hisi_zip_qm_init(struct hisi_qm *qm, struct
> pci_dev *pdev)
> >   	qm->sqe_size = HZIP_SQE_SIZE;
> >   	qm->dev_name = hisi_zip_name;
> >
> > -	qm->fun_type = (pdev->device == PCI_DEVICE_ID_ZIP_PF) ?
> > +	qm->fun_type = (pdev->device == ZIP_PF_PCI_DEVICE_ID) ?
> >   			QM_HW_PF : QM_HW_VF;
> >   	if (qm->fun_type == QM_HW_PF) {
> >   		qm->qp_base = HZIP_PF_DEF_Q_BASE;
> > diff --git a/include/linux/hisi_acc_qm.h b/include/linux/hisi_acc_qm.h
> > index 8befb59c6fb3..2d209bf15419 100644
> > --- a/include/linux/hisi_acc_qm.h
> > +++ b/include/linux/hisi_acc_qm.h
> > @@ -9,6 +9,13 @@
> >   #include <linux/module.h>
> >   #include <linux/pci.h>
> >
> > +#define ZIP_PF_PCI_DEVICE_ID		0xa250
> > +#define ZIP_VF_PCI_DEVICE_ID		0xa251
> > +#define SEC_PF_PCI_DEVICE_ID		0xa255
> > +#define SEC_VF_PCI_DEVICE_ID		0xa256
> > +#define HPRE_PF_PCI_DEVICE_ID		0xa258
> > +#define HPRE_VF_PCI_DEVICE_ID		0xa259
> > +
> 
> maybe can be added to include/linux/pci_ids.h under the
> PCI_VENDOR_ID_HUAWEI definition ?

Make sense. Will do.

Thanks,
Shameer
 
> 
> >   #define QM_QNUM_V1			4096
> >   #define QM_QNUM_V2			1024
> >   #define QM_MAX_VFS_NUM_V2		63

  reply	other threads:[~2021-09-24  8:19 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-09-15  9:50 [PATCH v3 0/6] vfio/hisilicon: add acc live migration driver Shameer Kolothum
2021-09-15  9:50 ` [PATCH v3 1/6] crypto: hisilicon/qm: Move the QM header to include/linux Shameer Kolothum
2021-09-15 12:49   ` Jason Gunthorpe
2021-09-15  9:50 ` [PATCH v3 2/6] crypto: hisilicon/qm: Move few definitions to common header Shameer Kolothum
2021-09-15  9:50 ` [PATCH v3 3/6] hisi_acc_qm: Move PCI device IDs " Shameer Kolothum
2021-09-22 15:11   ` Max Gurtovoy
2021-09-24  8:18     ` Shameerali Kolothum Thodi [this message]
2021-09-15  9:50 ` [PATCH v3 4/6] hisi-acc-vfio-pci: add new vfio_pci driver for HiSilicon ACC devices Shameer Kolothum
2021-09-15 12:51   ` Jason Gunthorpe
2021-09-15 13:35     ` Shameerali Kolothum Thodi
2021-09-15  9:50 ` [PATCH v3 5/6] hisi_acc_vfio_pci: Restrict access to VF dev BAR2 migration region Shameer Kolothum
2021-09-15  9:50 ` [PATCH v3 6/6] hisi_acc_vfio_pci: Add support for VFIO live migration Shameer Kolothum
2021-09-15 13:07   ` Jason Gunthorpe
2021-09-15 13:28     ` Shameerali Kolothum Thodi
2021-09-16 13:58       ` Jason Gunthorpe
2021-09-27 13:46         ` Shameerali Kolothum Thodi
2021-09-27 15:01           ` Jason Gunthorpe
2021-09-27 15:27             ` Shameerali Kolothum Thodi
2021-09-27 16:00             ` Leon Romanovsky
2021-09-27 16:06               ` Jason Gunthorpe
2021-09-27 18:17                 ` Leon Romanovsky
2021-09-27 18:22                   ` Jason Gunthorpe
2021-09-27 18:30                     ` Leon Romanovsky
2021-09-27 18:32                       ` Jason Gunthorpe
2021-09-29  3:57 ` [PATCH v3 0/6] vfio/hisilicon: add acc live migration driver Tian, Kevin
2021-09-29  8:34   ` Shameerali Kolothum Thodi
2021-09-29  9:05     ` Tian, Kevin
2021-09-29  9:16       ` Shameerali Kolothum Thodi
2021-09-30  0:42         ` Tian, Kevin
2021-09-30  6:34           ` Shameerali Kolothum Thodi
2021-10-15  5:53             ` Tian, Kevin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=d21236b3bdfc44e698a66de4b1444a85@huawei.com \
    --to=shameerali.kolothum.thodi@huawei.com \
    --cc=alex.williamson@redhat.com \
    --cc=jgg@nvidia.com \
    --cc=jonathan.cameron@huawei.com \
    --cc=kvm@vger.kernel.org \
    --cc=linux-crypto@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=liulongfang@huawei.com \
    --cc=mgurtovoy@nvidia.com \
    --cc=prime.zeng@hisilicon.com \
    --cc=wangzhou1@hisilicon.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome