From: Philipp Zabel <p.zabel@pengutronix.de>
To: Inki Dae <inki.dae@samsung.com>,
Jagan Teki <jagan@amarulasolutions.com>,
Marek Szyprowski <m.szyprowski@samsung.com>,
Andrzej Hajda <andrzej.hajda@intel.com>,
Neil Armstrong <neil.armstrong@linaro.org>,
Robert Foss <rfoss@kernel.org>,
Laurent Pinchart <Laurent.pinchart@ideasonboard.com>,
Jonas Karlman <jonas@kwiboo.se>,
Jernej Skrabec <jernej.skrabec@gmail.com>,
Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
Maxime Ripard <mripard@kernel.org>,
Thomas Zimmermann <tzimmermann@suse.de>,
David Airlie <airlied@gmail.com>,
Simona Vetter <simona@ffwll.ch>
Cc: dri-devel@lists.freedesktop.org, linux-kernel@vger.kernel.org,
kernel@pengutronix.de
Subject: Re: [PATCH 0/2] drm/bridge: samsung-dsim: Small cleanups
Date: Fri, 27 Jun 2025 13:49:09 +0200 [thread overview]
Message-ID: <d21382cf4ff508fb4b21536373875f5566b6d35e.camel@pengutronix.de> (raw)
In-Reply-To: <20250527-samsung-dsim-v1-0-5be520d84fbb@pengutronix.de>
On Di, 2025-05-27 at 16:21 +0200, Philipp Zabel wrote:
> Replace an open-coded goto-again construct with a while loop and a
> custom MHZ macro with the common HZ_PER_MHZ.
>
> Signed-off-by: Philipp Zabel <p.zabel@pengutronix.de>
> ---
> Philipp Zabel (2):
> drm/bridge: samsung-dsim: use while loop in samsung_dsim_transfer_start
> drm/bridge: samsung-dsim: Use HZ_PER_MHZ macro from units.h
>
> drivers/gpu/drm/bridge/samsung-dsim.c | 77 +++++++++++++++--------------------
> 1 file changed, 33 insertions(+), 44 deletions(-)
> ---
> base-commit: 99764593528f9e0ee9509f9e4a4eb21db99d0681
> change-id: 20250527-samsung-dsim-2bae3b45f77b
>
> Best regards,
Applied to drm-misc-next.
[1/2] drm/bridge: samsung-dsim: use while loop in samsung_dsim_transfer_start
commit: bafc628678796e3a05bd54c30280f4ecdaf3ebba
[2/2] drm/bridge: samsung-dsim: Use HZ_PER_MHZ macro from units.h
commit: b462b0ef4d788d56f0e575406e58450358dcbd96
regards
Philipp
prev parent reply other threads:[~2025-06-27 11:49 UTC|newest]
Thread overview: 8+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-05-27 14:21 Philipp Zabel
2025-05-27 14:21 ` [PATCH 1/2] drm/bridge: samsung-dsim: use while loop in samsung_dsim_transfer_start Philipp Zabel
2025-05-27 14:52 ` Frieder Schrempf
2025-05-27 15:10 ` Alexander Stein
2025-05-27 14:21 ` [PATCH 2/2] drm/bridge: samsung-dsim: Use HZ_PER_MHZ macro from units.h Philipp Zabel
2025-05-27 14:53 ` Frieder Schrempf
2025-05-27 15:12 ` Alexander Stein
2025-06-27 11:49 ` Philipp Zabel [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=d21382cf4ff508fb4b21536373875f5566b6d35e.camel@pengutronix.de \
--to=p.zabel@pengutronix.de \
--cc=Laurent.pinchart@ideasonboard.com \
--cc=airlied@gmail.com \
--cc=andrzej.hajda@intel.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=inki.dae@samsung.com \
--cc=jagan@amarulasolutions.com \
--cc=jernej.skrabec@gmail.com \
--cc=jonas@kwiboo.se \
--cc=kernel@pengutronix.de \
--cc=linux-kernel@vger.kernel.org \
--cc=m.szyprowski@samsung.com \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mripard@kernel.org \
--cc=neil.armstrong@linaro.org \
--cc=rfoss@kernel.org \
--cc=simona@ffwll.ch \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®