mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Hans Verkuil <hverkuil@xs4all.nl>
To: Tomasz Figa <tfiga@chromium.org>,
	Sakari Ailus <sakari.ailus@linux.intel.com>
Cc: "Laurent Pinchart" <laurent.pinchart@ideasonboard.com>,
	"Krzysztof Kozlowski" <krzysztof.kozlowski@linaro.org>,
	"Mauro Carvalho Chehab" <mchehab@kernel.org>,
	"Marek Szyprowski" <m.szyprowski@samsung.com>,
	"Maxim Levitsky" <maximlevitsky@gmail.com>,
	"Sean Young" <sean@mess.org>,
	"Olli Salonen" <olli.salonen@iki.fi>,
	"Abylay Ospan" <aospan@amazon.com>,
	"Jemma Denson" <jdenson@gmail.com>,
	"Patrick Boettcher" <patrick.boettcher@posteo.de>,
	"Jacopo Mondi" <jacopo+renesas@jmondi.org>,
	"Kieran Bingham" <kieran.bingham+renesas@ideasonboard.com>,
	"Niklas Söderlund" <niklas.soderlund+renesas@ragnatech.se>,
	"Tim Harvey" <tharvey@gateworks.com>,
	"Andy Walls" <awalls@md.metrocast.net>,
	"Bingbu Cao" <bingbu.cao@intel.com>,
	linux-media@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 5/6] media: platform: Use str_enable_disable-like helpers
Date: Thu, 20 Feb 2025 14:51:23 +0100	[thread overview]
Message-ID: <d3cf3e65-fe43-4c0b-bfb5-03fdd3c9fc29@xs4all.nl> (raw)
In-Reply-To: <CAAFQd5ASMNr2tO+R1sYa58diWLHJr8iomKA2-PinEojCdXT98A@mail.gmail.com>

On 1/15/25 08:47, Tomasz Figa wrote:
> On Wed, Jan 15, 2025 at 4:39 PM Sakari Ailus
> <sakari.ailus@linux.intel.com> wrote:
>>
>> Hi Laurent,
>>
>> On Tue, Jan 14, 2025 at 10:42:40PM +0200, Laurent Pinchart wrote:
>>> Hi Krzysztof,
>>>
>>> Thank you for the patch.
>>>
>>> On Tue, Jan 14, 2025 at 08:46:21PM +0100, Krzysztof Kozlowski wrote:
>>>> Replace ternary (condition ? "enable" : "disable") syntax with helpers
>>>> from string_choices.h because:
>>>> 1. Simple function call with one argument is easier to read.  Ternary
>>>>    operator has three arguments and with wrapping might lead to quite
>>>>    long code.
>>>
>>> It's more difficult to read for me.
>>
>> I don't have any issue in using the ternary operator either. Using these
>> helpers makes the lines generally 3 characters shorter.
>>
>>>
>>>> 2. Is slightly shorter thus also easier to read.
>>>> 3. It brings uniformity in the text - same string.
>>>> 4. Allows deduping by the linker, which results in a smaller binary
>>>>    file.
>>>
>>> I don't see why the linker can't de-dup string in the current code.
>>
>> In fact the functions are static inline so from that point of view I don't
>> think there's any difference.
>>
>>>
>>> I'm sorry, I just don't see the point in doing this. I'd like to avoid
>>> those changes in the Linux media subsystem, or at the very least in
>>> drivers I maintain.
>>
>> I don't have much of an opinion, perhaps I slightly prefer using these as
>> the rest of the kernel does, too. Yet if we choose not to use these
>> helpers, we continue to be occasional targets of largish patchsets "fixing"
>> this.
> 
> To put one more aspect on the scales:
> 
> These kinds of patches actually make it more difficult to backport
> changes (e.g. fixes) to stable kernels, so my preference would be to
> only use the new helpers in new drivers.

I agree with Tomasz. Now, if the whole kernel is converting to these
new functions, then I guess we should follow, but from what I can tell
that doesn't appear to be the case.

I'll reject this series. It can always be resurrected if there is
sufficient demand for this.

Regards,

	Hans

> 
> Best regards,
> Tomasz
> 


  reply	other threads:[~2025-02-20 13:51 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-01-14 19:46 [PATCH 0/6] media: " Krzysztof Kozlowski
2025-01-14 19:46 ` [PATCH 1/6] " Krzysztof Kozlowski
2025-01-14 19:46 ` [PATCH 2/6] media: dvb: " Krzysztof Kozlowski
2025-01-14 19:46 ` [PATCH 3/6] media: i2c: " Krzysztof Kozlowski
2025-01-14 19:46 ` [PATCH 4/6] media: pci: " Krzysztof Kozlowski
2025-01-14 19:46 ` [PATCH 5/6] media: platform: " Krzysztof Kozlowski
2025-01-14 20:42   ` Laurent Pinchart
2025-01-14 21:06     ` Krzysztof Kozlowski
2025-01-15  7:44       ` Laurent Pinchart
2025-01-15  7:39     ` Sakari Ailus
2025-01-15  7:47       ` Tomasz Figa
2025-02-20 13:51         ` Hans Verkuil [this message]
2025-01-14 19:46 ` [PATCH 6/6] media: usb: " Krzysztof Kozlowski

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=d3cf3e65-fe43-4c0b-bfb5-03fdd3c9fc29@xs4all.nl \
    --to=hverkuil@xs4all.nl \
    --cc=aospan@amazon.com \
    --cc=awalls@md.metrocast.net \
    --cc=bingbu.cao@intel.com \
    --cc=jacopo+renesas@jmondi.org \
    --cc=jdenson@gmail.com \
    --cc=kieran.bingham+renesas@ideasonboard.com \
    --cc=krzysztof.kozlowski@linaro.org \
    --cc=laurent.pinchart@ideasonboard.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-media@vger.kernel.org \
    --cc=m.szyprowski@samsung.com \
    --cc=maximlevitsky@gmail.com \
    --cc=mchehab@kernel.org \
    --cc=niklas.soderlund+renesas@ragnatech.se \
    --cc=olli.salonen@iki.fi \
    --cc=patrick.boettcher@posteo.de \
    --cc=sakari.ailus@linux.intel.com \
    --cc=sean@mess.org \
    --cc=tfiga@chromium.org \
    --cc=tharvey@gateworks.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®