From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1752923AbcHALY0 (ORCPT ); Mon, 1 Aug 2016 07:24:26 -0400 Received: from mout.web.de ([212.227.15.3]:59354 "EHLO mout.web.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751530AbcHALYQ (ORCPT ); Mon, 1 Aug 2016 07:24:16 -0400 Subject: Re: [Cocci] [PATCH v3] Coccinelle: Script to replace allocate and memset with zalloc functions To: Amitoj Kaur Chawla References: <20160801070233.GA19102@amitoj-Inspiron-3542> From: SF Markus Elfring Cc: LKML , Coccinelle , Gilles Muller , Julia Lawall , Michal Marek , Nicolas Palix Message-ID: Date: Mon, 1 Aug 2016 13:23:33 +0200 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Thunderbird/45.2 MIME-Version: 1.0 In-Reply-To: <20160801070233.GA19102@amitoj-Inspiron-3542> Content-Type: text/plain; charset=windows-1252 Content-Transfer-Encoding: 7bit X-Provags-ID: V03:K0:TRb9rqgHNvUwr/fyJqoivRGqh8Q4qD0p2//SAgpWsuDIBlmmKXN wZOGSWoBBMiOZT0WUtX0IAg9CW+LRLqBRcwPQmWITzGOdZjxquW2lO4jkGCbFcQV9My+fEM wdKJWeT6hk3o0i/9if6ToWAvc9SDqhWSoUCR8wQ4XvEvUmqaNkli9vblHsCrko1QpLfoQX4 D2QY8dhwiSwsQ5X6hLeyQ== X-UI-Out-Filterresults: notjunk:1;V01:K0:lnsxuLN2xzM=:wYaJ15qIHZknJxinDGCLwW TrakcC3jQ7fWpMVjfa5kvLv/fVHG+YMh8tezmeODYJ1VQU9hAxXCkpJBBFH8aabPeBBRF676z 1fOyCneuCTjGSQRgkB5DLsWRuqGTTJBQOzW3wdS+jY/vc2H60T0hGSi3dqapmDZ7patnuATRp Dre+W10eX2lY/hc+Gl2aF0XrKVCZXCzbYj88IOH5q9GNv16G6qSm3gNbPrvqO/fkiIe82aLEM CbwajateVkWaB74uyVsVS9LFA9qjBITBF8Lzri+XBntorwExTRXDBgol/GVmcGiTHj0bh3gJF y2GfT5bgVNwhFGN07I9S/n1IflWfC711BXJTeSf0P51XNHa6FPEYqlAIdFI1y3utYvs+DlTjV zymt8rVkT03jelQlJjJh4F3BcBT7QQ1JjgBw5Vo1z8p5G/MOXMP/lMxsKnOQ2GOyIdDnAxbcd ZqXWSYfX2UxmgA/KZdMsVpCvSUmLsiHFmIyJZKMDgdknDUk+EWBEjdf6AwHHjcetZ6U2n5oMe a9BlxzQUv6UB5NMxyfaiEsc8Y2bRJKeIcCwKC5dOvP4dmp9GzdbIqswbJ6qzny/zryBf380nv 3WyUeQJmfiO6kG3rLVsHWyNHiOcUFvOqjBbfU2X0NETpUCnLlkGWzGg9keoZ3ygBrOu6J/58D IfXBfqzIF2KWfIERo6Od2tQPUv7bVSvMIaHvXyv0fyrDSTHeohxGraRR4qJu5v6MqWl4GVAxO qER2CyreRB/MkCc59MQf6FKUX2+Vj/1S+GdmBTBPmlHObVfBy2vJ4qyCekx7FL5Ku03Kf/o0r X//SWKY Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org > +@vz1 depends on patch && !context && !org && !report@ > +type T; > +T *d; > +statement S; > +@@ > + > + d = > +- vmalloc > ++ vzalloc > + (...); > + if (!d) S > +- memset(d, 0, sizeof(T)); > + > +@vz2 depends on patch && !context && !org && !report@ > +expression d; > +statement S; > +@@ > + > + d = > +- vmalloc > ++ vzalloc > + (...); > + if (!d) S > +- memset(d, 0, sizeof(*d)); I suggest to take another look at a few implementation details. 1. Would it make sense to merge such SmPL rules into one so that code duplication could be reduced a bit in such a script? 2. How do you think about to extend the shown check list with the function "kvm_kvzalloc"? 3. Do you want to maintain a growing (?) function name list manually? Regards, Markus