From: Florian Fainelli <f.fainelli@gmail.com>
To: Vivien Didelot <vivien.didelot@savoirfairelinux.com>,
netdev@vger.kernel.org
Cc: linux-kernel@vger.kernel.org, kernel@savoirfairelinux.com,
"David S. Miller" <davem@davemloft.net>,
Andrew Lunn <andrew@lunn.ch>
Subject: Re: [PATCH net-next] net: dsa: rename switch operations structure
Date: Wed, 24 Aug 2016 14:15:39 -0700 [thread overview]
Message-ID: <d4265fdc-1624-7c40-5779-786bdb63375d@gmail.com> (raw)
In-Reply-To: <20160823163856.21456-1-vivien.didelot@savoirfairelinux.com>
On 08/23/2016 09:38 AM, Vivien Didelot wrote:
> Now that the dsa_switch_driver structure contains only function pointers
> as it is supposed to, rename it to the more appropriate dsa_switch_ops,
> uniformly to any other operations structure in the kernel.
>
> No functional changes here, basically just the result of something like:
> s/dsa_switch_driver *drv/dsa_switch_ops *ops/g
>
> However keep the {un,}register_switch_driver functions and their
> dsa_switch_drivers list as is, since they represent the -- likely to be
> deprecated soon -- legacy DSA registration framework.
>
> In the meantime, also fix the following checks from checkpatch.pl to
> make it happy with this patch:
>
> CHECK: Comparison to NULL could be written "!ops"
> #403: FILE: net/dsa/dsa.c:470:
> + if (ops == NULL) {
>
> CHECK: Comparison to NULL could be written "ds->ops->get_strings"
> #773: FILE: net/dsa/slave.c:697:
> + if (ds->ops->get_strings != NULL)
>
> CHECK: Comparison to NULL could be written "ds->ops->get_ethtool_stats"
> #824: FILE: net/dsa/slave.c:785:
> + if (ds->ops->get_ethtool_stats != NULL)
>
> CHECK: Comparison to NULL could be written "ds->ops->get_sset_count"
> #835: FILE: net/dsa/slave.c:798:
> + if (ds->ops->get_sset_count != NULL)
>
> total: 0 errors, 0 warnings, 4 checks, 784 lines checked
>
> Signed-off-by: Vivien Didelot <vivien.didelot@savoirfairelinux.com>
Acked-by: Florian Fainelli <f.fainelli@gmail.com>
Thanks!
--
Florian
next prev parent reply other threads:[~2016-08-24 21:15 UTC|newest]
Thread overview: 3+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-08-23 16:38 Vivien Didelot
2016-08-24 21:15 ` Florian Fainelli [this message]
2016-08-25 4:46 ` David Miller
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=d4265fdc-1624-7c40-5779-786bdb63375d@gmail.com \
--to=f.fainelli@gmail.com \
--cc=andrew@lunn.ch \
--cc=davem@davemloft.net \
--cc=kernel@savoirfairelinux.com \
--cc=linux-kernel@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=vivien.didelot@savoirfairelinux.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®