mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: luojiaxing <luojiaxing@huawei.com>
To: Greg KH <gregkh@linuxfoundation.org>
Cc: <akpm@linux-foundation.org>, <viro@zeniv.linux.org.uk>,
	<andriy.shevchenko@linux.intel.com>,
	<linux-kernel@vger.kernel.org>, <martin.petersen@oracle.com>,
	<john.garry@huawei.com>, <himanshu.madhani@cavium.com>,
	<felipe.balbi@linux.intel.com>, <uma.shankar@intel.com>,
	<anshuman.gupta@intel.com>, <animesh.manna@intel.com>,
	<linux-usb@vger.kernel.org>, <linux-scsi@vger.kernel.org>,
	<linuxarm@huawei.com>
Subject: Re: [PATCH v2 0/5] Introduce a new helper marco DEFINE_SHOW_STORE_ATTRIBUTE at seq_file.c
Date: Tue, 3 Nov 2020 16:19:09 +0800	[thread overview]
Message-ID: <d4852df0-d7e0-ee7e-352c-58eaf47c2c72@huawei.com> (raw)
In-Reply-To: <20201030084448.GA1625087@kroah.com>

Hi

On 2020/10/30 16:44, Greg KH wrote:
> On Fri, Oct 30, 2020 at 04:31:57PM +0800, Luo Jiaxing wrote:
>> We already own DEFINE_SHOW_ATTRIBUTE() helper macro for defining attribute
>> for read-only file, but we found many of drivers also want a helper marco for
>> read-write file too.
>>
>> So we try to add this macro to help decrease code duplication.
>>
>> Luo Jiaxing (5):
>>    seq_file: Introduce DEFINE_SHOW_STORE_ATTRIBUTE() helper macro
>>    scsi: hisi_sas: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs
>>    scsi: qla2xxx: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs
>>    usb: dwc3: debugfs: Introduce DEFINE_SHOW_STORE_ATTRIBUTE
>>    drm/i915/display: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs
> What changed from v1?


Sorry, I should add a commit for the change.


In v1, Andy pointed out that the old name of DEFINE_STORE_ATTRIBUTE was 
easily misunderstood as a write-only file rather than a read-write file.

Therefore, it is changed to DEFINE_SHOW_STORE_ATTRIBUTE according to his 
suggestion.


Thanks

Jiaxing


>
> thanks,
>
> greg k-h
>
> .
>


  reply	other threads:[~2020-11-03  8:19 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-10-30  8:31 Luo Jiaxing
2020-10-30  8:31 ` [PATCH v2 1/5] seq_file: Introduce DEFINE_SHOW_STORE_ATTRIBUTE() helper macro Luo Jiaxing
2020-10-30  8:31 ` [PATCH v2 2/5] scsi: hisi_sas: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs Luo Jiaxing
2020-10-30  8:32 ` [PATCH v2 3/5] scsi: qla2xxx: " Luo Jiaxing
2020-10-31  8:45   ` kernel test robot
2020-10-30  8:32 ` [PATCH v2 4/5] usb: dwc3: debugfs: Introduce DEFINE_SHOW_STORE_ATTRIBUTE Luo Jiaxing
2020-10-30  8:59   ` Felipe Balbi
2020-10-30  8:32 ` [PATCH v2 5/5] drm/i915/display: Introduce DEFINE_SHOW_STORE_ATTRIBUTE for debugfs Luo Jiaxing
2020-10-31 11:06   ` kernel test robot
2020-10-30  8:44 ` [PATCH v2 0/5] Introduce a new helper marco DEFINE_SHOW_STORE_ATTRIBUTE at seq_file.c Greg KH
2020-11-03  8:19   ` luojiaxing [this message]
2020-11-03  8:27     ` Greg KH

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=d4852df0-d7e0-ee7e-352c-58eaf47c2c72@huawei.com \
    --to=luojiaxing@huawei.com \
    --cc=akpm@linux-foundation.org \
    --cc=andriy.shevchenko@linux.intel.com \
    --cc=animesh.manna@intel.com \
    --cc=anshuman.gupta@intel.com \
    --cc=felipe.balbi@linux.intel.com \
    --cc=gregkh@linuxfoundation.org \
    --cc=himanshu.madhani@cavium.com \
    --cc=john.garry@huawei.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-scsi@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    --cc=linuxarm@huawei.com \
    --cc=martin.petersen@oracle.com \
    --cc=uma.shankar@intel.com \
    --cc=viro@zeniv.linux.org.uk \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®