From: Paolo Bonzini <pbonzini@redhat.com>
To: Sean Christopherson <sean.j.christopherson@intel.com>
Cc: Vitaly Kuznetsov <vkuznets@redhat.com>,
Wanpeng Li <wanpengli@tencent.com>,
Jim Mattson <jmattson@google.com>, Joerg Roedel <joro@8bytes.org>,
kvm@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 0/5] KVM: x86: X86_FEATURE bit() cleanup
Date: Wed, 15 Jan 2020 19:07:41 +0100 [thread overview]
Message-ID: <d53bd488-b871-47c4-c65c-4c231eff3cf9@redhat.com> (raw)
In-Reply-To: <20191217213242.11712-1-sean.j.christopherson@intel.com>
On 17/12/19 22:32, Sean Christopherson wrote:
> Small series to add build-time protections on reverse CPUID lookup (and
> other usages of bit()), and to rename the misleading-generic bit() helper
> to something that better conveys its purpose.
>
> I don't love emulator changes in patch 1 as adding one-off helpers is a
> bit silly, but IMO it's the lesser of two evils, e.g. adding dedicated
> helpers is arguably less error prone than manually encoding a CPUID
> lookup, and the helpers approach avoids having to include cpuid.h in the
> emulator code.
>
> v2:
> - Rework the assertions to use the reverse_cpuid table instead of
> using the last cpufeatures word (which was not at all intuitive).
>
> Sean Christopherson (5):
> KVM: x86: Add dedicated emulator helpers for querying CPUID features
> KVM: x86: Move bit() helper to cpuid.h
> KVM: x86: Add CPUID_7_1_EAX to the reverse CPUID table
> KVM: x86: Expand build-time assertion on reverse CPUID usage
> KVM: x86: Refactor and rename bit() to feature_bit() macro
>
> arch/x86/include/asm/kvm_emulate.h | 4 +++
> arch/x86/kvm/cpuid.c | 5 ++--
> arch/x86/kvm/cpuid.h | 41 +++++++++++++++++++++++++----
> arch/x86/kvm/emulate.c | 21 +++------------
> arch/x86/kvm/svm.c | 4 +--
> arch/x86/kvm/vmx/vmx.c | 42 +++++++++++++++---------------
> arch/x86/kvm/x86.c | 18 +++++++++++++
> arch/x86/kvm/x86.h | 5 ----
> 8 files changed, 87 insertions(+), 53 deletions(-)
>
Queued, thanks.
Paolo
prev parent reply other threads:[~2020-01-15 18:07 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-12-17 21:32 Sean Christopherson
2019-12-17 21:32 ` [PATCH v2 1/5] KVM: x86: Add dedicated emulator helpers for querying CPUID features Sean Christopherson
2019-12-17 21:32 ` [PATCH v2 2/5] KVM: x86: Move bit() helper to cpuid.h Sean Christopherson
2019-12-17 21:32 ` [PATCH v2 3/5] KVM: x86: Add CPUID_7_1_EAX to the reverse CPUID table Sean Christopherson
2019-12-17 21:32 ` [PATCH v2 4/5] KVM: x86: Expand build-time assertion on reverse CPUID usage Sean Christopherson
2019-12-17 21:32 ` [PATCH v2 5/5] KVM: x86: Refactor and rename bit() to feature_bit() macro Sean Christopherson
2020-01-15 18:07 ` Paolo Bonzini [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=d53bd488-b871-47c4-c65c-4c231eff3cf9@redhat.com \
--to=pbonzini@redhat.com \
--cc=jmattson@google.com \
--cc=joro@8bytes.org \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=sean.j.christopherson@intel.com \
--cc=vkuznets@redhat.com \
--cc=wanpengli@tencent.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®