From: Armin Wolf <W_Armin@gmx.de>
To: Derek John Clark <derekjohn.clark@gmail.com>
Cc: "Hans de Goede" <hdegoede@redhat.com>,
"Ilpo Järvinen" <ilpo.jarvinen@linux.intel.com>,
"Jonathan Corbet" <corbet@lwn.net>,
"Mario Limonciello" <superm1@kernel.org>,
"Luke Jones" <luke@ljones.dev>, "Xino Ni" <nijs1@lenovo.com>,
"Zhixin Zhang" <zhangzx36@lenovo.com>,
"Mia Shao" <shaohz1@lenovo.com>,
"Mark Pearson" <mpearson-lenovo@squebb.ca>,
"Pierre-Loup A . Griffais" <pgriffais@valvesoftware.com>,
"Cody T . -H . Chiu" <codyit@gmail.com>,
"John Martens" <johnfanv2@gmail.com>,
platform-driver-x86@vger.kernel.org, linux-doc@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH v4 4/6 RESEND] platform/x86: Add Lenovo Capability Data 01 WMI Driver
Date: Thu, 3 Apr 2025 03:40:12 +0200 [thread overview]
Message-ID: <d5920e7b-2e5e-4958-b7e4-5e1395aa0e24@gmx.de> (raw)
In-Reply-To: <CAFqHKT=6iKG4UmF2-PUESCDDnLcgzon5Z3UqJd+vNrXLXf9CSQ@mail.gmail.com>
Am 02.04.25 um 22:47 schrieb Derek John Clark:
> On Wed, Mar 26, 2025 at 6:29 PM Armin Wolf <W_Armin@gmx.de> wrote:
>> Am 17.03.25 um 15:43 schrieb Derek J. Clark:
>>
>>> Adds lenovo-wmi-capdata01 driver which provides the
>>> LENOVO_CAPABILITY_DATA_01 WMI data block that comes on "Other Mode"
>>> enabled hardware. Provides an interface for querying if a given
>>> attribute is supported by the hardware, as well as its default_value,
>>> max_value, min_value, and step increment.
>>>
>>> Signed-off-by: Derek J. Clark <derekjohn.clark@gmail.com>
>>> ---
>>> v4:
>>> - Make driver data a private struct, remove references from Other Mode
>>> driver.
>>> - Don't cache data at device initialization. Instead, on component bind,
>>> cache the data on a member variable of the Other Mode driver data
>>> passed as a void pointer.
>>> - Add header file for capdata01 structs.
>>> - Add new struct to pass capdata01 array data and array length to Other
>>> Mode.
>>> v3:
>>> - Add as component to lenovo-wmi-other driver.
>>> v2:
>>> - Use devm_kmalloc to ensure driver can be instanced, remove global
>>> reference.
>>> - Ensure reverse Christmas tree for all variable declarations.
>>> - Remove extra whitespace.
>>> - Use guard(mutex) in all mutex instances, global mutex.
>>> - Use pr_fmt instead of adding the driver name to each pr_err.
>>> - Remove noisy pr_info usage.
>>> - Rename capdata_wmi to lenovo_wmi_cd01_priv and cd01_wmi to priv.
>>> - Use list to get the lenovo_wmi_cd01_priv instance in
>>> lenovo_wmi_capdata01_get as none of the data provided by the macros
>>> that will use it can pass a member of the struct for use in
>>> container_of.
>>> ---
>>> MAINTAINERS | 2 +
>>> drivers/platform/x86/Kconfig | 4 +
>>> drivers/platform/x86/Makefile | 1 +
>>> drivers/platform/x86/lenovo-wmi-capdata01.c | 136 ++++++++++++++++++++
>>> drivers/platform/x86/lenovo-wmi-capdata01.h | 29 +++++
>>> 5 files changed, 172 insertions(+)
>>> create mode 100644 drivers/platform/x86/lenovo-wmi-capdata01.c
>>> create mode 100644 drivers/platform/x86/lenovo-wmi-capdata01.h
>>>
>>> diff --git a/MAINTAINERS b/MAINTAINERS
>>> index 6dde75922aaf..56ead241a053 100644
>>> --- a/MAINTAINERS
>>> +++ b/MAINTAINERS
>>> @@ -13164,6 +13164,8 @@ L: platform-driver-x86@vger.kernel.org
>>> S: Maintained
>>> F: Documentation/wmi/devices/lenovo-wmi-gamezone.rst
>>> F: Documentation/wmi/devices/lenovo-wmi-other.rst
>>> +F: drivers/platform/x86/lenovo-wmi-capdata01.c
>>> +F: drivers/platform/x86/lenovo-wmi-capdata01.h
>>> F: drivers/platform/x86/lenovo-wmi-events.c
>>> F: drivers/platform/x86/lenovo-wmi-events.h
>>> F: drivers/platform/x86/lenovo-wmi-helpers.c
>>> diff --git a/drivers/platform/x86/Kconfig b/drivers/platform/x86/Kconfig
>>> index 13b8f4ac5dc5..64663667f0cb 100644
>>> --- a/drivers/platform/x86/Kconfig
>>> +++ b/drivers/platform/x86/Kconfig
>>> @@ -467,6 +467,10 @@ config LENOVO_WMI_HELPERS
>>> tristate
>>> depends on ACPI_WMI
>>>
>>> +config LENOVO_WMI_DATA01
>>> + tristate
>>> + depends on ACPI_WMI
>>> +
>>> config IDEAPAD_LAPTOP
>>> tristate "Lenovo IdeaPad Laptop Extras"
>>> depends on ACPI
>>> diff --git a/drivers/platform/x86/Makefile b/drivers/platform/x86/Makefile
>>> index fc039839286a..7a35c77221b7 100644
>>> --- a/drivers/platform/x86/Makefile
>>> +++ b/drivers/platform/x86/Makefile
>>> @@ -69,6 +69,7 @@ obj-$(CONFIG_THINKPAD_LMI) += think-lmi.o
>>> obj-$(CONFIG_YOGABOOK) += lenovo-yogabook.o
>>> obj-$(CONFIG_YT2_1380) += lenovo-yoga-tab2-pro-1380-fastcharger.o
>>> obj-$(CONFIG_LENOVO_WMI_CAMERA) += lenovo-wmi-camera.o
>>> +obj-$(CONFIG_LENOVO_WMI_DATA01) += lenovo-wmi-capdata01.o
>>> obj-$(CONFIG_LENOVO_WMI_EVENTS) += lenovo-wmi-events.o
>>> obj-$(CONFIG_LENOVO_WMI_HELPERS) += lenovo-wmi-helpers.o
>>>
>>> diff --git a/drivers/platform/x86/lenovo-wmi-capdata01.c b/drivers/platform/x86/lenovo-wmi-capdata01.c
>>> new file mode 100644
>>> index 000000000000..b6876611ffd9
>>> --- /dev/null
>>> +++ b/drivers/platform/x86/lenovo-wmi-capdata01.c
>>> @@ -0,0 +1,136 @@
>>> +// SPDX-License-Identifier: GPL-2.0-or-later
>>> +/*
>>> + * LENOVO_CAPABILITY_DATA_01 WMI data block driver. This interface provides
>>> + * information on tunable attributes used by the "Other Mode" WMI interface,
>>> + * including if it is supported by the hardware, the default_value, max_value,
>>> + * min_value, and step increment.
>>> + *
>>> + * Copyright(C) 2025 Derek J. Clark <derekjohn.clark@gmail.com>
>>> + */
>>> +
>>> +#include <linux/cleanup.h>
>>> +#include <linux/component.h>
>>> +#include <linux/container_of.h>
>>> +#include <linux/device.h>
>>> +#include <linux/gfp_types.h>
>>> +#include <linux/types.h>
>>> +#include <linux/wmi.h>
>>> +#include "lenovo-wmi-capdata01.h"
>> Hi,
>>
>> please also include linux/acpi.h, linux/export.h and linux/module.h.
>>
>>> +
>>> +/* Interface GUIDs */
>>> +#define LENOVO_CAPABILITY_DATA_01_GUID "7A8F5407-CB67-4D6E-B547-39B3BE018154"
>>> +
>>> +struct lwmi_cd01_priv {
>>> + struct wmi_device *wdev;
>>> +};
>>> +
>>> +/*
>> /* -> /**
>>
>>> + * lenovo_cd01_component_bind() - On master bind, caches all capability data on
>>> + * the master device.
>>> + * @cd01_dev: Pointer to the capability data 01 parent device.
>>> + * @om_dev: Pointer to the other mode parent device.
>>> + * @data: capdata01_list object pointer to return the capability data with.
>>> + *
>>> + * Returns: 0, or an error.
>>> + */
>>> +static int lenovo_cd01_component_bind(struct device *cd01_dev,
>>> + struct device *om_dev, void *data)
>>> +{
>>> + struct lwmi_cd01_priv *priv = dev_get_drvdata(cd01_dev);
>>> + int count, idx;
>>> +
>>> + if (!priv)
>>> + return -ENODEV;
>> This check is unnecessary, please drop.
>>
> Acked
>
>>> +
>>> + count = wmidev_instance_count(priv->wdev);
>>> +
>>> + if (count == 0)
>>> + return -EINVAL;
>> The WMI driver core already ensures that WMI devices with 0 instances are
>> rejected. Please drop this check.
>>
> Good to know, thanks.
>
>>> +
>>> + ((struct cd01_list *)data)->count = count;
>>> + ((struct cd01_list *)data)->data = devm_kmalloc_array(om_dev, count,
>>> + sizeof(struct capdata01 *),
>>> + GFP_KERNEL);
>> Two things:
>>
>> - using a local variable with a type of struct cd01_list * results in cleaner source code here
>>
>> - using devres is not possible inside the component callbacks, since the lifetime of the component
>> device is not necessarily tied to the lifetime of the underlying device.
>>
>> I suggest you move the whole WMI data querying into lwmi_cd01_probe(), because then you can keep using
>> devres.
>>
> Doing this in probe() puts the list on lwmi_cd01_priv. Should I copy
> that data on bind, or pass back a pointer to the cd01 device struct
> and use an exported function on cd01 and dev_get_drvdata to access
> priv->list->data[idx] when needed? I prefer the latter as this avoids
> needing to do devm memory allocation in component/master binds, then I
> can check for NULL when accessing and clear the pointer on
> master_unbind to avoid calling to a removed device driver.
Passing a pointer is OK, but please only pass a pointer to the struct cd01_list itself,
not the full cd01 device struct. Maybe you can also add a comment explaining that this
pointer will become invalid when unbinding from the component.
Explicitly NULL-ing this pointer upon unbinding seems unnecessary to me.
> (snip)
>
>>> +struct cd01_list {
>>> + struct capdata01 **data;
>>> + int count;
>>> +};
>> In order to save memory you could try something like this:
>>
>> struct cd01_list {
>> size_t count;
>> struct capdata01 data[];
>> };
>>
>> This way you
>>
>> 1. Avoid the memory fragmentation resulting from multiple memory allocations.
>>
>> 2. Omit two pointers when accessing the data.
>>
>> You can use struct_size() from linux/overflow.h to calculate the size of such
>> an array with a trailing flexible array.
>>
>> Thanks,
>> Armin Wolf
>>
> I think I have this part working in my branch. Using devm_kzalloc also
> allows me to omit manually setting NULL in a few cases, which is
> cleaner. Is it preferred to use struct_size() directly in the
> devm_kzalloc call, or create a separate `size` variable to set the
> result to and pass that into the function?
>
> - Derek
>
In most cases using struct_size() directly inside the devm_kzalloc() call is preferred.
Thanks,
Armin Wolf
>>> +
>>> +int lwmi_cd01_match(struct device *dev, void *data);
>>> +
>>> +#endif /* !_LENOVO_WMI_CAPDATA01_H_ */
next prev parent reply other threads:[~2025-04-03 1:40 UTC|newest]
Thread overview: 49+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-03-17 14:43 [PATCH v4 0/6 RESEND] platform/x86: Add Lenovo Gaming Series WMI Drivers Derek J. Clark
2025-03-17 14:43 ` [PATCH v4 1/6 RESEND] platform/x86: Add lenovo-wmi-* driver Documentation Derek J. Clark
2025-03-18 4:24 ` Mario Limonciello
2025-03-19 2:48 ` Derek J. Clark
2025-03-19 4:41 ` Bagas Sanjaya
2025-03-19 4:50 ` Derek J. Clark
2025-03-27 0:26 ` Armin Wolf
2025-03-30 4:49 ` Derek John Clark
2025-03-17 14:43 ` [PATCH v4 2/6 RESEND] platform/x86: Add lenovo-wmi-helpers Derek J. Clark
2025-03-18 4:27 ` Mario Limonciello
2025-03-19 2:50 ` Derek J. Clark
2025-03-26 19:45 ` Matthew Schwartz
2025-03-27 0:40 ` Armin Wolf
2025-03-30 4:55 ` Derek John Clark
2025-03-27 12:43 ` Ilpo Järvinen
2025-04-02 21:22 ` Derek John Clark
2025-03-17 14:43 ` [PATCH v4 3/6 RESEND] platform/x86: Add Lenovo WMI Events Driver Derek J. Clark
2025-03-18 4:30 ` Mario Limonciello
2025-03-26 19:47 ` Matthew Schwartz
2025-03-27 1:03 ` Armin Wolf
2025-03-30 4:55 ` Derek John Clark
2025-03-27 12:47 ` Ilpo Järvinen
2025-03-17 14:43 ` [PATCH v4 4/6 RESEND] platform/x86: Add Lenovo Capability Data 01 WMI Driver Derek J. Clark
2025-03-26 19:47 ` Matthew Schwartz
2025-03-27 1:29 ` Armin Wolf
2025-04-02 20:47 ` Derek John Clark
2025-04-03 1:40 ` Armin Wolf [this message]
2025-03-27 12:56 ` Ilpo Järvinen
2025-04-02 21:22 ` Derek John Clark
2025-04-03 1:21 ` Armin Wolf
2025-04-03 11:01 ` Ilpo Järvinen
2025-03-17 14:43 ` [PATCH v4 5/6 RESEND] platform/x86: Add Lenovo Other Mode " Derek J. Clark
2025-03-26 19:48 ` Matthew Schwartz
2025-03-27 3:28 ` Armin Wolf
2025-04-02 22:24 ` Derek John Clark
2025-04-03 1:28 ` Armin Wolf
2025-04-03 11:05 ` Ilpo Järvinen
2025-03-27 13:49 ` Ilpo Järvinen
2025-04-02 21:22 ` Derek John Clark
2025-04-03 10:49 ` Ilpo Järvinen
2025-03-17 14:43 ` [PATCH v4 6/6 RESEND] platform/x86: Add Lenovo Gamezone " Derek J. Clark
2025-03-26 19:48 ` Matthew Schwartz
2025-03-27 3:49 ` Armin Wolf
2025-04-02 20:58 ` Derek John Clark
2025-04-03 1:32 ` Armin Wolf
2025-03-27 13:56 ` Ilpo Järvinen
2025-04-02 21:22 ` Derek John Clark
2025-04-03 10:53 ` Ilpo Järvinen
2025-03-27 3:52 ` [PATCH v4 0/6 RESEND] platform/x86: Add Lenovo Gaming Series WMI Drivers Armin Wolf
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=d5920e7b-2e5e-4958-b7e4-5e1395aa0e24@gmx.de \
--to=w_armin@gmx.de \
--cc=codyit@gmail.com \
--cc=corbet@lwn.net \
--cc=derekjohn.clark@gmail.com \
--cc=hdegoede@redhat.com \
--cc=ilpo.jarvinen@linux.intel.com \
--cc=johnfanv2@gmail.com \
--cc=linux-doc@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=luke@ljones.dev \
--cc=mpearson-lenovo@squebb.ca \
--cc=nijs1@lenovo.com \
--cc=pgriffais@valvesoftware.com \
--cc=platform-driver-x86@vger.kernel.org \
--cc=shaohz1@lenovo.com \
--cc=superm1@kernel.org \
--cc=zhangzx36@lenovo.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®