From: Ming Lei <tom.leiming@gmail.com>
To: Arjan van de Ven <arjan@infradead.org>
Cc: kay.sievers@vrfy.org, greg@kroah.com, cornelia.huck@de.ibm.com,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH] [PATCH/RESEND] driver core: remove polling for driver_probe_done(v4)
Date: Sat, 21 Feb 2009 09:28:34 +0800 [thread overview]
Message-ID: <d82e647a0902201728s5e57f02cs8f8c20567f914717@mail.gmail.com> (raw)
In-Reply-To: <20090220073345.501247f7@infradead.org>
2009/2/20 Arjan van de Ven <arjan@infradead.org>:
> On Fri, 20 Feb 2009 22:17:27 +0800
> tom.leiming@gmail.com wrote:
>
>> From: Ming Lei <tom.leiming@gmail.com>
>>
>> This patch adds a function : driver_wait_probe_done,
>> which waits on condition of probing done to replace
>> polling for driver_probe_done in fs initialization.
>>
>> There is no better way to avoid polling for
>> driver_probe_done _and_ existence of the root device,
>> so we does not replace the driver_probe_done with
>> driver_wait_probe_done in such special case.
>>
>> Removing polling in fs initialization may lead to
>> a faster boot.
>>
>> This patch is against the latest linux-next tree.
>
> you broke it i this revision though
>
>> -int wait_for_device_probe(void)
>> +void driver_wait_probe_done(void)
>> {
>> - /* wait for the known devices to complete their probing */
>> - while (driver_probe_done() != 0)
>> - msleep(100);
>> - async_synchronize_full();
>> - return 0;
>> + pr_debug("%s: probe_count = %d\n", __func__,
>> + atomic_read(&probe_count));
>> + wait_event(probe_waitqueue, atomic_read(&probe_count) == 0);
>
>
> You lost the async_synchronize_full()!
I patch patch-v2.6.29-rc5-next-20090220.gz against v2.6.29-rc5
directly to build
the linux-next tree(it is quicker for me),so I don't know why you add
async_synchronize_full()
in driver core and seems it doesn't matter with driver core.
Would you mind that I resend a patch,which does
async_synchronize_full() after
driver_wait_probe_done() in do_mounts.c or do_mounts_md.c ?
>
>
>> - wait_for_device_probe();
>> + driver_wait_probe_done();
>
> I also don't understand why you rename the function..
> wait_for_device_probe() is not a bad name ;)
> Sounds like a gratuitous change to me.
OK, I will use wait_for_device_probe().
>
>
> --
> Arjan van de Ven Intel Open Source Technology Centre
> For development, discussion and tips for power savings,
> visit http://www.lesswatts.org
>
--
Lei Ming
next prev parent reply other threads:[~2009-02-21 1:28 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-02-20 14:17 tom.leiming
2009-02-20 15:33 ` Arjan van de Ven
2009-02-21 1:28 ` Ming Lei [this message]
2009-02-21 4:29 ` Arjan van de Ven
2009-02-21 8:21 ` Ming Lei
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=d82e647a0902201728s5e57f02cs8f8c20567f914717@mail.gmail.com \
--to=tom.leiming@gmail.com \
--cc=arjan@infradead.org \
--cc=cornelia.huck@de.ibm.com \
--cc=greg@kroah.com \
--cc=kay.sievers@vrfy.org \
--cc=linux-kernel@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®