From: Tony Krowiak <akrowiak@linux.ibm.com>
To: Cornelia Huck <cohuck@redhat.com>
Cc: linux-s390@vger.kernel.org, linux-kernel@vger.kernel.org,
kvm@vger.kernel.org, freude@linux.ibm.com,
borntraeger@de.ibm.com, mjrosato@linux.ibm.com,
pmorel@linux.ibm.com, pasic@linux.ibm.com,
alex.williamson@redhat.com, kwankhede@nvidia.com,
jjherne@linux.ibm.com, fiuczy@linux.ibm.com
Subject: Re: [PATCH v7 05/15] s390/vfio-ap: introduce shadow CRYCB
Date: Tue, 21 Apr 2020 17:39:45 -0400 [thread overview]
Message-ID: <d8df1a4d-5b6a-bb62-558f-1609b5f767df@linux.ibm.com> (raw)
In-Reply-To: <20200416135815.0ec6e0b3.cohuck@redhat.com>
On 4/16/20 7:58 AM, Cornelia Huck wrote:
> On Tue, 7 Apr 2020 15:20:05 -0400
> Tony Krowiak<akrowiak@linux.ibm.com> wrote:
>
>> Let's introduce a shadow copy of the KVM guest's CRYCB and maintain it for
>> the lifespan of the guest. The shadow CRYCB will be used to provide the
>> AP configuration for a KVM guest.
> 'shadow CRYCB' seems to be a bit of a misnomer, as the real CRYCB has a
> different format (for starters, it also contains key wrapping stuff).
> It seems to be more of a 'shadow matrix'.
You make a valid point; however in reality, matrix - as it is used
throughout vfio ap - is a misnomer. The
matrix is actually comprised of the assigned APIDs and APQIs
(i.e., APQNs) and does not include the control domain assignments.
In reality, the APM, AQM and ADM are fields within the AP control
block (APCB) which is embedded within the CRYCB, so a more
accurate name might be 'shadow_apcb'. I think I'll go with that.
>> Signed-off-by: Tony Krowiak<akrowiak@linux.ibm.com>
>> ---
>> drivers/s390/crypto/vfio_ap_ops.c | 31 +++++++++++++++++++++------
>> drivers/s390/crypto/vfio_ap_private.h | 1 +
>> 2 files changed, 25 insertions(+), 7 deletions(-)
>>
>> diff --git a/drivers/s390/crypto/vfio_ap_ops.c b/drivers/s390/crypto/vfio_ap_ops.c
>> index 8ece0d52ff4c..b8b678032ab7 100644
>> --- a/drivers/s390/crypto/vfio_ap_ops.c
>> +++ b/drivers/s390/crypto/vfio_ap_ops.c
>> @@ -280,14 +280,32 @@ static int handle_pqap(struct kvm_vcpu *vcpu)
>> return 0;
>> }
>>
>> +static void vfio_ap_matrix_clear(struct ap_matrix *matrix)
> vfio_ap_matrix_clear_masks()?
Sure, that works.
>
>> +{
>> + bitmap_clear(matrix->apm, 0, AP_DEVICES);
>> + bitmap_clear(matrix->aqm, 0, AP_DOMAINS);
>> + bitmap_clear(matrix->adm, 0, AP_DOMAINS);
>> +}
>> +
>> static void vfio_ap_matrix_init(struct ap_config_info *info,
>> struct ap_matrix *matrix)
>> {
>> + vfio_ap_matrix_clear(matrix);
>> matrix->apm_max = info->apxa ? info->Na : 63;
>> matrix->aqm_max = info->apxa ? info->Nd : 15;
>> matrix->adm_max = info->apxa ? info->Nd : 15;
>> }
>>
>> +static bool vfio_ap_mdev_commit_crycb(struct ap_matrix_mdev *matrix_mdev)
> vfio_ap_mdev_commit_masks()?
Since I am changing the name of shadow_crycb to shadow_apcb,
it probably makes more sense to rename this to
vfio_ap_mdev_commit_apcb().
>
> And it does not seem to return anything? (Maybe it should, to be
> consumed below?)
In patch 7, the check at the beginning of this function (for a CRYCB)
is moved into the vfio_ap_mdev_has_crycb() function, so there is
no need to return anything from this function. I will introduce the
vfio_ap_mdev_has_crycb() function in this patch instead for the
next submission.
>
>> +{
>> + if (matrix_mdev->kvm && matrix_mdev->kvm->arch.crypto.crycbd) {
>> + kvm_arch_crypto_set_masks(matrix_mdev->kvm,
>> + matrix_mdev->shadow_crycb.apm,
>> + matrix_mdev->shadow_crycb.aqm,
>> + matrix_mdev->shadow_crycb.adm);
>> + }
>> +}
>> +
>> static int vfio_ap_mdev_create(struct kobject *kobj, struct mdev_device *mdev)
>> {
>> struct ap_matrix_mdev *matrix_mdev;
>> @@ -303,6 +321,7 @@ static int vfio_ap_mdev_create(struct kobject *kobj, struct mdev_device *mdev)
>>
>> matrix_mdev->mdev = mdev;
>> vfio_ap_matrix_init(&matrix_dev->info, &matrix_mdev->matrix);
>> + vfio_ap_matrix_init(&matrix_dev->info, &matrix_mdev->shadow_crycb);
>> mdev_set_drvdata(mdev, matrix_mdev);
>> matrix_mdev->pqap_hook.hook = handle_pqap;
>> matrix_mdev->pqap_hook.owner = THIS_MODULE;
>> @@ -1126,13 +1145,9 @@ static int vfio_ap_mdev_group_notifier(struct notifier_block *nb,
>> if (ret)
>> return NOTIFY_DONE;
>>
>> - /* If there is no CRYCB pointer, then we can't copy the masks */
>> - if (!matrix_mdev->kvm->arch.crypto.crycbd)
>> - return NOTIFY_DONE;
>> -
>> - kvm_arch_crypto_set_masks(matrix_mdev->kvm, matrix_mdev->matrix.apm,
>> - matrix_mdev->matrix.aqm,
>> - matrix_mdev->matrix.adm);
>> + memcpy(&matrix_mdev->shadow_crycb, &matrix_mdev->matrix,
>> + sizeof(matrix_mdev->shadow_crycb));
>> + vfio_ap_mdev_commit_crycb(matrix_mdev);
> You are changing the return code for !crycb; maybe that's where a good
> return code for vfio_ap_mdev_commit_crycb() would come in handy :)
See my comments above regarding moving the introduction of the
vfio_ap_mdev_has_crycb() function from patch 7 to this patch.
In that case, that function will be called here before committing.
>
>>
>> return NOTIFY_OK;
>> }
>> @@ -1247,6 +1262,8 @@ static void vfio_ap_mdev_release(struct mdev_device *mdev)
>> kvm_put_kvm(matrix_mdev->kvm);
>> matrix_mdev->kvm = NULL;
>> }
>> +
>> + vfio_ap_matrix_clear(&matrix_mdev->shadow_crycb);
>> mutex_unlock(&matrix_dev->lock);
>>
>> vfio_unregister_notifier(mdev_dev(mdev), VFIO_IOMMU_NOTIFY,
>> diff --git a/drivers/s390/crypto/vfio_ap_private.h b/drivers/s390/crypto/vfio_ap_private.h
>> index 4b6e144bab17..87cc270c3212 100644
>> --- a/drivers/s390/crypto/vfio_ap_private.h
>> +++ b/drivers/s390/crypto/vfio_ap_private.h
>> @@ -83,6 +83,7 @@ struct ap_matrix {
>> struct ap_matrix_mdev {
>> struct list_head node;
>> struct ap_matrix matrix;
>> + struct ap_matrix shadow_crycb;
> I think shadow_matrix would be a better name.
Changing to shadow_apcb as per comments above.
>
>> struct notifier_block group_notifier;
>> struct notifier_block iommu_notifier;
>> struct kvm *kvm;
next prev parent reply other threads:[~2020-04-21 21:39 UTC|newest]
Thread overview: 64+ messages / expand[flat|nested] mbox.gz Atom feed top
2020-04-07 19:20 [PATCH v7 00/15] s390/vfio-ap: dynamic configuration support Tony Krowiak
2020-04-07 19:20 ` [PATCH v7 01/15] s390/vfio-ap: store queue struct in hash table for quick access Tony Krowiak
2020-04-08 10:48 ` Cornelia Huck
2020-04-08 15:38 ` Tony Krowiak
2020-04-08 16:27 ` Cornelia Huck
2020-04-08 16:34 ` Tony Krowiak
2020-04-24 3:57 ` Halil Pasic
2020-04-27 13:05 ` Harald Freudenberger
2020-04-27 15:17 ` Halil Pasic
2020-04-27 21:48 ` Tony Krowiak
2020-04-28 10:07 ` Halil Pasic
2020-04-28 10:57 ` Harald Freudenberger
2020-04-28 22:30 ` Tony Krowiak
2020-04-29 7:56 ` Harald Freudenberger
2020-04-29 11:30 ` Halil Pasic
2020-04-28 10:46 ` Harald Freudenberger
2020-04-07 19:20 ` [PATCH v7 02/15] s390/vfio-ap: manage link between queue struct and matrix mdev Tony Krowiak
2020-04-09 15:06 ` Cornelia Huck
2020-04-10 15:32 ` Tony Krowiak
2020-04-10 15:41 ` Tony Krowiak
2020-04-07 19:20 ` [PATCH v7 03/15] s390/zcrypt: driver callback to indicate resource in use Tony Krowiak
2020-04-14 12:08 ` Cornelia Huck
2020-04-15 17:10 ` Tony Krowiak
2020-04-16 10:05 ` Cornelia Huck
2020-04-16 14:35 ` Tony Krowiak
2020-04-14 12:58 ` Cornelia Huck
2020-04-15 6:08 ` Harald Freudenberger
2020-04-16 9:33 ` Cornelia Huck
2020-04-17 13:54 ` Harald Freudenberger
2020-04-15 17:10 ` Tony Krowiak
2020-04-16 9:37 ` Cornelia Huck
2020-04-24 3:33 ` Halil Pasic
2020-04-24 17:07 ` Tony Krowiak
2020-04-24 18:23 ` Halil Pasic
2020-04-27 21:36 ` Tony Krowiak
2020-04-27 8:20 ` Pierre Morel
2020-04-27 22:24 ` Tony Krowiak
2020-04-28 8:09 ` Pierre Morel
2020-04-28 11:07 ` Harald Freudenberger
2020-04-28 14:37 ` Tony Krowiak
2020-04-07 19:20 ` [PATCH v7 04/15] s390/vfio-ap: implement in-use callback for vfio_ap driver Tony Krowiak
2020-04-16 11:18 ` Cornelia Huck
2020-04-16 14:45 ` Tony Krowiak
2020-04-17 11:23 ` Pierre Morel
2020-04-24 3:13 ` Halil Pasic
2020-04-24 16:58 ` Tony Krowiak
2020-04-07 19:20 ` [PATCH v7 05/15] s390/vfio-ap: introduce shadow CRYCB Tony Krowiak
2020-04-16 11:58 ` Cornelia Huck
2020-04-21 21:39 ` Tony Krowiak [this message]
2020-04-07 19:20 ` [PATCH v7 06/15] s390/vfio-ap: sysfs attribute to display the guest CRYCB Tony Krowiak
2020-04-08 10:33 ` Cornelia Huck
2020-04-08 16:38 ` Tony Krowiak
2020-04-08 16:46 ` Cornelia Huck
2020-04-09 14:18 ` Tony Krowiak
2020-04-07 19:20 ` [PATCH v7 07/15] s390/vfio-ap: filter CRYCB bits for unavailable queue devices Tony Krowiak
2020-04-07 19:20 ` [PATCH v7 08/15] s390/vfio_ap: add qlink from ap_matrix_mdev struct to vfio_ap_queue struct Tony Krowiak
2020-04-07 19:20 ` [PATCH v7 09/15] s390/vfio-ap: allow assignment of unavailable AP queues to mdev device Tony Krowiak
2020-04-07 19:20 ` [PATCH v7 10/15] s390/vfio-ap: allow configuration of matrix mdev in use by a KVM guest Tony Krowiak
2020-04-07 19:20 ` [PATCH v7 11/15] s390/vfio-ap: allow hot plug/unplug of AP resources using mdev device Tony Krowiak
2020-04-07 19:20 ` [PATCH v7 12/15] s390/zcrypt: Notify driver on config changed and scan complete callbacks Tony Krowiak
2020-04-07 19:20 ` [PATCH v7 13/15] s390/vfio-ap: handle host AP config change notification Tony Krowiak
2020-04-07 19:20 ` [PATCH v7 14/15] s390/vfio-ap: handle AP bus scan completed notification Tony Krowiak
2020-04-07 19:20 ` [PATCH v7 15/15] s390/vfio-ap: handle probe/remove not due to host AP config changes Tony Krowiak
2020-05-07 15:03 ` [PATCH v7 03/15] s390/zcrypt: driver callback to indicate resource in use Tony Krowiak
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=d8df1a4d-5b6a-bb62-558f-1609b5f767df@linux.ibm.com \
--to=akrowiak@linux.ibm.com \
--cc=alex.williamson@redhat.com \
--cc=borntraeger@de.ibm.com \
--cc=cohuck@redhat.com \
--cc=fiuczy@linux.ibm.com \
--cc=freude@linux.ibm.com \
--cc=jjherne@linux.ibm.com \
--cc=kvm@vger.kernel.org \
--cc=kwankhede@nvidia.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-s390@vger.kernel.org \
--cc=mjrosato@linux.ibm.com \
--cc=pasic@linux.ibm.com \
--cc=pmorel@linux.ibm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome